MR18 JTAG with RPI error pls hlp

I get this error when trying to follow https://openwrt.org/toh/meraki/mr18/jtag#notes

mr18-001Capture
can someone hlp me?

Well I look and tried everything nothing worked getting same error checked GPIO's running on a RPI 2B v1.1

Sorry but I can't help you any further. I used a usb blaster with male / female dupont cables, without soldering. Using the commands given in the guide. Very easy.

Can you give a link to that (USB blaster)?

https://www.ebay.com/sch/i.html?_from=R40&_nkw=usb+blaster+altera&_sacat=0&LH_TitleDesc=0&_sop=15
https://www.amazon.com/s?k=usb+blaster+altera&crid=22DPHK0IPNZY5&sprefix=usb+blaste%2Caps%2C288&ref=nb_sb_ss_ac-o-p_1_10

Connect only
TDI TDO TMS TCK nTRST + 1 GND

Ok I just got my USB blaster, dare I ask how to use it to flash...
Do I use my PC or raspberry?

\o/
Rav

It's the same. RPI if you don't have another serial.
Good luck

Ok I still have problems, seams like its the same problem as before... I dint take a screenshot... so cant say for sure. After checking wires and setup five times I gave up.

I will give it a go again tomorrow.

To test the connections are ok.

  1. Connect serial
  2. Connect jtag
  3. Turn on meraki 18 and check the boot from the serial
  4. From the terminal give the command to stop the boot

    if the boot stops it is OK.
  5. Open another terminal and connect with telnet to opencd
  6. Give the command "resume"
    telnet
    if the boot restarts the connection is ok and you can proceed to flash.

You could check below

I used a Raspberry Pi Zero W, but @vuhuy suggested to other users that were having issues to check proper timings for the specific Raspberry Pi being used

Refer to