Mount USB issue

Hi everyone,

Just mounted USB disk to router (mounted as /home/share),
then also configured SMB (Name = Share, Path = /home/share).

Shared folder can be accessed through "\\share" but it's not the USB disk.
Storage size only 6x MB. By WinSCP, I found it just the internal storage of router not my USB disk.

How to make SMB connect to right disk ?


Attached one more screen cap for reference.

are you sure it's actually mounted ?

share name doesn't have to be same as the mount point \\p00p could be /home/mountpoint

Hi frollic,

Do you means USB disk /dev/sda1 not mounted as /home/share ?

How to mount the USB disk correctly ?

it would appear so, since you say 6MB matches your flash space.

there should be a auto mount check box somewhere.

if you ssh to the router, you can also run the mount command, to see what's mounted.

USB really not mounted. Which steps was missed ?


try unplugging the drive, and plugging it back in.

auto mount might have to be enabled, if the option still exists somwhere.

Try mounting and run -

uci show fstab; grep -e /dev/sda /etc/mtab
1 Like

Hi Everyone,

Finally mounted. I forgot to install ** kmod-fs-ext4**

Thanks everyone !

But have a new question, why couldn't find /home/usb under WinSCP ?

what is /home/usb ?

you wrote /home/share previously ....

yes, just want to change the mount path.

Better roll back to /home/share ?

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

doesn't really mater....

Rolled back to /home/Share, Thanks

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.