Missing DOH from LuCI Services tab

I've got https-dns-proxy running, and luci-app-https-dns-proxy installed. Everything is working, except that the DoH tab from the Services tab has gone missing. It used to be there. I've tried removing and reinstalling luci-app-https-dns-proxy but it didn't make a difference. Also tried logging in and out of LuCI.

Any suggestions?

1 Like

Does the problem persist after a reboot?

Yes, it persists after a reboot.

It's interesting - if I switch luci themes to argon, I can see the tab but get a 403 error when I click on it.

Which OpenWrt version you are using?
Self built or release?
(And have you upgraded some packages, or are packages still there as they were originally)

Ps. Never heard about "argon" theme. Sounds strange.

19.07.3 -- all of my luci-compat-depending packages (luci apps for DoH, simple-adblock, vpn-policy-routing, etc) have disppeared from the menu. I had to revert to 18.06.8 (due to another issue) shortly and didn't have time to investigate. Will be able to switch back to 19.07.3 partition on Wedneday.

1 Like

I'm using 19.07.2. Yes, I did upgrade some packages because after removing and reinstalling the DoH LuCI app, I noticed there were updates to LuCI itself - and I wondered if inconsistent versions was the cause of the problem. It didn't fix it, but the issue predated the problem so I don't think it's the cause. I am using extroot, don't know if that's connected.

Well maybe it'll go away when I upgrade to 19.07.3 when it is released for the r7500v2.

Are you currently seeing any upgradable LuCI packages, or have you upgraded them already?

I don't see any upgrades for LuCI available.

I can confirm this is an issue. Experienced the same on v19.07.2 when I needed to re-install luci-app-https-dns-proxy. I got back the DoH menu by "upgrading" to v19.07.2 over the same v19.07.2, while keeping the settings, then manually restoring all my packages, including luci-app-https-dns-proxy.

Later on I tried upgrading to the new v19.07.3 on another router without keeping settings, then installed DoH from scratch. No DoH menu. That suggests there might be an issue with some recent versions of luci, but I couldn't find anything suspicious in dmesg and logread output.

1 Like

FYI @jeff47 and @tmomas , since this issue was reported there has been a new update to luci* packages. I've tried it on my router running v19.07.3 and it did solve the problem with luci-app-https-dns-proxy, it's back in the Services menu.

Thanks! It's been OK since I upgraded to 19.07.3 as well.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.