OpenWrt 19.07.3 service release

Great work guys, keep up the good work.

Maybe a glitch.
In a dumbap i want to assign no firewall zone (unspecified) to the lan interface. This worked on my R7800 under 19.07.2 and on my Archer C7 v5 under 19.07.3 but not on my R7800 under 19.07.3.
The option is there but after choosing unspecified and saving the lan interface icon stays green and the zone is still on lan.

Excellent work guys.

I have a problem with the hg556a router the following fix was not added;a=commit;h=af667c73c5d

Indeed, the fix came too late for 19.07.3, see

1 Like

keep up the good work. i have successfully updated my wndr4300 to the 19.07.03. i'm not sure why a couple of my luci status drop down show error. i don't recall getting error with 18.06. or am i doing something wrong or missing packages?

Routes status shows:

Updated 4 installations... one device failed during flashing, but once recovered (tftp), all is working well.

  • Ubiquiti RouterStation Pro (ath79, squashfs) - successful. This is my VPN endpoint on my network, uses extroot and a bunch of packages. Everything working perfectly.

  • TP-Link TL-WR902AC (ar71xx, squashfs) - FAILED TO FLASH. Another user experiencing a similar issue here, and I have had this problem for all sysupgrade images on 19.07.x. This the travel router I use to connect back to my home VPN, uses extroot and a bunch of packages. Required tftp recovery, but after that it appears to be working well.

  • VirtualBox VM (x86, ext4) - successful. This is just a VM to use as a dev system.

  • Linksys E3000 (brcm47xx, squashfs) - successful. I don't wifi and this is basically just a hardware based OpenWrt dev box (sometimes I'll use it to try to replicate other users' issues with packages, VLAN configurations, etc.)


Thanks for all the hard work!

I couldn't upgrade my GL.iNet GL-B1300 (soft-bricked, rolled back to v19.07.2 via TFTP). Updated: the issue with GL.iNet GL-B1300 has now been resolved.

I've successfully upgraded Ubiquiti Edgerouter X (via sysupgrade), GL-MT300N-V2 (sysupgrade), TP-Link TL-WR902AC (sysupgrade failed, TFTP recovery worked).

On all my v19.07.3 devices I'm having an issues with luci-app-https-dns-proxy where it doesn't show up in Services menu, same as a few other folks in that thread. This was also an issue on v19.07.2 if I manually upgraded luci-app-https-dns-proxy. Updated: also resolved.

TP-Link Archer C2600 here..
successful sysupgrade (keeping settings) from 19.07.2 => 19.07.3
Just over a day uptime, all working well!

Grate work people! :beers::beers:


One question, why there is no firmware 19.07.3 for D-Link DAP-2610? It's a supported model.

Thanks everyone!!!

Support for DAP-2610 exists only in master. It has not been backported to 19.07.

One problem with my upgrade: the 2.4 GHz radio failed to start. 5.0 was fine. All settings transferred. That said I am just using as a dumb AP. I am using a TP-Link C2600 and had upgraded from 19.07.2. Downgraded back to 19.07.2 and the 2.4 GHz radio is working.

Thanks @tmomas for your anwer.

Second question, any idea (more or less) when will be backported to 19.07?

Basic answer is: never

Devices are pretty rarely backported to already released stable release branches.

The new device will then be in the forthcoming 20.0x release, when it gets done later this year.

If some developer gets interested in the device and the needed changes are minimal, the support might be backported to 19.07, but that would be more like an exception that the default behaviour.


Thanks @hnyman for clarifying my doubts.

Easy amigo...

Thank you all. I updated my Linksys wrt3200acm and got everything back up and running normally in minutes.

Nice! My contribution made it to the release notes page :grin:
Amazing work all around!


I think it should be re released with a newer bugless luci, one without the log out login issue

Upgraded my C7 V5 and my NBG6617.without a problem. Thank you.
btw when I can't log into LuCI after IP address changes I visit the logout page first.

No such problem with my C7 V5