Mikrotik map lite ver2 no wifi

I can netboot 19.07.1 and install using the files linked below. But there is no wifi. I tried installing the ath10k mods, but this did not help. There is no wifi in luci and nothing in /etc/config/wireless

Any ideas?


I was able to restore RouterOS by writing the backup made of MTD5 to the firmware partition from the openwrt initramfs. Everything seems to work except the wifi...

mtd -r write mtd5-backup.bin firmware

this restoration, with the backup from the mtd backup, made in the network booted ram image, also restored the license and everything back to normal operation. Hopefully someone has suggestions about getting the mAP lite working with wifi

I was able to build for the ath79 board, and the firmware boots, but I get the following error messages:

[    7.884964] ath9k 18100000.wmac: Direct firmware load for ath9k-eeprom-ahb-18100000.wmac.bin failed with error -2
[    7.895611] ath9k 18100000.wmac: Falling back to syfs fallback for: ath9k-eeprom-ahb-18100000.wmac.bin
[    7.948449] urngd: v1.0.2 started.
[    8.191976] firmware ath9k-eeprom-ahb-18100000.wmac.bin: firmware_loading_store: map pages failed
[    8.201983] ath: phy0: Unable to load EEPROM file ath9k-eeprom-ahb-18100000.wmac.bin
[    8.210046] ath9k 18100000.wmac: failed to initialize device
[    8.215968] ath9k: probe of 18100000.wmac failed with error -22

I also post the dts file I made which used the one for the wAP G-5HacT2HnD as a template, in case anyone who knows better can look at it or wants to try themselves:

Few months later, but some feedback from my recent adventure in getting ath79 on the routerboard-wap-g-52shpacn self building an image. I do not have a RBmAP2nD, but might pick one up if this adventure in porting is proving fruitful.

based on some assumptions without having the device:

  1. spec sheets say it only has a qca9531, which im guesing means your DTS pcie definition is not needed as it'll leverage wmac. but that's not the problem with your error message.
  2. the error message you point to is the fact it can't load the caldata generated by 10-ath9k-eeprom's caldata_from_file. By default, 10-ath9k-eeprom looks at 0x1000 for 0x440. It seems the mikrotiks i've tinkered with start at 0x5000 for 0x844. You can confirm this with hexdump -x /sys/firmware/mikrotik/hard_config/wlan_data. Try modifying those address ranges and see if it falls back to the file successfully now. you may need to remove/modify the mac patching in there as well.

As it turns out the latest release build in ar71xx is working:

I tried your suggestions but did not succeed. It would be good going forward to get the map lite in the ath79 tree, but having a working release build is probably enough for most people

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.