Mi Router 4A Gigabit extremely slow

Refer to the Debricking instructions to revert to stock firmware. Ensure you use the correct chinese v2.x, or Global firmware v3.x for your 4A. They are not interchangeable.

Ok, this thing is driving me crazy..i've spent more than 10 more hours..in order to go back to the official stock global firmware. After many tries, i found out only the TinyPXE with the CHINESE firmware works... i got back to the stock but chinese firmware and everything worked again. Now i tried to go from the chinese firmware to the global which my router came with...i tried with TinyPXE AND the Official Xiaomi - 3.0.24 - in English i found here but they cannot work..so i have to unbrick again with the chinese....
Why this is happening? my router came with english firmware and as i can recall it was 3.0.X version, so probably the version i try to put back..

Does the label attached to the underside of the 4A have any chinese characters in it, or is it all in English?

Its all english.. Also when i first received it everything was english..

I tried to go straight to english stock with TinyPXE unbrick tool, and with OpenwrtInvasion..both failed..

Wait..so, in other words...anyone who put openwrt and want to go back to global stock OR bricked it during openwrtInvation can NOT go back to english firmware??
So what is the second option here about?

@bill888 stated this upfront...

i didnt understand that the word interchangeable meant you cannot go back, i thought it was like, you have to choose one or another. On the other hand, i had tried plenty of times the global unbrick, but it couldnt work...the chinese worked immediately (and i saw other people also).

Anyway...what my options now?

edit: also, any opinion on this? https://admin.halimjr.com/r4a-gigabit-global-firmware/

1 Like

Does the label on the underside of your 4A quote 'Gigabit' or 'Giga' version? (Mine is the earlier 'Giga' Global international edition which I understand may be a modified chinese version shipped with v2.x english firmware which I was able to upgrade to v3.0.x global firmware)

In the past, I have read on Mi forums where some 4A owners have flashed their Global 4A with chinese firmware, and discovered they could not return to Global international firmware.

Its Model: R4A
and with bold: Xiaomi Router 4A Gigabit Edition

Did you see the last link i posted? It supposed to do this exact thing (through the GUI)

Apart from slight differences in batch file names, the procedure is same as documented by OlegLOM.

I wonder whether the v2.28.132 firmware on the Turkish website may be identical to the 'upgrade_2to3.bin' posted by OlegLOM? Update: The files are same size but are NOT identical when I perform a binary comparison.

I see...So the question is: if i brick it with OlegLom/The turkish version...can i go back, at least to the Chinese version?

  1. i read somewhere that chinese version is not optimized for the router, so apart from the language (that i can handle with translator, although ugly solution) do i have performance issues?

One observation with both OlegLom/By.TRabZonLu procedures are they also replace the bootloader.

I don't know the answers to your questions about returning to chinese firmware and performance.

I can only suggest you read through the entire turkish thread originally created by By.TRabZonLu.

Ok...after countless hours of trying without luck...finally the solution appeared (Easy way with official tools)....
So, here are the instructions for Xiaomi Mi Router 4A Gigabit Edition with Chinese 2.28 firmware to Global (English) 3.0.24:

  1. From brick to Chinese i used this exact way https://forum.openwrt.org/t/xiaomi-mi-router-4a-gigabit-edition-r4ag-r4a-gigabit-fully-supported-and-flashable-with-openwrtinvasion/36685/678?u=uzer123

  2. After the router is working fine but in Chinese i followed this: https://forum.openwrt.org/t/xiaomi-mi-router-4a-gigabit-edition-r4ag-r4a-gigabit-fully-supported-and-flashable-with-openwrtinvasion/36685/747?u=uzer123 BUT instead of download the Chinese firmware at step 2, i downloaded this (stock Global) https://github.com/acecilia/OpenWRTInvasion/blob/master/firmwares/stock/miwifi_r4a_all_03233_3.0.24_INT.bin
    The router open as i bought it. English Stock.

1 Like

fwiw, I've updated the Openwrt wiki page for the 4A to recommend using Mi Wifi Repair tool.


Nice, I'm happy i'll possibly help other people:)

What is your final conclusion, still SLOW?

My R4A came to me 2-month ago, I tested it using OpenWrt offical build, LAN internet speed is ~920Mbps, WiFi speed is reasonable, almost the same as the stock firmware. tested using SpeedTest website.

I really don't know, because most probably i had to do more settings that i didn't that caused some kind of conflict, for example i know put my stock router/modem to bridge mode.
For sure, openwrt is very difficult for a new user, and although i spend a lot of time, i couldnt find the optimal settings. On the other hand, i found some users saying that stock performance is the same or better cause there are some proprietary optimizations by xiaomi..

Yes. for a single parameter, likes Speed, stock FW maybe always better.
We use openwrt for its many other features/functions.

Yes..I'm sure... unfortunately it didn't work out for me and IVe spend countless hours.. strangely I didn't find many noob friendly video tutorials so I abandoned the idea..

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.