Mi Router 4A Gigabit extremely slow

I followed the https://openwrt.org/toh/xiaomi_mi_router_4 instructions and installed the current release 21.02.1.
After installing without any further settings (only enable wifi), my connection is extremely slow (like wait 30s for a youtube video to load, and speedtest cannot run). I tried both with cabled connection and wifi and both are this slow.
Xiaomi stock firmware was running fine.. What can cause this?

Try this via sysupgrade..

sysupgrade is a command line tool only or i can do that through the openwrt GUI?

GuI firmware upgrade

thnx, and what is the firmware you sent me? older version?

edit: unfortunately the issue doesnt go away..

It was the latest snapshot.

unfortunately it doesnt look to work..and i have spend like 8 hours trying stuff (reinstalling, format etc) i cannot imagine where is the problem..i guess the last option is to test in another house cause my network setup is a bit complicated..

Cam you test the iperf throughout?

i just tried speed test by ookla but it cannot run at all..
i havent tried iperf, but i will..

Is the network connected to the WAN port also 192.168.1.X? In that case you need to change the LAN to a different range to avoid conflict.

i'll take a look on this. Still i'm a bit confused with this openwrt config. LAN is supposed to handle all the local devices (so if you have a raspberry for example with a static ip and this what i usually see in routers' config pages. But what about WAN? isn't it supposed to be the public ip that is not set by the user?

SSH in to the router and run the following...

cat /etc/config/network

cat /etc/config/dhcp

Post the results in preformatted text, by using the icon highlighted in red...

OpenWRT Posting Icons

cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd5d:5ed8:5001::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'


cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

I don't see any DNS entries in the WAN config section.

In LuCI -

Interfaces > WAN > Edit > Advanced Settings

You can do one of two things...

Either check "Use DNS servers advertised by peer", or enter them in the boxes below.

The peer was enabled..I just put custom but nothing changed.. internet is still working but very very slow..

I noticed in the thread title your device is listed as the Mi Router 4A Gigabit, but the link to the installation instructions in your first post is for the Mi 4.

At the very top of that page it explicitly states...

(Do not confuse with Mi Router 4A 100m/Gigabit edition routers)

The same counter-warning is posted on the Mi Router 4A Gigabit page...

It appears you may have installed the wrong firmware....

You are right..i just posted wrong link..
And now i just reinstalled this https://firmware-selector.openwrt.org/?version=21.02.1&target=ramips%2Fmt7621&id=xiaomi_mi-router-4a-gigabit
21.02.1 version. But, this didnt work also...
How i can go to the stock firmware?

Refer to the Debricking instructions to revert to stock firmware. Ensure you use the correct chinese v2.x, or Global firmware v3.x for your 4A. They are not interchangeable.

Ok, this thing is driving me crazy..i've spent more than 10 more hours..in order to go back to the official stock global firmware. After many tries, i found out only the TinyPXE with the CHINESE firmware works... i got back to the stock but chinese firmware and everything worked again. Now i tried to go from the chinese firmware to the global which my router came with...i tried with TinyPXE AND the Official Xiaomi - 3.0.24 - in English i found here but they cannot work..so i have to unbrick again with the chinese....
Why this is happening? my router came with english firmware and as i can recall it was 3.0.X version, so probably the version i try to put back..

Does the label attached to the underside of the 4A have any chinese characters in it, or is it all in English?