Mi Router 4A Gigabit Edition lost power during OpenWRT to Stock ROM migration! Device won't turn on

Hello, I have a Xiaomi Mi Router 4a Gigabit Edition Global version manufactured after the 2nd half of 2021. While converting this device to the original ROM, the device completely crashed! It won't turn on, it doesn't give IP. There are TX-RX-GND-3.3V pins on the motherboard, is there any way to reinstall the operating system with these pins?

How do you know that it won't turn on?
There's no LED on?
You could give it a try and connect the router via a TTL-Serial-To-USB-converter to your PC and see if there's still any output.

See "Debricking" here: https://openwrt.org/inbox/toh/xiaomi/xiaomi_mi_router_4a_gigabit_edition

1 Like

The LEDs are on but it automatically identifies an IP address like There is also no SSID, Ethernet connection answer, etc. How do I connect the TTL-Serial-To-USB-converter to the computer? How do I get a printout?

I'm trying now

I was just wondering...

You mean, your PC gets no IP address from the router?
That's not really a problem at this stage...

I thought so...most probably the firmware isn't complete, so the router won't work as expected.
With some luck at least the boot loader is still working, so that's why you need the serial connection.
How to do this, depends on the OS you're using on your PC.
Don't hesitate to ask if anything isn't clear for you.

I have a MacBook Air and macOS Ventura is Running in it.

Try doing a reset using the RESET button. I forgot the actual steps but it's something like

  1. Remove power from device
  2. Press and hold on the RESET button for at least 15 secs
  3. Plug the power back on while still pressing the RESET button
  4. Keep pressing on the RESET button for another 15secs (make it 20 secs if you want to be sure)
  5. Then release the RESET button

Uh...that's the only system i have absolutely no knowledge of.
Do you already have got a working TTL-serial-to-USB converter?

Because: I don't know which TTL-serial-to-USB converter (to be precise: the chips on it) are best working with your MacBook.
There're converter with chips like Prolific 2303, FTDI 232, CP2102, CH340 and maybe some others i've never read of.
So in this regard you have to ask someone else.
I'm also not aware which terminal program is available on macOS.

If the boot loader is still working you don't need the serial connection.
You will probably need a Windows PC to run the tool(s) mentioned in the debricking recipes.

Just out of curiosity: How can one make sure that the boot loader is working without a serial console to see the output?

behavioural analysis (sorry, was in rush, so will elaborate)
With working bootloader the magic keypress (similar to what was mentioned above) should lead to some activities like bootp/dhcp requests and probably some LED activity.

I solved the problem by using an application with a name like Xiaomi Tool with Debrick management...

1 Like

So would you please mark the topic as solved?
Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.