Mi 4A Gigabit -> Only 1 LAN Port Working

Hello,

I have followed the guide and instruction listed here to flash to Mi 4A Router Gugabit Edition with OpenWRT Firmware -> [OpenWrt Wiki] Xiaomi Mi Router 4A Gigabit Edition

This router has has 2 LAN Ports. But I am only able to use 1 (the first one). When connecting to the other port, LAN isn't working.

My OpenWRT Details,

My Interface Details,

Can anyone help me configure it properly as how to get that second LAN Port working?

Thanks.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
1 Like

Hello,

Thank you for the quick reply,

Here are the output as requested,

cat /etc/config/network

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fdcd:c910:0b59::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username 'yyyyyyyyy'
        option password 'xxxxxx'
        option ipv6 'auto'
        option peerdns '0'
        list dns '94.140.14.14'
        list dns '94.140.15.15'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config device
        option name 'wan'
        option macaddr 'xxxxxx'

cat /etc/config/wireless

I have the Wireless disabled here in this router since I use different access point.

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option band '2g'
        option htmode 'HT20'
        option channel 'auto'
        option cell_density '0'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk-mixed'
        option key 'xxxxx'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option htmode 'VHT80'
        option channel 'auto'
        option cell_density '0'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt_5G'
        option encryption 'psk-mixed'
        option key 'xxxxx'
        option disabled '1'

cat /etc/config/dhcp

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option start '151'
        option limit '45'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name 'Tenda-AP'
        option dns '1'
        option mac 'xxxxxx'
        option ip '192.168.1.10'

config host
        option name 'HP-AIO'
        option dns '1'
        option mac 'xxxxxx'
        option ip '192.168.1.150'

config host
        option name 'VM-Win11-AVS'
        option dns '1'
        option mac 'xxxxx'
        option ip '192.168.1.40'

config host
        option name 'U22-Ubuntu'
        option dns '1'
        option mac 'xxxxx'
        option ip '192.168.1.30'

config host
        option name 'TL-SG108E'
        option dns '1'
        option mac 'xxxxx'
        option ip '192.168.1.5'

config host
        option name 'S1'
        option dns '1'
        option mac 'xxxxx'
        option ip '192.168.1.25'

cat /etc/config/firewall

root@OpenWrt:~# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

Kindly check and assist!!

Thanks.

I don't see any reason that you'd have issues with the 2nd lan port. Does it indicate a physical link when you attempt a connection? You may need to check the cable(s) and also the physical port itself for debris or bent pins, etc.. It is also possible there is physical damage to the circuitry.

1 Like

Hello,

Thanks for your reply.

It is working with Stock Firmware but under OpenWRT there is no Link from this LAN Port 2

Same cable is working fine with LAN Port 1 but won't work with LAN Port 2. I have changed cables but can't get any link on LAN Port 2.

I am not an expert on this, but I wonder if Switching configuration is done alright in my configuration. Talking about Configuration, I didn't have to do anything since everything else is working fine out of the box from on this OpenWRT given firmware except this LAN Port 2.

I am feeling clueless as what is wrong or what should I do :expressionless:

Thanks.

P.S.

Can you please help me on how to reset this router to OpenWRT default (like factory reset)?

The Reset page says,

To reset the firmware to its initial state, click "Perform reset" (only possible with squashfs images).

Do I have that mentioned image? I mean, I flashed the image available here -> [OpenWrt Wiki] Xiaomi Mi Router 4A Gigabit Edition

Is it ok to do reset from this page, with that mentioned image?

Thanks.

My 4AG router, both 2 LAN port working ok, maybe your router hardware has a problem.

Could you back to Xiaomi stock fw, to confirm the hardware?

1 Like

Yes, you can follow the instructions for the reset... the TL;DR is this:

firstboot -y && reboot now

This will reset to defaults. wifi will be disabled, and you'll need to connect via ethernet.

1 Like

Hello,

Thank you for your replies.

Stock Firmware was OK on both ports.

I have done the reset, the 2nd Port is now working.

However my Switch TP-Link Tl-SG108E (Managed 8Port Gigabit Switch) is acting up. Hot swap between both ports of Mi 4A Router isn't working. I don't have any Link aggregation or VLAN type things enabled on this switch. It is acting as a dumb switch but still, removing the cable from Mi 4A LAN Port 1 to LAN Port 2 wont bring any link to the switch.

But primary issue is solved, I have got the Mi 4A router with OpenWRT now working on both LAN Ports.

Thank you guys for your help and suggestions.

This certainly sounds like an issue with that switch and not your Mi 4A with OpenWrt. The way to verify that the Mi 4A is working properly is to use another ethernet device to see if a link is established on each of the LAN ports (and it sounds like you may have already done that). If the result of the test shows that the 4A is okay, you will want to replace that switch.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.