Mesh link between two router

Hello,

I would like to connect two routers via Wi-Fi so that they can communicate with each other and allow my devices to connect throughout my house, which has three floors. I have two routers.

I’ve heard about mesh networking, but I have no idea how it works. Should I use DAWN, uSteer, or mesh11sd?

Which one is the most practical, and which packages do I need to install?

Thank you!

DAWN USTEER - steering clients to closest AP
11S BATMAN WDS- wifi distribution

You need mesh11sd and if you need vlans across you need gretap

1 Like

thanks for response

my /Etc/config/wireless

config wifi-iface 'wifinet3' 
	option device 'radio0'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_id 'mesh'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key 'mypassword'
	option network 'lan'


config wifi-iface 'wifinet4' 
	option device 'radio1'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_id 'mesh'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option key 'mypassword'
	option network 'lan'

my package is mesh11sd and wpad-basic-mbedtls, is right ?

then mesh11sd status is like this

root@OpenWrt:~# mesh11sd status
awk: cmd. line:1: (FILENAME=- FNR=2) fatal: not enough arguments to satisfy format string
        `%s phy1-mesh0'
         ^ ran out for this one
{
  "setup":{
    "version":"4.1.1",
    "enabled":"1",
    "procd_status":"running",
    "portal_detect":"1",
    "portal_detect_threshold":"0",
    "portal_channel":"default",
    "channel_tracking_checkinterval":"30",
    "mesh_basename":"m-11s-",
    "auto_config":"0",
    "auto_mesh_network":"lan",
    "auto_mesh_band":"2g40",
    "auto_mesh_id":"92d490daf46cfe534c56ddd669297e",
    "mesh_gate_enable":"1",
    "mesh_leechmode_enable":"0",
    "mesh_gate_encryption":"0",
awk: cmd. line:1: (FILENAME=- FNR=2) fatal: not enough arguments to satisfy format string
        `%s phy1-mesh0'
         ^ ran out for this one
    "txpower":"",
    "mesh_path_cost":"10",
    "mesh_path_stabilisation":"1",
    "checkinterval":"10",
    "interface_timeout":"10",
    "ssid_suffix_enable":"1",
    "debuglevel":"1"
  },
  "interfaces":{
  }
}
root@OpenWrt:~#

replace that with wpad-mbedtls, not sure it is necessary, i use that for KV

My awk does not squawk like that
What is in your awk -V ?

1 Like
root@OpenWrt:~# awk -V
GNU Awk 5.3.0, API 4.0, PMA Avon 8-g1
Copyright (C) 1989, 1991-2023 Free Software Foundation.

This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 3 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program. If not, see http://www.gnu.org/licenses/.
root@OpenWrt:~#

i have installed now wpad-mbedtls

my config in /etc/config/mesh11sd/

config mesh11sd 'setup'

config mesh11sd 'mesh_params'
	option mesh_fwding '1'
	option mesh_rssi_threshold '-65'
	option mesh_gate_announcements '1'
	option mesh_hwmp_rootmode '4'
	option mesh_hwmp_rann_interval '5000'
	option mesh_hwmp_root_interval '5000'
	option mesh_hwmp_active_path_timeout '5000'
	option mesh_hwmp_active_path_to_root_timeout '6000'
	option mesh_max_peer_links '16'
	option mesh_plink_timeout '10'
	option mesh_connected_to_gate '1'

https://github.com/openNDS/mesh11sd/blob/master/linux_openwrt/mesh11sd/files/etc/config/mesh11sd

it's very not clear for me

OK, restore busybox awk

ln -sf ../../bin/busybox /usr/bin/awk

Maybe command statuses get better

1 Like

seems better

root@OpenWrt:~# mesh11sd status
{
  "setup":{
    "version":"4.1.1",
    "enabled":"1",
    "procd_status":"running",
    "portal_detect":"1",
    "portal_detect_threshold":"0",
    "portal_channel":"default",
    "channel_tracking_checkinterval":"30",
    "mesh_basename":"m-11s-",
    "auto_config":"0",
    "auto_mesh_network":"lan",
    "auto_mesh_band":"2g40",
    "auto_mesh_id":"92d490daf46cfe534c56ddd669297e",
    "mesh_gate_enable":"1",
    "mesh_leechmode_enable":"0",
    "mesh_gate_encryption":"0",
    "txpower":"23",
    "mesh_path_cost":"10",
    "mesh_path_stabilisation":"1",
    "checkinterval":"10",
    "interface_timeout":"10",
    "ssid_suffix_enable":"1",
    "debuglevel":"1"
  },
  "interfaces":{
    "phy1-mesh0":{
      "mesh_retry_timeout":"100",
      "mesh_confirm_timeout":"100",
      "mesh_holding_timeout":"100",
      "mesh_max_peer_links":"32",
      "mesh_max_retries":"3",
      "mesh_ttl":"31",
      "mesh_element_ttl":"31",
      "mesh_auto_open_plinks":"1",
      "mesh_hwmp_max_preq_retries":"4",
      "mesh_path_refresh_time":"1000",
      "mesh_min_discovery_timeout":"100",
      "mesh_hwmp_active_path_timeout":"5000",
      "mesh_hwmp_preq_min_interval":"10",
      "mesh_hwmp_net_diameter_traversal_time":"50",
      "mesh_hwmp_rootmode":"0",
      "mesh_hwmp_rann_interval":"5000",
      "mesh_gate_announcements":"0",
      "mesh_fwding":"1",
      "mesh_sync_offset_max_neighor":"50",
      "mesh_rssi_threshold":"0",
      "mesh_hwmp_active_path_to_root_timeout":"6000",
      "mesh_hwmp_root_interval":"5000",
      "mesh_hwmp_confirmation_interval":"2000",
      "mesh_power_mode":"active",
      "mesh_awake_window":"10",
      "mesh_plink_timeout":"1800",
      "mesh_connected_to_gate":"0",
      "mesh_nolearn":"0",
      "mesh_connected_to_as":"0",
      "interface":"ERROR: mesh interface is unnamed in wireless config"
      "error":" interface must be named to see further status information"
    }
    "phy0-mesh0":{
      "mesh_retry_timeout":"100",
      "mesh_confirm_timeout":"100",
      "mesh_holding_timeout":"100",
      "mesh_max_peer_links":"32",
      "mesh_max_retries":"3",
      "mesh_ttl":"31",
      "mesh_element_ttl":"31",
      "mesh_auto_open_plinks":"1",
      "mesh_hwmp_max_preq_retries":"4",
      "mesh_path_refresh_time":"1000",
      "mesh_min_discovery_timeout":"100",
      "mesh_hwmp_active_path_timeout":"5000",
      "mesh_hwmp_preq_min_interval":"10",
      "mesh_hwmp_net_diameter_traversal_time":"50",
      "mesh_hwmp_rootmode":"0",
      "mesh_hwmp_rann_interval":"5000",
      "mesh_gate_announcements":"0",
      "mesh_fwding":"1",
      "mesh_sync_offset_max_neighor":"50",
      "mesh_rssi_threshold":"0",
      "mesh_hwmp_active_path_to_root_timeout":"6000",
      "mesh_hwmp_root_interval":"5000",
      "mesh_hwmp_confirmation_interval":"2000",
      "mesh_power_mode":"active",
      "mesh_awake_window":"10",
      "mesh_plink_timeout":"1800",
      "mesh_connected_to_gate":"0",
      "mesh_nolearn":"0",
      "mesh_connected_to_as":"0",
      "interface":"ERROR: mesh interface is unnamed in wireless config"
      "error":" interface must be named to see further status information"
    }
  }
}

I think you need some loop prevention protocol is setting up 2 links.
It says something to set interface names (where dim phy0-mesh0 is type mesh2 and mesh5?)

I haven't configured the second router yet, which is probably why it's not working. I'm going to set up the second mesh now.

In any case, you're the only one who managed to resolve this awk error, and I really appreciate it.

Thank you!

i will configure my second router in 20 min i keep informed brada :wink:

I dunno i set up 2 routers with identical parameters and they work since v22...

Your command broke m'y lan

Do you know why ?

Ok i think understand

My first router finish by .1

Ip of second will be .2
In br lan

??

 "interface":"ERROR: mesh interface is unnamed in wireless config"
      "error":" interface must be named to see further status information"

Maybe the problem is adguard

If you need a simple connection between two routers, you can forget the mesh11sd.
All you need is 802.11s mesh that you have already configured in your second post. Do not create two meshes using the same network 'lan' Use wpad-mbedtls which enables 802.11 mesh in wifi radios.

1 Like

first router

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

second router

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.2.2'
	option netmask '255.255.255.0'
	option ip6assign '60'

I mean in /etc/config/wireless only one wifinet can use the option network 'lan*

Okay, I can now see my two mesh points, one on 2.4 GHz and one on 5 GHz, but in the host field, there's a "?".

Is that normal?

ok in second router i disabled lan

Please share the /etc/config/wireless file in both the routers.

A simple question, but should the Mesh ID be the same as the regular 2.4 GHz or 5 GHz Wi-Fi SSID?

For example:

  • openstar2.4 (AP mode)
  • openstar2.4 (Mesh mode)

ok i will share

The mesh id does not need to be the same as the ssid. Very good meshid is 'mesh', 'homemesh', 'mulonesh' ...

1 Like

@Drop
It is good that you started your own thread after hijacking a previous one:

From this it is not clear that you actually want a mesh network.

What do you want to achieve here?

Do you want your user devices to move from one access point to another automatically as you walk around?

1 Like