Meraki MX60: Network not working

Not sure if I'm missing a step or something obvious, but I'm trying to get LEDE working on a Meraki MX60 and it all seems to work fine in terms of booting, but the networking doesn't appear to be working properly.

I followed the instructions at to boot to an initramfs image that I downloaded from

In terms of process:

  • I setup a TFTP server on a laptop and directly connected an Ethernet cable from the laptop NIC to the WAN port on the MX60. I set the IP address of the laptop to
  • I interrupted the boot process and ran the boot commands from the file.
  • The file successfully copied down from the TFTP server on laptop to the MX60 and it booted up
  • I can access the LEDE CLI over serial and it appears to operate OK
  • ifconfig shows the br-lan interface with IP address and also shows the eth0, eth0.1 and eth0.2 interfaces, but none with IP addresses
  • Note; at this point the laptop is still connected to the WAN NIC

If I try and ping from the MX60, it doesn't respond. I've tried connecting the laptop to all interfaces on the MX60 but I get no ping response on any ports. I also tried pinging from the laptop to the MX60 at but get no response.

Am I missing something?

Because there is no network connectivity, I cannot proceed with flashing the MX60 with a more persistent LEDE image, as I cannot copy an image onto the MX60 over the network.

Hey @jvanderson, this should now be fixed as of

For other peoples future reference, to resolve this simply U-boot the latest development build. That seems to work better.

I seem to be having the same issue with my MX60w. I loaded the 17.01.4 and I tried the latest development build with no luck. @riptidewave93 how do apply the fix for this? I'ts not clear to me where or how I apply the fix. Sorry, I'm not familiar with any of this yet.

I'm not familiar with LEDE. The device boots fine to the 17.01.4 file using TFTP. I see exactly the same results as the person who started this thread.

sure, so once you boot into the tftp image, you have the shell, then do
vi /etc/config/network
change lan from eth0.1 to eth0
change wan from eth0.2 to eth1
change wan6 from eth0.2 to eth1

then go to bottom and there is 3 seconds of switch0 stuff,
just delete all 3 switch/vlan sections, then save and exit vi,

after that type /etc/init.d/network restart
then you should be able to communicate through the network to the box

Courtesy : @alphaz18

I finally managed to get the MX60W flashed, using the MX60 sysupgrade TAR. All BIN files make the ports WAN - tagged with VLAN 2. I used a second device to tag LAN as VLAN 2 and through UART used iptables to allow LuCI on the Meraki's WAN IP:

iptables -I INPUT -d -p tcp --dport 80 -j ACCEPT

I proceed to download/install the recovery and flash the MX60 sysupgrade. I then installed kmod-ath9k and rebooted.

See this page, there's a major documentation issue regarding the MX60's:

The reset button on boot also tries to tftp another image, the Uboot environment needs to be corrected as well.