[SOLVED] No IP or LuCI on Meraki MX60W

Hello all,

I have a Meraki MX60W, and I have followed the steps at: https://github.com/riptidewave93/LEDE-MX60-MX60W/blob/master/README.md#flashing

I have successfully booted the machine and rearranged the partitions.

I was then going to proceed to create the recovery partition. I noticed that cannot reach LuCI, nor do I see any traffic on the ports on the device. So, at this time, I am unable to access the device via Ethernet once OpenWRT boots.

Any ideas?

Does SSH work?

Trunk builds do not include LuCI.

Trunk??? I never said I installed trunk, I'm attempting to install 17.01.4.

I cannot reach 192.168.1.1.

root@LEDE:/# ifconfig 
br-lan    Link encap:Ethernet  HWaddr 00:18:0A:xx:xx:xx  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fd33:f453:91b6::1/60 Scope:Global
          inet6 addr: fe80::218:aff:fe37:6f20/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:2210 (2.1 KiB)

eth0      Link encap:Ethernet  HWaddr 00:18:0A:xx:xx:xx  
          inet6 addr: fe80::218:aff:fe37:6f20/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:66 errors:0 dropped:0 overruns:0 frame:0
          TX packets:414 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:12293 (12.0 KiB)  TX bytes:132706 (129.5 KiB)
          Interrupt:39 

eth0.1    Link encap:Ethernet  HWaddr 00:18:0A:xx:xx:xx  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:2210 (2.1 KiB)

eth0.2    Link encap:Ethernet  HWaddr 00:18:0A:xx:xx:xx  
          inet6 addr: fe80::218:aff:fe37:6f20/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:385 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:126527 (123.5 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:864 errors:0 dropped:0 overruns:0 frame:0
          TX packets:864 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:56272 (54.9 KiB)  TX bytes:56272 (54.9 KiB)

I'm running off the TFTP image; but I cannot flash, because I have no Ethernet access.

It looks like the switch is misconfigured, as packets are being received by eth0 but not transferred to eth0.1 or eth0.2. This means they are reaching the CPU port without a VLAN tag of 1 or 2, or without a VLAN tag at all.

Post your /etc/config/network.

I ran Wireshark, all ports are making DHCP request with VLAN tag 2...
:thinking:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc3:223e:a292::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '4 3 2 1 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

Unplug all Ethernet cables and run swconfig dev switch0 show. The only port that should show connected would be the CPU. And it should be port 0. Then plug in a cable to one port at a time and identify them.

root@LEDE:/# swconfig dev switch0 show
/bin/ash: swconfig: not found

Well that is a problem since UCI scripts use swconfig to configure the switch.

WHOA!!!!

Do you think that the builds fail to include swconfig?

The only thing I try to test is use another device and tag LAN as VLAN 2....and install swconfig.

Yes if you can get in and out on a VLAN however the switch is running now.

Or you could try to bring up wifi.

Once you can get software in, might be best to sysupgrade right to the release build, which ought to work.

This is 17.01.4!

...and there's no /etc/config/wireless!!!

Yes but it's an initramdisk build-- of uncertain configuration.

Do you have iw? Does iw list show an active wifi driver?

Actually, if the switch is running in an 'unmanaged' mode(*), you should just be able to change lan to eth0, and detach wan from eth entirely, and have untagged LAN packets on all the ports.

*which is the power-up default of most switch chips, so someone can build an unmanaged switch by putting the chip in a box with no brains at all.

no IW...
I now have LuCI. I'm attempting to flash the sysupgrade:

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

I've tried 17.01.4 and 17.01.3...

UPDATE: I have managed to flash and boot the recovery image, but once again, all ports are tagged with VLAN 2.

Also, I cannot install swconfig:


Collected errors:
 * verify_pkg_installable: Only have 0kb available on filesystem /overlay, pkg kmod-swconfig needs 1
 * opkg_install_cmd: Cannot install package kmod-swconfig.

I was able to flash the MX60 sysupgrade, but NOT MX60W.

All TFTP files appear to have ports tagged as VLAN 2...this means you have open the cover to enter an iptables rule to access LuCI to flash...and a device with more than one port and capable of tagging...I'm exploring further.