[MedionNAS] installation and recovery

Im very new to this. I have some Linux experience. I install 17.01.4 onto a Medion NAS it boots and works. The GUI and SSH work. I can create a share but only within the few megs of / the 1.4tb unavailable. I cant mount or share it.

First if all, version 17 is quite old, I would consider upgrading first. Second, I think you should post more info about how you configured your system exactly and how you are testing it.

1 Like

Thanks for replying. Im new to this, what is the best site to download the latest version and instructions to upgrade.

See https://openwrt.org/toh/medion/md86587

1 Like

Thanks. That command line refers to 17.01.4 Im feeling out of my depth at the moment. Is there a way through the browser?

The table at https://openwrt.org/toh/medion/md86587#installation points to 19.07.2.
The instructions might be outdated regarding the OpenWrt version.

I know I am asking dumb questions but once I have downloaded http://downloads.openwrt.org/releases/19.07.2/targets/oxnas/ox820/openwrt-19.07.2-oxnas-ox820-mitrastar_stg-212-squashfs-sysupgrade.tar what do I do with it?

Thanks Eric

I now have a brick. Instructions seem to refer to "how to" version 17 nothing about 19. Hard find correct files. It wont ping, is not on the DHCP. Can the drives be imaged?

I really need assistance please. I have a serial cable and can see the device start but not boot. Is there a way to save this. I have another one but don't want to destroy it. version 17 work but attempting to install 19 bricked it.

providing an exact log / capture of

  • the steps you performed
  • your current environment / bootlog

would help...

without that... you have to wait and hope someone who has the device, if this happens, they will also likely require this information

will you update the wiki if we can solve your problem? i'm not allowed, so it might encourage others if your committed to clearing up the documents.

1 Like

It's almost impossible to brick an oxnas box, as it can boot from harddisk, before it touches the flash.
Here you can find tools to use a spare disk to restore the original firmware in flash.


Thanks for your message. This is all I can get from the serial.

Stage-1 Bootloader Thu Nov 24 19:20:59 CST 2011
Attempting to set PLLA to 750MHz ...
  plla_ctrl0 : 0x0000000A
  plla_ctrl1 : 0x000F0000
  plla_ctrl2 : 0x001D01A0
  plla_ctrl3 : 0x00000017

Setup memory, testing, Image 0
  Hdr len: 0x0001A94C
  Hdr CRC: 0xF0019DAC

U-Boot 1.1.2 (Jun 24 2011 - 09:41:57)

U-Boot code: 60D00000 -> 60D1A94C  BSS: -> 60D1F004
RAM Configuration:
	Bank #0: 60000000 128 MB
SRAM Configuration:
	64KB at 0x50000000
NAND:128 MiB
In:    serial
Out:   serial
Err:   serial
Setting Linux mem= boot arg value
Hit any key to stop autoboot:  2  1  0 

NAND read: device 0 offset 0x440000, size 0x90000
 589824 bytes read: OK
## Starting application at 0x64000000 ...

Yes, looks like it had no OS...but can you tell us what did you do before it was bricked???

To be honest I don't remember the exact steps, I attempted to install version 19.7 but the instructions were for 17 so tried to find and substitute the files. The Medion 86407 stopped responding for a long time so I switched it off and back on. From then on it was off line, it would not communicate over the LAN and did not request an IP address. I have tried a HDD from a working unit without success. I can communicate with it using serial cable.


Thanks I am still trying to get a handle on this.

load_nand=nboot 61000000 0 440000
boot=bootm 61000000
boot_nand=run load_nand boot
VENDOR_NAME=MitraStar Technology Corp.
boot_stage2=nand read 0x64000000 0x440000 0x90000 ; go 64000000
bootcmd=run boot_stage2
bootargs= console=ttyS0,115200 elevator=cfq mac_adr=0x00,0x30,0xe0,0x00,0x00,0x01 mem=128M poweroutage=yes

Environment size: 541/131068 bytes

now.. i don't have your device... nor the patience/specific knowledge to dig too much into what you've done...

but on a superficial glance... my guess is that you've written the wrong / mismatched / incorrectly / oversized? data to your partition/s (likely kernel)...

therefore it makes sense for you to re-do the instructions for 17 ( what worked )... in order to remedy having "known good / booting" data on those partitions... ( for an advanced user, there are uboot commands that might allow you to inspect what is residing where your kernel is expected to be... but at your skill level, i don't think that is worth your time / effort / risk )

the other thing to do is get a spare hard disk and follow up on @Mijzelf 's advice and get the thing booting from a hard disk.

I have an identical NAS that is untouched at the moment. I also have Debian installed on a netbook. Last night I followed this and seem to have my brick doing a bit more. I guess I need to get 17 back on it now. I have OX820 # prompt and am getting more options from the "help" command. I dont know how to get 17 on can I use TFTP?

dd if=openwrt-oxnas-ox820-u-boot.bin bs=64k of=openwrt-oxnas-ox820-u-boot.bin.pad conv=sync
cat openwrt-oxnas-ox820-u-boot.bin.pad openwrt-oxnas-stg212-fit-uImage-initramfs.itb > openwrt-oxnas-stg212-fit-uImage-initramfs.boot

tftp 64000000 openwrt-oxnas-stg212-fit-uImage-initramfs.boot 
nand erase 0x440000 0x400000 
nand write 0x64000000 0x440000 0x400000 
setenv bootcmd nand read 0x64000000 0x440000 0x90000\\; go 0x64000000 saveenv go 64000000

I have no experience with the Mitrastar/Medion, but quite a bit with the Pogoplug V3 which is another OXNAS NAS target.

With 18.06 the whole OXNAS target has been completely overhauled, so it's not entirely surprising that the instructions for 17.01 don't work anymore. Also, sysupgrading from 17.01 to 18.06 or 19.07 on the Pogoplug will not work and, if forced, softbrick it. I am pretty sure it will be the same for the Medion.

Judging from the DTS, there doesn't seem any difference in the flash layout between the Pogoplug and the Mitrastar/Medion. So I would imagine that the installation process for the Pogoplug V3 (outlined on the page, it is current for 19.02) also works for your Medion box. If you feel adventurous, you might just give it a shot, no warranties though.

Word of advice: There has been a long-standing bug in the OXNAS target that prevents a soft reboot that has only recently been fixed in snapshots and for the upcoming 19.07.3.

Thanks, I think I am progressing. Following this I can get it to sort of works. I used lede-17.01.4-oxnas-stg212-u-boot-initramfs.bin. When I reboot it I get this on the serial connection.

Loading from device 0: 128MiB 3,3V 8-bit (offset 0x440000)
** Bad Magic Number 0xea0000be **
## Booting image at 60000000 ...
Bad Magic Number

if I type got 64000000

it loads and sort of works, I need to reinstall samba
"opkg update; opkg install luci-app-samba"

If I power cycle it is dead again. I guess I need to write the file.