[MedionNAS] installation and recovery

But why are you trying to mix and match processes and images between 17.01 and 19.07? Go with the Pogoplug process of 19.07, use 19.07 images for initramfs and sysupgrade.

Where do you get 60000000 from? And honestly, I would look into getting the system working stable before installing anything else.

Yes, because the initramfs image only runs in RAM, of course you have to write something to flash to be persistant. Again, follow the installation process, it is all laid out there.

Sidenote: 19.07.3 has just been tagged and built and should be released in the next few hours/days. As I said above, it contains an important fix for the Oxnas targets.

Thanks, the 60000000 comes up as it boots. I see this on console.

Loading from device 0: 128MiB 3,3V 8-bit (offset 0x440000)
** Bad Magic Number 0xea0000be **
## Booting image at 60000000 ...
Bad Magic Number

I understood version 19 was very different and as I had 17 working previously would be the best route to take.

Sorry, but from what you are writing I don't get what you are doing, or trying to do, or which path you are following.

I want to get this usable again. I don't like the original Medion OS, the openWRT looks much better. Earlier I had trouble seeing the complete drive and was advised to update from 17 to 19 as 17 was old. I can get it to boot and to a linux like prompt. I can a see the GUI and console. I have access to SSH connection. If I turn off the power the image file is lost and it wont boot. I now need to install a working OS.

I was probably too wordy, I do that sometimes. So let me reiterate:

  • yes, you can try to install 19.07
  • there are no installation instructions for 19.07 for your device (Oxnas CPU, Mitrastar/Medion)
  • the PogoPlug V3 is similar (if not even identical where it matters) to this device
  • you can try the installation instructions for the PogoPlug V3, but you would of course use the image files for the Mitrastar/Medion instead of the PogoPlug ones
  • do not use 17.01 files, they are completely different and not compatible, not even for upgrading
  • if you boot into an "initramfs" image, it is only running in RAM, once you reboot you will be back to your current unworking state, so you would probably want to do all the other steps in the instructions, not just one of them

Thanks, I will try again later when I get home from work. I guess I do not do Step 4b.

You don't need to do 4b (so neither 4b.1 and 4b.2), these are steps for 18.06. You are trying to install 19.07, you should only need to do 4a.

If you did and your boot process still wants to boot from 60000000 please recheck step 1: it should want to boot from 60500000 and I'm honestly not sure where "60000000" is coming from since that value is not mentioned anywhere.

1 Like

Getting there, it now boots and retains everything. I can power cycle and it reboots. I now need to solve the missing "services" tab. Maybe missing Samba but I cant find how to install Samba.

Yes, you will need to install Samba, that's a topic for a different thread though.

Also, it would still be good if you laid out exactly what you did to get to this point, if only to help other people with the same problem (and to be able to update the wiki page.) Can you confirm that the Pogoplug instructions do work for your Medion device?

Thanks, I will that, I appreciate the assistance and am happy help someone else.

You're welcome, but, again, can you confirm that the Pogoplug instructions did work for your Medion device?

1 Like

Yes they worked. I am attempting to write instructions based on my install now.


Please let me know your opinion.

Update the Medion to latest firmware from within the NAS web interface if possible.

You will need a serial connection and terminal console software on your PC (see the "Serial" section) between your PC and the Medion.

This worked for me - PL2303HX USB To TTL RS232 module and firmware version 333, the driver is available at http:// bit.ly/prolific333

An ethernet connection between your PC and the Medion, with your PC's ethernet interface set to static IP

A TFTP server on your PC, serving the initramfs-uImage

The image files. From https://downloads.openwrt.org/releases/19.07.3/targets/oxnas/ox820/

openwrt-19.07.3-oxnas-ox820-mitrastar_stg-212-initramfs-uImage (rename to initramfs-uImage as dots confuse the TFTP transfer)



Open the serial connection and power on.

Bits rate: 115200

Data bits: 8

Stop bits: 1

Parity: None

Flow control: None

When you see “Hit any key to stop autoboot” hit any key to stop autoboot.

setenv bootcmd 'nboot 60500000 0 440000; bootm'


setenv serverip

setenv ipaddr (use direct ethernet cable between PC and Medion )

tftp 64000000 initramfs-uImage

bootm 64000000

uci set network.lan.proto=static

uci set network.lan.ipaddr=

uci set network.lan.netmask=

uci commit

service network restart

Brower on your PC go to the Medion address (

Log into the GUI as root (password not required)

From GUI go to > system > Back/Flash Firmware >

Then under “Flash new firmware image” > Choose file > then open openwrt-19.07.3-oxnas-ox820-mitrastar_stg-212-squashfs-sysupgrade.tar from where you previously saved it.

Then Flash image

Go to Network tab > interfaces > lan > edit and set a static IP, gateway & DNS then connect to your network

Go to System > Administration >set yourself a password.

System > Software > Available > Update lists > “Filter “samba” > luci-app-samba

Go to System . Reboot

Set up storage partition of the drive:-

Connect to your Medion with SSH

From SSH (format the drive EXT4)

umount /mnt/SDA2

opkg update

opkg install e2fsprogs

opkg install kmod-fs-ext4

mkfs.ext4 /dev/sda2

chmod 777 /mnt/SDA2

System > Mount Points > Generate Config > Mount Attached devices > Add /mnt/sda2

Services > Network Shares > Add > “Name it something meaningful” > path /mnt/SDA2 > Browseable > Allow Guests > 777 > 777 > Save & Apply

Your efforts are appreciated, but I'm not entirely sure they are necessary. If the Pogoplug instructions do work, they can be just copypasted into the Medion page anyway. No need to reinvent the wheel -- and also no need to describe the serial driver installation (it will differ for everyone) or how to install Samba (that is another topic). In the meantime I simplified the Pogoplug instructions, by the way.


That is the really interesting part where the instructions would differ: How is a serial connection connected? The current description

The board got a populated 4-pin header which is a 3.3V TTL serial port. VCC | RX | TX | GND

is very sparse. Images or a really detailed description would be nice here.

( renaming thread > installation and recovery )

1 Like

Black is ground
White is TX
Green is RX
Red is 3.3v not used

I am wanting to replace the HDD in one of these. Do they need anything on the HDD to work? From what I can tell everything is in flash.


I just flashed a Medion NAS according to the descriptions of PogoPlug (mentioned by @takimata) and @hondabeat (at least until the static configuration of IP in the web. For the moment I have no need to go further)
In fact I did it several times. It turned out for me that the step "sysupgrade /tmp/squashfs-sysupgrade.tar" of the PogoPlug installation process did not work for me. During this step while still connected to serial console I got regularly blue screens.
Finally I followed the sysupgrade description of @hondabeat using the web console and this worked perfectly.

As TFTP server I used "Pumpkin" under windows. This also produced some trouble together with the windows firewall, networking area (private vs. public network)...
If you get several lines of "ARP Resend request" in the serial console during the TFTP process you should double check the TFTP connection.

I also disconnected the serial console as soon as I managed to boot into OpenWrt early after "service network restart" to limit blue screen scenarios.

Probably the mentioned issues above are very specific to my windows laptop but perhaps it nevertheless could help someone...

I will try to edit "https://openwrt.org/toh/medion/md86587" and write down my experience.



I have no HDD connected at all and OpenWrt works. So I would expect that nothing is stored on the HDD.


Blue screen? Where? Did your Windows system bluescreen as reaction on a serial connection with an OpenWrt box?