LUCI Error after upgrade to r10949 or r10951: /etc/config/luci seems to be corrupt

I use 19.07 SNAPSHOT (ath79) on a TP-Link C7 V2. Since Version r10949 or r10951 i get an error after making sysupgrade:

/usr/lib/lua/luci/dispatcher.lua:315: /etc/config/luci seems to be corrupt, unable to find section 'main'
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:315: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:208: in function </usr/lib/lua/luci/dispatcher.lua:207>

I already made a backup of config, hard reset and restore from config. No solution. LUCI is not working any more. LUCI with releases r10936 and before works without any problem.

I use the following packages:
install wget
But i don't think this is the reason for the error. After making sysupgrade i can't rech luci via http.

I already looked at /etc/config/luci but i doesn*t seems to be corrupt.

Any idea?

And thanks to all developers / supporters for your work!

Is this a custom build? If so, please run a make dirclean, followed by make clean. The error above happens when rpcd is crashing which might be triggered by a bad compilation.

Did it work with default configs?

No, IT ist the 'official' snapshot

I did not test it explicit for http. I do not remember but i think it did not work for http and for schure not after install of the packages for https.

Wait...then what did you actually test for???

r10949 and or r10951 are likely quite old.

  • To be clear, you are aware that you should not restore your backup config across versions, correct? You need to manually glean them and setup on the new version.
  • and are you aware that - changing from ar71xx to ath79 requires fresh configs anyway

Can we try the default configs first?

  • I'm almost sure that the question was regarding the official status of your r10949 and/or r10951 firmware. We are aware that 19.07.1 is an official version.
  • The current snapshot would not be numbered 19.07 - today's (04 MAR) was numbered "OpenWrt SNAPSHOT r12423-0493d57e04"
  • Is that the version you have?
  • Please be mindful that all desired packaged should be installed immediately after flashing (or within 24 hours) as the snapshot packages changes approximately daily
1 Like

After sysupgrade i did not test to access luci via http. I immediately installed luci-ssl because i don't want to use luci without ssl. I have to upgrade again to a newer version and to test access to http-LUCI after sysupgrade. Maybe this evening...

I use the snapshot of 19.07, not the recent snapshot. Therefor these versions are the latest. Most of the time i make a sysupgrade with keeping the config and most of the time it works well. If not, i make a hard reset and import the backup-config.

OK, later this day....

yes, i know. I use the latest snapshot of 19.07.

No, i use the version at
I always install the packages immediately after flashing the system.

Thanks for your help!

Hi, I got this error, too, right after making the upgrade from 19.07.1 to 19.07.2 on the O2 box 6431.
It disappears after making a restart, but can appear again, I wasn't able to reproduce though.
Then I made a custom compile with additional packages (release 19.07.2), but even after doing 'make dirclean && make clean' before compiling, this also happened right after flashing. Is there something in the config files that can produce this error?
I have these packages included:

  • htop
  • luci
  • luci-app-banip
  • luci-app-ddns
  • luci-app-diag-core
  • luci-app-sqm
  • luci-app-ntpc
  • luci-app-watchcat
  • luci-app-wifischedule
  • luci-app-wol
  • luci-app-statistics
  • luci-compat
  • curl
  • wget
  • openssh-sftp-server
  • 6in4
  • netperf
  • nano


Hi, it finally worked after after I turned off the router for 30 seconds after each step (hard reset, flash, reconfigure / import backup). I don't know exactly if this ist the reason but I always took the same steps to set up and turning off was the only difference. Maybe you can try this.
Now i use 19.07.2 and it works well.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

thanks for the quick answer! I will try this tonight!

By the way when looking at the log I found when the problem happened:

[71116.147195] pppd invoked oom-killer: gfp_mask=0x14201ca(GFP_HIGHUSER_MOVABLE|__GFP_COLD), nodemask=(null),  order=0, oom_score_adj=0
[71116.166190] CPU: 0 PID: 7560 Comm: pppd Not tainted 4.14.171 #0
[71116.170671] Stack : 00000000 ffffffff 0000000e 80081748 80670000 8061d300 00000000 00000000
[71116.672099] Out of memory: Kill process 7435 (rpcd) score 4 or sacrifice child
[71116.679371] Killed process 7435 (rpcd) total-vm:2172kB, anon-rss:260kB, file-rss:4kB, shmem-rss:0kB

But now I wonder why at all this happened.. ?