Luci batman hard_if now shown as "unsupported", but working

Hi, since today my 4.19 master snapshot installations show "Unsupported protocol type.", and no interface statistics like RX/TX bytes for Batman hard interfaces.
A few days ago they still showed as "Unmanaged", but with interface stats.

I vaguely remember a "luci-proto-batadv", but I can't find it in the package list in the device that still runs 4.19.69, which displays the complete, correct interface stats. Or has this something to do with the luci changes, that are currently trickling through git?


Btw: Not solved, just erroneously marked as such.

I didn't find the LuCI proto though.

I misremembered, i was thinking of luci-proto-relayd.

It's probably the same reason as for the post in the other section: Proto "Unmanaged" not available in latest snapshot

1 Like

Not the solution. "relayd" was for a different problem.

Luci master still is broken w.r.t. the topic "Batman hard_if not shown correctly in luci":

1 Like

I am also seeing this issue ("Unsupported protocol type.") on interfaces using batadv and batadv_hard_if proto (on batman 2019.1) – was this issue ever tackled?

Context: 19.07.0 firmware on a Netgear WNDR3700v4

No, since there never was a bug report.

That happens because the protocol is not for LuCI.

My mistake - I just realized there's a separate process for reporting bugs. (Sorry, I thought these forums were "the way".)

1 Like

I guess it could be nice to have the ability to hide such interfaces from appearing in LuCI?
(For example, an option for hidden that users could specify in the interface stanza)

Would that be a bad idea in terms of security/transparency, though?

It would be interesting. I hope those who develop LuCI will raise it.

IMHO, hiding the Batman devices is not a solution. The stats displayed in LUCI when they were properly integrated (<=2019) were very helpful.

The issue is solved now.
My master snapshot compile from yesterday does nicely display interface stats and everything else for BATMAN interfaces now again. Thanks :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.