LuCI APP: luci-app-3ginfo - 3ginfo gui (Info about 3G/LTE connection)

Hi, I created the Luci application for the 3ginfo project

luci-app-3ginfo is a GUI for 3ginfo application/project https://eko.one.pl/?p=openwrt-3ginfo

Works with mPCI-E and USB 3G/LTE modems.

Screenshots:

Download:
https://github.com/4IceG/luci-app-3ginfo

Other useful packages:


8 Likes

hello,
I had a look at your app and I tried to install. qmisignal works fine, but I don't find any luci-app-3ginfo package to download around your link.
Was I wrong?

thanks
Graziano

Hi, the package is of course downloadable.


https://github.com/4IceG/luci-app-3ginfo/releases/download/1.3/luci-app-3ginfo_1.3_all.ipk
1 Like

thank you,
sorry I'm still not used to git :slight_smile:

I take the chance to ask you for assistance about following problems I encountered using qmi-signal:

  1. It causes some trouble with web interface, Luci hangs constantly and always goes on time out; terminal console is not affected, so I was able to remove the package and go back to normal behaviour.

  2. another issue (always qmi-signal) is a lock conflict with a tiny script of mine who perform uqmi -d /dev/cdc-wdm0 --get-current-settings every 5 seconds (I need to check "out of call" status); PS command shows 4 or more uqmi running tasks.
    With my script not running, I keep qmi-signal running: after some time it hangs. I close the qmi-signal tab, but the console PS command shows again a lot of uqmi running tasks.

I've just installed latest OpenWrt version and the minimum necessary to use QMI interface and luci-app-qmi.

Thank you in advance
Graz

hi again,
after installing the package I click to "configuration" tab and I get this message:

/usr/lib/lua/luci/dispatcher.lua:1334: module 'luci.cbi' not found:
	no field package.preload['luci.cbi']
	no file './luci/cbi.lua'
	no file '/usr/share/lua/luci/cbi.lua'
	no file '/usr/share/lua/luci/cbi/init.lua'
	no file '/usr/lib/lua/luci/cbi.lua'
	no file '/usr/lib/lua/luci/cbi/init.lua'
	no file './luci/cbi.so'
	no file '/usr/lib/lua/luci/cbi.so'
	no file '/usr/lib/lua/loadall.so'
	no file './luci.so'
	no file '/usr/lib/lua/luci.so'
	no file '/usr/lib/lua/loadall.so'
stack traceback:
	[C]: in function 'require'
	/usr/lib/lua/luci/dispatcher.lua:1334: in function '_cbi'
	/usr/lib/lua/luci/dispatcher.lua:1023: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:478: in function </usr/lib/lua/luci/dispatcher.lua:477>

what is wrong?

Ok I found the solution,
I installed luci-compat package and now all works fine

1 Like