[Solved]4G usb cannot connect

Hi. i got a Huawei 3372 (non Hilink) version of the 4G usb modem and i would like to make use of it in my Openwrt. The carrier needs the roaming option enabled. as APN i have to put myq, no username/password. No PIN as well.
In the system it has been seen as hardware and i would like to configure it, preferably through Luci. Could someone help me on that please? Here is the output of dmesg command

[    9.135252] usbcore: registered new interface driver option
[    9.141066] usbserial: USB Serial support registered for GSM modem (1-port)
[    9.224976] kmodloader: done loading kernel modules from /etc/modules.d/*
[   11.714469] usb 1-1: new high-speed USB device number 2 using ehci-pci
[   15.135942] usb 1-1: USB disconnect, device number 2
[   16.027172] usb 1-1: new high-speed USB device number 3 using ehci-pci
[   16.332267] option 1-1:1.0: GSM modem (1-port) converter detected
[   16.338803] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
[   16.346207] option 1-1:1.1: GSM modem (1-port) converter detected
[   16.352567] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
[   16.557263] huawei_cdc_ncm 1-1:1.2: resetting NTB format to 16-bit
[   16.588647] huawei_cdc_ncm 1-1:1.2: MAC-Address: 00:1e:10:1f:00:00
[   16.594908] huawei_cdc_ncm 1-1:1.2: setting rx_max = 16384
[   16.630541] huawei_cdc_ncm 1-1:1.2: NDP will be placed at end of frame for this device.
[   16.638928] huawei_cdc_ncm 1-1:1.2: cdc-wdm0: USB WDM device
[   16.645661] huawei_cdc_ncm 1-1:1.2 wwan0: register 'huawei_cdc_ncm' at usb-0000:00:0f.5-1, Huawei CDC NCM device, 00:1e:10:1f:00:00

You should be able to configure APN through Luci, for roaming setting I suppose you will need to send (once) the corresponding AT command from any terminal app like picocom.

1 Like

thanks it worked. How do i see the status of signal through Luci?

Consider using this instead of plain OpenWrt.
This will give you signal information and many other modem related features.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Hi @atux_null you can try..

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.