Low Wifi 5G speed with TP-Link Archer C6 v3


I've installed OpenWrt 22.03.0-rc1 in the TP-Link Archer C6 v3.20 router (MediaTek MT7621 - ramips/mt7621). I've done this because I want to put a script to disable wifi radios at night.

The router is connected to my 1gbps fibre OTN. When I connect to the Archer using Ethernet in my computer, I get +-900mbps down/up speeds, so I think it mostly works fine (I enabled software/hardware flow offloading in Network/Firewall).

But using 5Ghz wifi, the download speed with all the devices I have is bound to +-350mbps. It is a MediaTek MT7613BE 802.11nac chip which reports bitrate of 750 to 820mbps in the OpenWRT "Wireless" screen. It's using AC mode and 80Mhz, because if I chose 120Mhz, devices cannot connect.

Is there another thing I can try or a closed source driver I can install so I can improve the speed of this interface a little? Thanks!!

Edit: with a very modern smartphone, I can get 460mbps, but I still think I should get a lot more. Am I right?

can you post the output of : iw list

fwiw, if you want faster wifi speeds, you may need to consider installing a separate wireless access point running OEM firmware for maximum performance. OpenWrt wireless is often inferior to OEM firmwares in my experience.

For my Xiaomi 4A Gigabit with 21.02.x, I recall routed speeds from WAN to ethernet LAN were

Routed speeds to Intel 7026ac 802.11ac 2x2 wireless (80MHz) client

Here it is: https://pastebin.com/k0Vr0Dfp

Not really, there is a difference between the advertized data link rate - and the effective throughput you can get at your clients. The advertized top speeds of modern routers are given with all rf chains used (3x3, 4x4, up to 8x8 for wifi6), but your clients are mostly 2x2 (notebooks, good phones), 1x1 (IoT, cheap phones, USB cards, cheap tablets, cheap notebooks, ...) or maybe 3x3 for very high-end notebooks. With 802.11ac, 2x2 (@80 MHz channel bandwidth) leaves you with 866 MBit/s link rate at most, which -in practice- allows you speeds (rule of thumb, roughly half) around 300-350 MBit/s, maybe 400 MBit/s under ideal circumstances.

If you want more than that, you either need to increase the number of rf chains (~antennas) on both client and AP - or move to 802.11ax/ wifi6.


Look at this :

IMHO, stick to the channel 36, with a channel width of 160Mhz.

If I chose 160Mhz, the interface doesn't even work. I cannot see the wifi in any of my devices, including a Samsung S22+ (Wi-Fi 802.11 a/b/g/n/ac/ax 2.4G+5GHz+6GHz, HE160, MIMO, 1024-QAM - Up to 2.4Gbps Download / Up to 2.4Gbps Upload)

Thanks for the picture. It helps me to understand how it works.

Also, thank you @slh for your explanation. But a Samsung S22+ should be able to use the full 160Mhz if it would be shown, right?

160 MHz rarely works, half of your bandwidth always overlaps with the DFS range, meaning you're very suspectible to interference and radar events (and false radar events, caused by interference from your neighbours). Unless you're in a shielded rf lab, live in the sticks far away from airports, ports, military, weather stations and neighbours or can use the 6 GHz band (even shorter range, fewer competition), you'd be better of with 80 MHz channels.

The more you push it (160 MHz), the more you challenge hardware, firmware and drivers, some will stand the pressure better than others.

1 Like

in my case, with a totolink a8000ru, i set channel 36, width 160Mhz. My phone is a samsung S20, and it connects using 80Mhz. not 160Mhz but at least it can connects and it works...
if your radio doesn't even want to start, then there must be a bad setting combination somewhere ?

So your device says :

                VHT Capabilities (0x338001f8):
                        Max MPDU length: 3895
                        Supported Channel Width: 160 MHz, 80+80 MHz
                        RX LDPC
                        short GI (80 MHz)
                        short GI (160/80+80 MHz)

                        * 5180 MHz [36] (23.0 dBm)
                        * 5200 MHz [40] (23.0 dBm)
                        * 5220 MHz [44] (23.0 dBm)
                        * 5240 MHz [48] (23.0 dBm)
                        * 5260 MHz [52] (20.0 dBm) (radar detection)
                        * 5280 MHz [56] (20.0 dBm) (radar detection)
                        * 5300 MHz [60] (20.0 dBm) (radar detection)
                        * 5320 MHz [64] (20.0 dBm) (radar detection)
                        * 5500 MHz [100] (23.0 dBm) (radar detection)
                        * 5520 MHz [104] (23.0 dBm) (radar detection)
                        * 5540 MHz [108] (23.0 dBm) (radar detection)
                        * 5560 MHz [112] (23.0 dBm) (radar detection)
                        * 5580 MHz [116] (23.0 dBm) (radar detection)
                        * 5600 MHz [120] (23.0 dBm) (radar detection)
                        * 5620 MHz [124] (23.0 dBm) (radar detection)
                        * 5640 MHz [128] (23.0 dBm) (radar detection)
                        * 5660 MHz [132] (23.0 dBm) (radar detection)
                        * 5680 MHz [136] (23.0 dBm) (radar detection)
                        * 5700 MHz [140] (23.0 dBm) (radar detection)
                        * 5720 MHz [144] (13.0 dBm) (radar detection)
                        * 5745 MHz [149] (13.0 dBm)
                        * 5765 MHz [153] (13.0 dBm)
                        * 5785 MHz [157] (13.0 dBm)
                        * 5805 MHz [161] (13.0 dBm)
                        * 5825 MHz [165] (13.0 dBm)
                        * 5845 MHz [169] (13.0 dBm)
                        * 5865 MHz [173] (13.0 dBm)

Can you force Channel 100 then ?

you can try to troubleshot your problem with this free tool : Acrylic wifi home

it will show you in the chan column how many channels are used. 4 channels = 80Mhz, 8 channels = 160Mhz.

Thanks a lot for the help. I've tried all the combinations of channels with 160Mhz to no avail. Maybe with further fixes to drivers something more can be achieved. To be honest, the speed is lower than with the old router, but the perceived speed on my smartphone is better, so I'm ok with it.

I could try with future versions of OpenWRT if 160Mhz is available, but maybe as @slh said, it's not worth it. If I try it in the future and it works better, I'll update this thread.


C6v3 doesn't support 160mhz or dfs channels even with the stock firmware, so maybe a hardware limitation?

It says it supports 863Mhz on the 5Ghz band.

867 Mbps :sweat_smile:


And from the Spec page :

So that's true, the device doesn't support 160Mhz channel width.


Ahhh! Then the problem is with OpenWRT that should not allow 160Mhz. Thanks for finding it for me.

Anyways, @slh said this:

"leaves you with 866 MBit/s link rate at most, which -in practice- allows you speeds (rule of thumb, roughly half) around 300-350 MBit/s, maybe 400 MBit/s under ideal circumstances"

And that's true: I get from 300 to 450 MBit/s. But why is that?

but according to the command output : iw list
the driver says :

                VHT Capabilities (0x338001f8):
                        Max MPDU length: 3895
                        Supported Channel Width: 160 MHz, 80+80 MHz
                        RX LDPC
                        short GI (80 MHz)
                        short GI (160/80+80 MHz)

it talks about 160Mhz, why ??

I don't know why. This is what I see:

maybe this issue should be reported here : https://github.com/openwrt/mt76/issues

Sorry, i opened my own topic, i don't want to hijack this one as my router is different.

Maybe the OpenWRT frontend (LuCI) takes the information from there...