Lost WiFi internet

Hi guys,
I have an issue.
I installed OpenWRT to Asus RT-N13U B1 - OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152) It's was openwrt-18.06.1-ramips-rt305x-rt-n13u-squashfs-sysupgrade.bin
First time I set Wi-Fi, https, SSH, parental control for time and with OpenDNS. I got a problem. I lost the Internet.
Ok, I Performed reset.
So, I set just SSH and password of course. Wi-Fi SSID, and Password WPA2-PSK..
Ohh, I thought thats really cool.
But, NOT. I got the problem again. Via Ethernet - my desktop has the Internet. So, Wi-Fi clients (Phones, tablets) doesn't have. It's approximately in 3 hours.
I switch off and switch on again. Cool. I have the Internet.
SO, I can't do it every 2-3 hours.
Who can help me to troubleshooting this?
I can show log or.....

I'm a bit confused. What firmware did your router have before the installation?

Original firmware
RT-N13U.RB_2.0.2.0.trx

Then why did you flash openwrt-18.06.1-ramips-rt305x-rt-n13u-squashfs-sysupgrade.bin?
You were supposed to flash http://downloads.openwrt.org/releases/18.06.1/targets/ramips/rt305x/openwrt-18.06.1-ramips-rt305x-rt-n13u-initramfs-kernel.bin

On this forum.
One man said me to install that
in this topic - LEDE-Settings lost after reboot

Ah I see. Then he must be right about initramfs, though I'm not sure it's there. I thought it could be just the name is wrong., but now hat I see you had issues with saving settings as you mentioned in the other post. That page diffidently needs to be fixed after your issue is sorted out.

So, if I understand your issue right, your wirelesses work for 2 or 3 hours, then disconnect by themselves?Or do they remain connected to WiFi by lose internet connection? Does it happen for them all at once, or one by one?

Could you provide /etc/config/network and /etc/config/wireless?

They are online - connected to Wi-Fi but don't have internet and one by one.

I hid MAC-adress
network -

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdfd:fb67:c9aa::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'xx:xx:xx:xx:xx:32'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '00:xx:xx:xx:xx:33'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'rt305x'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'rt305x'
        option vlan '1'
        option ports '0 1 2 3 5 6t'

config switch_vlan
        option device 'rt305x'
        option vlan '2'
                                           

wireless -

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option channel 'auto'
        option htmode 'HT40'
        option legacy_rates '1'
        option country 'US'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'MyPaSSword'
        option ssid 'My NaMe'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option network 'guest'
        option encryption 'psk2'
        option ssid 'My NaMeGuest'
        option key 'keygen123'
        option disabled '1'

Could you try to set the channel instead of leaving it as auto? Choose channel 1, 6 or 11. Ideally you would use a scanner software to see what channels are less congested.

When the wireless devices have no internet connection, did you try pinging the router form them to make sure they are actually connected? How about if you try to ping an outside IP from them (e.g. 8.8.8.8)?

Ifsetting channel doesn'tfix the issue, you could post System Log http://192.168.1.1/cgi-bin/luci/admin/status/syslog and Kernel Log http://192.168.1.2/cgi-bin/luci/admin/status/dmesg here.

I don't know if your trust level on the forum is Basic or Member. If it's basic then you will have restriction of the number of posts you post, so try to group your replies together.

1 Like

initramfs is only to be uploaded to RAM on boot through serial. This way you can check if Openwrt will actually work on your device or not and it can also be used for development purposes. It should not be flashed to the device because it's not a usual sysupgrade firmware.

Yes I understand. What I'm saying is that if the image is actually initramfs then why is it listed in the wiki as the installation image in the first place. If there is a reason why it was done like that, then there has to be a note that users should flash sysupgrade right after it.

I have no idea about that. Maybe someone mentioned it by mistake and no one cared enough to change it after that.

1 Like

I changed the channel. My smartphone doesn't ping after lost connection. They show that they are connected to Wi-Fi, but without Internet and doesn't ping 192.168.1.1 and of course 8.8.8.8
I see the droppes in the logs.
So, my desktop has Internet via LAN.

my logs: I couldn't add logs there are too many letters. I've added links

syslog:
https://mega.nz/#!qJdQgCjJ!t8LKazA-wrIJb4t7J0PBl-K0T9BiVZvMKEGyPzzksRQ

Kernel:
https://mega.nz/#!3BdiiILQ!Hr0RPJXI4hOqWD9VbU4BW6AjXxp2b5baj2BqYdN8Wt8

If it's OK.

I noticed the following:

Sun Mar 24 18:05:50 2019 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:c8:1a IEEE 802.11: authenticated
Sun Mar 24 18:05:50 2019 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:c8:1a IEEE 802.11: associated (aid 2)
Sun Mar 24 18:05:50 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED xx:xx:xx:xx:c8:1a
Sun Mar 24 18:05:50 2019 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:c8:1a WPA: pairwise key handshake completed (RSN)
Sun Mar 24 18:05:51 2019 daemon.info dnsmasq-dhcp[1270]: DHCPREQUEST(br-lan) 192.168.1.120 xx:xx:xx:xx:c8:1a
Sun Mar 24 18:05:51 2019 daemon.info dnsmasq-dhcp[1270]: DHCPACK(br-lan) 192.168.1.120 xx:xx:xx:xx:c8:1a android-dd3fbfd7c3d10797
Sun Mar 24 18:06:34 2019 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:c8:1a IEEE 802.11: disconnected due to excessive missing ACKs
Sun Mar 24 18:06:34 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED xx:xx:xx:xx:c8:1a

So it seems that your devices get disconnected from the AP for some reason relating to DHCP acknowledgment maybe. I am not sure what the missing ACKs mean here. I would probably advise you to lengthen the DHCP lease period, possibly to 12h. If it's already the same value then lower it to 1h maybe. You'll need to experiment with this value to see what works for you. It could be related to some issue within the wifi driver maybe?

1 Like

It's set to 12 h, I'll try.
Upd: I reduced to 1 h.
Testing...

Can you post your DHCP config? /etc/config/dhcp

Edit: You may be able to gain something by forcing the DHCP server on your system. You may find it under LAN->DHCP config in LuCI. Also go to DHCP and DNS in LuCI and mark the DHCP server as authoritative. It may work in some situations when devices fail to get DHCP addresses.

1 Like

Just this. I use nano and SSH

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

DHCP is enable Authoritative

I believe this file has more data than you posted above and please always use the code blocks to post any config and logs. In SSH try to use cat /etc/config/dhcp and it should display the whole file.

cat:

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option dhcpv6 'server'
        option ra 'server'
        option leasetime '1h'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'guest'
        option interface 'guest'
        option start '2'
        option leasetime '2h'
        option limit '10'