Losing VDSL2 speed, advice?

Over the last week or so, my VDSL2 speed has steadily dropped from around 80mpbs to 50mbps. I've tried different devices and different firmwares, vectoring and non-vectoring but all with the same result. Right now, this is what I have:

**Data Rate:** 50.210 Mb/s / 12.000 Mb/s
**Max. Attainable Data Rate (ATTNDR):** 50.380 Mb/s / 15.805 Mb/s

This is using a vectoring firmware. If I use a non-vectoring firmware I get this:

**Data Rate:** 50.310 Mb/s / 12.000 Mb/s
**Max. Attainable Data Rate (ATTNDR):** 92.130 Mb/s / 15.415 Mb/s

Like I said, the speed has been dropping gradually over the past 8 to 9 days. This to me suggests maybe a faulty capacitor in the filter, possibly hit by a spike and is slowly losing capacitance and gaining EPR. So I've ordered a new face plate and CAT6 cable. When they arrive, I'll also leave the VDSL2 line disconnected overnight and install it the following morning. Calling the ISP currently is like pulling teeth, they're all short staffed due to ,, well you all know why.

Failing the microfilter, anyone got any ideas on what else could be causing this?


I've had issues like this before with the ISPs DSLAM equipment putting on a cap on the line speed for some inexplicable reason. Similar symptoms - firmware reporting a much higher attainable rate.

I had to get on the horn to the ISP and they asked the provider to remove the cap, after which everything was ok. This was BT if by any chance you happen to be using an ISP that uses BT Openreach

1 Like

Yeah, my ISP is SKY but still OpenReach. I'll try and see if I can get through in the morning, this all started, coincidentally, when I started messing around with OpenWRT, so the line would have been getting a lot of up/down events (you know how it goes when you're first setting the stuff up). So perhaps I tripped some "This consumer's being weird" flag.

My ISP at the time was Plusnet Business, who's tech support is really good. They can put a soft cap on the profile, but then there's also a hard cap that Openreach's equipment can put on.

If you plug and unplug your modem often, sometimes the DSLAM thinks the line is unstable, so it hard caps the speed. Then you get the symptom that your modem firmware will report an attainable rate a lot faster than what you're getting. This is exactly what happened to me, so likely what's happened to you too given that you've been taking the line up and down often.

With Plusnet it was easy to get removed due to their good tech support, but I 've heard horror stories about Sky, so good luck!

And incidentally, I was hard capped to 50mbps, which seems to be the same as you. I think this is the hard cap level (or at least one of them) that gets set automatically.

Yeah they can be a pain to deal with. But generally, if you call asking for your transfer code to another provider, you get through to a customer options team, and they tend to get stuff done.

Yup, you were bang on. I rang them and fortunately got through to someone who wasn't a script following drone. He confirmed that the DLM was locked to a "reliability profile". I obviously put the sky router back in-line and they have apparently also detected some fault at my side as well. I've got an engineer visit to sort it out. Took about 10 minutes to go through all the covid stuff. The tech-rep was blown away, first thing I asked was for them to release the profile on the DSLAM as it seems to be hard capped. He went away and checked and indeed that was exactly the case. Guy kept chuckling and told me that he'd never once got such a specific request from a customer that had figured out the problem before calling and had got it exactly right. I did mention I had gotten help from this forum though. So thanks for that advice man, 100%.

Fabulous, glad to have been of help and that you've sorted it out.

What I eventually did was to use a Draytek Vigor 130 modem in bridge mode instead. This way, you can take the Openwrt router up and down while the modem keeps the physical connection up and there's less risk of the DSLAM capping your line. Bouncing the pppoe connection doesn't seem to have the same effect.

Not sure you can do bridge mode with Sky though...I believe they use pppoa

They use mer DHCP on VLAN ID 101. My setup was actually using a HH5A setup with OpenWrt in a DSL bridge configuration. I then used a thin-client PC installed with OpenWrt to handle the leg work. I might try getting hold of a Draytek however as the HH5A is really a piece of krap with OpenWrt on it. Wifi speed maxes out at 130Mbs which is laughably bad and as VDSL2 speeds get faster, the device isn't going to be able to keep up. From what I read, I understand this is due to OpenWrt not utilising hardware in the device that assists with packet relaying, whereas the stock BT firmware does and thus does not suffer from this bottleneck. I ended up ditching the Wifi on the HH5A as well (it was also bridged to the thin client on another VLAN) and using the Sky router as a Wifi access point (Everything DSL related disabled, DHCP disabled etc..). Wifi speeds were then fine, but I had three devices running instead of just one, lol. Unfortunately, the Sky hub has no bridged mode, nor any VLAN configuration ability or I could throw the HH5A in the bin. If I get a Draytek I may still do so.

Just an update on this as I feel the information may be useful to others.

I ended up with an engineer visit as previously mentioned. Turns out, the profile cap had turned on because it had detected line instability. This was due to my DSL cable, the engineer showed me the problem with his test equipment; using my DSL cable he starting moving it around during the test and I could see the error states showing up whenever it was moving. This cable, was a special CAT 6 cable I ordered a while ago along with a filtered face-plate. They are supposed to be far better than the flat lossy cables supplied with the CSE, and they are, no doubt about that. But they are a very rigid cable due to the solid copper core wire. That puts a lot of stress on the end plugs, especially if you're moving your equipment around a lot while the cable is plugged in. Over time, this stress had caused either fractures or bad contact in the plug where the wire is crimped. This was causing a lot of noise on the line and making the DSL impose the cap to keep the line stable.

He replaced the cable with a regular old flat one and showed me the same test; the errors were gone even with the cable being moved around. After he'd gone, he'd taken off the cap and the line was up to 67 mb/s with the sky hub. I left it like that for a day and it seemed stable, so I whipped it out and put my HH5A back in. After adjusting the SNR, I'm now up to the maximum speed for my subscription, 80mb/s (it actually shows as 79.95 mb/s but that's close enough)

So basically, if anyone is using one of those rigid CAT6 DSL cables, be very ginger with it. Don't throw it about with your equipment when moving it. Unplug it, move your stuff then plug it back in and be careful about where it's placed, so it's putting as little strain as possible on the end plugs. Also a good idea to swap it out every year or so.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.