Looking for a Cheap OpenWrt-Compatible Router for Gaming and Streaming in the Netherlands

Is there a reason to do that instead of just merging the PR and making a build?

I suggest a Cudy x6/AX1800. There's one available on ebay.nl for ~42€.

If you want to connect wirelessly to your router, then I suggest to look out for the Linksys MR8300. It has two radios for 5GHz, so you can use one to connect to the router and the other as an AP. I bought mine when it was on sale on Amazon.de for about € 55.

you don't have to build it yourself, otherwise, to really.

I successfully made a build the other day which was pretty easy just following the instructions / pr commit msg, managed to get the router for 40 euro as I got a couple discounts which is a pretty good deal imo :slight_smile:

1 Like


might want to update the PR, confirm it working.

so I just got the router and flashed the firmware as instructed in the pr

Web UI Recovery method:

  1. Unplug the router
  2. Plug in and hold reset button 5~10 secs
  3. Set your computer IP address manually to 192.168.1.x /
  4. Flash image with web browser to

after flashing the factory image I build it says flashing successful after which it instantly reloads the webpage, the router doesn't appear to automatically restart and turning it off and on / trying the reset button doesn't change the fact that it keeps displaying the web recovery ui

what are you trying to achieve ?

is the device soft bricked ?
do you want to return to stock ?

(FYI, I've asked for your post to be moved to a separate thread)

I'm trying to flash OpenWrt, I followed the instructions mentioned in the PR:
Web UI Recovery method:

  1. Unplug the router
  2. Plug in and hold reset button 5~10 secs
  3. Set your computer IP address manually to 192.168.1.x /
  4. Flash image with web browser to

and I flashed the build I made myself: openwrt-ramips-mt7621-mercusys_mr70x-squashfs-factory.bin

After the flashing finished it displays the text showing that flashing was successful after which the page instantly reloads (still the flashing page).

I tried:

  • reflashing the image (nothing)
  • renaming the image and then reflashing it (nothing)
  • restarting and resetting the router (nothing)
  • flashing the stock firmware (nothing)
  • flashing the stock firmware but renamed to something shorter (nothing)

It seems like kajoj2 did have luck getting his build to work which I haven't tried yet but I did see others on the old PR mentioning a similiar issue: https://github.com/openwrt/openwrt/pull/5079#issuecomment-1294109273

I can also confirm that I do have the EU V1 version as indicated by the sticker on the bottom.

Just for fun, try the d-link firmware I linked to in the other thread, if you succeed with it, you can just reflash with MR70X fw afterwards.

could you link the firmware I couldn't find it when I looked at the thread just a bit ago

flashing this seems to take longer the stock one and the one I made automatically skip to like 40% ish

it says the dlink firmware is invalid

interesting, so it seems the stock fw is rejecting the openwrt ones.
what's the fw version on your router ?

any ideas, @nicefile & @jetsnguns ?

how do I check the FW version if I can't get past the web recovery? also it seems i'm not the only one as someone else on the old pr had a similar issue, I also tried to install the latest stock firmware but again I'm only able to boot into the web recovery, I also tried a different browser with no success.

My router is currently not with me, but I remember updating firmware only once right after purchasing it. I think the version was MR70X(EU)_V1_201127 or MR70X(EU)_V1_201222. I was still experiencing some random WiFi problems after updating though.

I tried flashing the first and latest official firmware but I'm still stuck in the web recovery

I posted a new forum post under the support and development section with an updated list of all the steps I've taken, I'm aware this forum post is most likely in the process of being moved but I felt like this would be a better idea.

The new forum post can be found here: Flashing Mercusys MR70X

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.