Looking for a Cheap OpenWrt-Compatible Router for Gaming and Streaming in the Netherlands

Hello everyone,

I'm looking for a router that supports OpenWRT and is priced around 50 euros. It should be available in the Netherlands and have an easy flashing process that doesn't require any hardware flashers.

My use case is to have this router in a separate room to extend my network (connected over WAN with the ISP modem/router). I primarily use my PC for gaming and my phone for streaming videos in 1080p. Our bandwidth is 100Mbps down and 10Mbps up.

If anyone has any recommendations for a router that can handle this kind of usage without breaking the bank, I would appreciate your suggestions. Thank you in advance!

At 100mbit, anything will work, as long as it's supported.

Have a look at the MR70X, not officially supported, yet, there's a PR pending, but you can make it work using a d-link fw.

hey! thanks for the reply

I took a look at the router's specs and it seems like a pretty good deal and the instructions also seem pretty easy. I'll monitor the PR and I'll probs order the router from amazon in a couple days.

Don't expect the PR to get approved any time soon, just use the d-link fw.

I personally haven't used openwrt yet but a PR with support for the d link one just got merged so I could indeed flash that one and install the package but couldn't i also just build my own image using the provided instructions merging the PR into main?

Sure, that should work too.

I'd use the image builder with the d-link fw, add the extra packages to it, then manually add the script for the fw.

Is there a reason to do that instead of just merging the PR and making a build?

I suggest a Cudy x6/AX1800. There's one available on ebay.nl for ~42€.

If you want to connect wirelessly to your router, then I suggest to look out for the Linksys MR8300. It has two radios for 5GHz, so you can use one to connect to the router and the other as an AP. I bought mine when it was on sale on Amazon.de for about € 55.

you don't have to build it yourself, otherwise, to really.

I successfully made a build the other day which was pretty easy just following the instructions / pr commit msg, managed to get the router for 40 euro as I got a couple discounts which is a pretty good deal imo :slight_smile:

1 Like


might want to update the PR, confirm it working.

so I just got the router and flashed the firmware as instructed in the pr

Web UI Recovery method:

  1. Unplug the router
  2. Plug in and hold reset button 5~10 secs
  3. Set your computer IP address manually to 192.168.1.x /
  4. Flash image with web browser to

after flashing the factory image I build it says flashing successful after which it instantly reloads the webpage, the router doesn't appear to automatically restart and turning it off and on / trying the reset button doesn't change the fact that it keeps displaying the web recovery ui

what are you trying to achieve ?

is the device soft bricked ?
do you want to return to stock ?

(FYI, I've asked for your post to be moved to a separate thread)

I'm trying to flash OpenWrt, I followed the instructions mentioned in the PR:
Web UI Recovery method:

  1. Unplug the router
  2. Plug in and hold reset button 5~10 secs
  3. Set your computer IP address manually to 192.168.1.x /
  4. Flash image with web browser to

and I flashed the build I made myself: openwrt-ramips-mt7621-mercusys_mr70x-squashfs-factory.bin

After the flashing finished it displays the text showing that flashing was successful after which the page instantly reloads (still the flashing page).

I tried:

  • reflashing the image (nothing)
  • renaming the image and then reflashing it (nothing)
  • restarting and resetting the router (nothing)
  • flashing the stock firmware (nothing)
  • flashing the stock firmware but renamed to something shorter (nothing)

It seems like kajoj2 did have luck getting his build to work which I haven't tried yet but I did see others on the old PR mentioning a similiar issue: https://github.com/openwrt/openwrt/pull/5079#issuecomment-1294109273

I can also confirm that I do have the EU V1 version as indicated by the sticker on the bottom.

Just for fun, try the d-link firmware I linked to in the other thread, if you succeed with it, you can just reflash with MR70X fw afterwards.

could you link the firmware I couldn't find it when I looked at the thread just a bit ago

flashing this seems to take longer the stock one and the one I made automatically skip to like 40% ish

it says the dlink firmware is invalid