Linsys EA8300 Radio1 and Radio2 not showing

Hello, I have just flashed OpenWRT (attempted all versions with EA8300 support, up to 19.07.3) and have come up with the error of having only Radio0 show up.

The router has two 5GHz Radios and one 2.4 GHz Radio. But only Radio0 (at 5 GHz) is showing up:

The question: How can I configure Radio1 and Radio2 to show up?

I checked several other related threads (Access Point Multiple Routes, Linksys EA8300 - 5ghz cannot set channels and 2nd 5ghz radio won't work, 5GHz channel problems, and Access point multiple routes) but nothing has worked so far.

All that shows up on iwinfo is:

root@OpenWrt:~# iwinfo
wlan0     ESSID: "Vanelope"
          Access Point: 32:23:03:6B:67:F0
          Mode: Master  Channel: 161 (5.805 GHz)
          Tx-Power: 30 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -103 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 168C:0056 0000:0000 [Qualcomm Atheros QCA9886]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

What I get on the network configuration seems normal:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd5d:bc32:6440::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask ''
        option ip6assign '60'
        option ipaddr ''
        list dns ''
        list dns ''

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'

But the result on the Wireless configuration is clearly missing the 2 radios

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option country 'GT'
        option channel '161'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key 'o*7dlkgfrtyex8Ys'
        option ssid 'Vanelope'
        option encryption 'psk2'

Thank you for your help.

Maybe backup /etc/config/wireless and reboot.
Any errors in the system or kernel logs?
You could try building from a snapshot.

I tried the backup of the wireless file. It just deleted the wireless configuration and generated a blank view, with nothing changed. Still just one radio.

The System Log shows a few errors. I pasted the section with errors here:

The Kernel Log also shows a few errors. Pasted here:

In both cases, it does seem like an error loading the ath10k/QCA4019 firmware.

I also just tried the latest snapshot. I'm not sure if it's any progress, but the errors in the kernel and system logs are gone. Same problem with only having Radio0 showing and nothing else has changed.

Is there a way to install just the items that are giving an error or to manually add support for the items not being regonized?

Install this package:

Thank you. Installed now:

Exactly the same as before, though. I'm still on the snapshot version. Thought to stay there given the lack of errors on the system and kernel logs.

This is the install command and results:

root@OpenWrt:~# opkg install ath10k-firmware-qca4019
Installing ath10k-firmware-qca4019 (20200122-1) to root...
Configuring ath10k-firmware-qca4019.
root@OpenWrt:~# Connection reset by port 22

So no errors in the log but no radios?

Try "iw list" from the command line.

Here's what iw list prints out... it appears it does read the 3 antennas

root@OpenWrt:~# iw list
Wiphy phy0
        max # scan SSIDs: 16
        max scan IEs length: 199 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Device supports T-DLS.
        Available Antennas: TX 0x3 RX 0x3
        Configured Antennas: TX 0x3 RX 0x3
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
                 * P2P-device
        Band 2:
                Capabilities: 0x19ef
                        RX LDPC
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 7935 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-15
                VHT Capabilities (0x339979b2):
                        Max MPDU length: 11454
                        Supported Channel Width: neither 160 nor 80+80
                        RX LDPC
                        short GI (80 MHz)
                        TX STBC
                        SU Beamformer
                        SU Beamformee
                        MU Beamformer
                        MU Beamformee
                        RX antenna pattern consistency
                        TX antenna pattern consistency
                VHT RX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT RX highest supported: 0 Mbps
                VHT TX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT TX highest supported: 0 Mbps
                        * 5180 MHz [36] (disabled)
                        * 5200 MHz [40] (disabled)
                        * 5220 MHz [44] (disabled)
                        * 5240 MHz [48] (disabled)
                        * 5260 MHz [52] (disabled)
                        * 5280 MHz [56] (disabled)
                        * 5300 MHz [60] (disabled)
                        * 5320 MHz [64] (disabled)
                        * 5500 MHz [100] (disabled)
                        * 5520 MHz [104] (disabled)
                        * 5540 MHz [108] (disabled)
                        * 5560 MHz [112] (disabled)
                        * 5580 MHz [116] (disabled)
                        * 5600 MHz [120] (disabled)
                        * 5620 MHz [124] (disabled)
                        * 5640 MHz [128] (disabled)
                        * 5660 MHz [132] (disabled)
                        * 5680 MHz [136] (disabled)
                        * 5700 MHz [140] (disabled)
                        * 5720 MHz [144] (disabled)
                        * 5745 MHz [149] (30.0 dBm)
                        * 5765 MHz [153] (30.0 dBm)
                        * 5785 MHz [157] (30.0 dBm)
                        * 5805 MHz [161] (30.0 dBm)
                        * 5825 MHz [165] (30.0 dBm)
                        * 5845 MHz [169] (disabled)
                        * 5865 MHz [173] (disabled)
        valid interface combinations:
                 * #{ managed } <= 16, #{ AP, mesh point } <= 16, #{ IBSS } <= 1,
                   total <= 16, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz, 80+80 MHz, 160 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        Supported extended features:
                * [ VHT_IBSS ]: VHT-IBSS
                * [ RRM ]: RRM
                * [ SET_SCAN_DWELL ]: scan dwell setting
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
                * [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
                * [ AIRTIME_FAIRNESS ]: airtime fairness scheduling

Should there be 3 radios (phy devices?), I don't know.
You could try a snapshot build (no luci).

Is you other firmware still the OEM'S ?
If so, try rebooting with OEM'S firmware.

I bought an EA8300 last week,upgraded twice to OEM firmware to have both firmware partitions fresh and ready to failover back if needed. Upgraded to 19.07.3, configured with Luci and everything works fine for me, stronger signal and stable Wi-Fi.

What version is your router ? Is it the new v.1.1? Maybe your issues are 1.1 related.?

Watch out, there is a new firmware version, which seems to add support for hardware v.1.1., which seems recent. I have not used it and it may install a GUI lock preventing GUI upgrade to OpenWRT, like the MR8300. If anyone was successful with GUI upgrade with this version, it would certainly be of public interest to the EA8300 community.

If you can't revert to OEM, try reflashig with the Linksys Telnet utility.

With only one radio working, you might as well wipe everything clean and start from scratch.

Hope this helps...

In reply to @Bobcat and @bjlockie...

I'm currently running the OpenWRT snapshot version. I removed version 19.07.3 and I'm running the latest snapshot build from

After installing it, I manually installed LuCI using the CLI and opkg.

And, yes, this router has 3 radios. 2 are 5 GHz and 1 is 2.4 GHz. In the default configuration from Linksys, they are configured to act as 1 using all band steering.

In the other firmware partition, I'm running the OEM software, version I don't see any notice regarding the hardware version. All I see as model number is "EA8300", no versioning.

While I finish getting OpenWRT with the full functionality the router offers. The OEM software works great on the band steering, and acceptably well as a DHCP, but quite poor in most of the other configurations (compared to OpenWRT).

Hw version is on sticker under unit

Thanks. Yes, no version mentioned on the sticker, so I guess it's version 1.

Are you still within you return window ? I bought mine refurbished new from authorized Linksys at They seems to be batches showing up regularly, so there maybe some issues fixed during the refurbish process, maybe...

My upgrade went so smooth from the first try, maybe you unit is defective and a replacement is to be considered ?

Thanks... so, if I understand correctly, you got an EA8300 and when you installed OpenWRT all radios showed up right from the start?

I bought this router 4 days ago, after returning an EA6350 that I had purchased that same week (I purchased it with "version 3" indicated and received "version 4"). So, I should be able to get a replacement if I can prove something is not working well, but OpenWRT is outside of the OEM scope for "working well".

All my radios work fine from the start, just needed to configure them with Luci and the rest is history. Fixed several issues in the process.

My first post here :

Depending on retailer, you might not need to prove anything except saying you have intermittent connection issues... Just make up a story and make sure you reflash to double stock FW beforehand.

Bestbuy, Amazon, Staples, are great with returns. Just return it and once refunded, just order another one...

I have assembled thousands of clone PC'S and managed several networks in my young days and have encountered countless weird issues, waiting countless hours with software, just to end up fixing with hardware replacement, either parts or entire units often with same model and make.

If hardware don't work the was it's supposed to with fresh (emphasis fresh, like in you case) production software, then it's a hardware issue. You can try and fight it as much as you want, but in the end, it's supposed to work the first time when using supported hardware and software revisions as in this case. Also, limit yourself to production versions like 19.07.3 and not untested snapshots. If it don't work with production, it's defective...

Once you have a known working state with basic install, you can go on and experiment all you want, knowing you are one flash away back to known working state if you put yourself in trouble.

Mine worked from the very first time as I would expect it to. I had researched the EA8300 here, prior to buying in order to make sure I had the confidence this would work.

I have yet to use the command line to configure anything, as I am happy with the result using LuCi for now. Hopefully, I can get my other MR8300 upgraded eventually, as it's essentially an EA8300 with 512Mb ram...

My advice, return it and buy another one.

Just my two bits as a old dinosaur who survived a few meteor showers...

1 Like

OK. Thank you for your experience. I wasn't sure if it was the model or my specific device. I didn't buy from a nice store like the ones mentioned... I bought from a good local store that doesn't have such a generous return policy. I'll still give it a shit, though.

Thanks again.... Took your advice and returned the router. Switched to Asus now... :slight_smile:

Asus what ? The EA8300 is a fine machine, why change ?

Yes it is. Lovely router. Really liked it, but at the store I bought it all of them where from the same batch, so it was very propable that it turn in out the same, and they were unwilling to accept another return if that was the case... Most stores in my country don't have generous return policies.
Now I'm using an Asus RT-AC66U_B1. It has Tomato, OpenWRT and AsusWRT-Merlín support. Managed to flash it already and up and running now :slight_smile:

It's unfortunate you had to change device model, but I'm happy you got things running as expected.

On my side, I just ordered my second refurb EA8300 for CAD $130, mesh is the next step here.