5GHz channel problems

With WR1200JS and XIAMI R3G i can use only channels 36 to 48 not anothers, why ?

Note : i use 2 box in WDS mode

In most regions, channels higher than 48 require devices with certain capabilities (DFS and TPC) to be allowed to work on those frequencies.

You could very briefly try, for the sake of checking only, to change your region to India and see if such frequencies will become available.

It goes without saying that if your device isn't capable of complying with the local regulations for operating on such frequencies, you shouldn't use a different region settings to use such channels. If you do the test, don't forget to change the region back to your actual region.

While I'm not familiar with the mt76 driver myself (and don't know about its potential restrictions in terms of DFS support), configuring the correct regulatory domain and checking the output of iw list should provide you with your options.

Ok for DFS channel but i have another problem with a recent compiled version ( 4.14.118 ) and associated box in WDS shutdown:

With old version ( 4.14.102 ) not this problem


[  313.076884] wlan1: associated
[  317.112809] wlan1: **deauthenticated** from d4:5f:25:eb:09:82 (Reason: 2=PREV_AUTH_NOT_VALID)
[  410.319047] wlan1: authenticate with d4:5f:25:eb:09:82
[  411.013791] wlan1: send auth to d4:5f:25:eb:09:82 (try 1/3)
[  411.027123] wlan1: authenticated
[  411.036288] wlan1: associate with d4:5f:25:eb:09:82 (try 1/3)
[  411.045531] wlan1: RX AssocResp from d4:5f:25:eb:09:82 (capab=0x11 status=0 aid=1)
[  411.053471] wlan1: associated
[  415.083220] wlan1: **deauthenticated** from d4:5f:25:eb:09:82 (Reason: 2=PREV_AUTH_NOT_VALID)
[  611.228610] wlan1: authenticate with d4:5f:25:eb:09:82
[  611.923782] wlan1: send auth to d4:5f:25:eb:09:82 (try 1/3)
[  611.931593] wlan1: authenticated
[  611.936300] wlan1: associate with d4:5f:25:eb:09:82 (try 1/3)
[  611.944583] wlan1: RX AssocResp from d4:5f:25:eb:09:82 (capab=0x11 status=0 aid=1)
[  611.952405] wlan1: associated
[  616.114491] wlan1: **deauthenticated** from d4:5f:25:eb:09:82 (Reason: 2=PREV_AUTH_NOT_VALID)

What version is that? Linux Kernel? Stock or thirdparty firmware?

What version is that? Linux Kernel? Stock or thirdparty firmware?

That is OpenWRT last master that I compiled a few days ago

git pull
scripts/feeds update-a
scripts/feeds install -a
make menuconfig …
make -j4

And connect the antenna port to a dummy load (most people won't have this kid of testing equipment available).

So is your 5 GHz channel issue solved?

For 5Ghz this is partialy solved ( indian country ) but the WIFI Openwrt master / WDS is not capable in auto mode to check channel disponilbility out of 36 / 48 channel range as my BOX ( Orange LiveBox 4 )

For the dummy load i have a big 50 Ohms 1 KW !!!

For the recent compiled version ( 4.14.118 ) i cannot use 5Ghz with the same config as version 4.14.102

1 Like

A little news:

With a WR1200JS and firmware 4.14.102 and WR1200JS with 4.14.120 no problem

WIth 2 * WR1200JS with 4.14.120 i cannot run Wifi …

Stupid problem !!!

  • Remark : Wifi is in WDS mode ( master and slave )

In reference to

Given that, last I checked, x-wrt was a very close clone of recent OpenWrt, the commit log there along with git diff --name-status x-wrt $(git mergebase x-wrt openwrt-master) or the like should help point you to the differences.

I have:
1 - Make folder TEST cd TEST
2 - git clone https://www.github.com/openwrt/openwrt.git
3 - wget https://github.com/x-wrt/x-wrt/archive/master.zip
4 - After i extract master.zip in x-wrt-master
5 - diff -r openwrt x-wrt-master > diff-listing
I got a big file > 78 k but I do not know what to do to find out what does not work in the official openwrt version !!!

Add both as remotes to the same local directory. Fetch both. Find the merge base with OpenWrt master and compare with that, as a start

with last compilation 4.14.121 the problem is not solved

jeff@deb-devel:~/devel/openwrt$ git remote add xwrt https://github.com/x-wrt/x-wrt
jeff@deb-devel:~/devel/openwrt$ git fetch xwrt
remote: Enumerating objects: 760, done.
remote: Counting objects: 100% (760/760), done.
remote: Compressing objects: 100% (9/9), done.
remote: Total 1397 (delta 752), reused 751 (delta 751), pack-reused 637
Receiving objects: 100% (1397/1397), 221.86 KiB | 6.93 MiB/s, done.
Resolving deltas: 100% (897/897), completed with 308 local objects.
From https://github.com/x-wrt/x-wrt
 * [new branch]            ar71xx-fix-switch-port-isolate           -> xwrt/ar71xx-fix-switch-port-isolate
 * [new branch]            arris                                    -> xwrt/arris
 * [new branch]            bridge-allow-receiption-on-disabled-port -> xwrt/bridge-allow-receiption-on-disabled-port
 * [new branch]            essedma-fix                              -> xwrt/essedma-fix
 * [new branch]            fix-ldd-glibc                            -> xwrt/fix-ldd-glibc
 * [new branch]            fix-libopenssl-deps                      -> xwrt/fix-libopenssl-deps
 * [new branch]            hc5861-fix                               -> xwrt/hc5861-fix
 * [new branch]            ipq40xx-install                          -> xwrt/ipq40xx-install
 * [new branch]            master                                   -> xwrt/master
 * [new branch]            ramips-fix-mac                           -> xwrt/ramips-fix-mac
jeff@deb-devel:~/devel/openwrt$ git merge-base openwrt/master xwrt/master
jeff@deb-devel:~/devel/openwrt$ git log -1 --pretty=short 085f66de9a1e0cba44eb15deb4f4803f1ac2286f
commit 085f66de9a
Author: Jan Hoffmann <redacted>

    ramips: create R6220 dtsi and improve WNDR3700v5 support
jeff@deb-devel:~/devel/openwrt$ git log --pretty='%h %cd %s' xwrt/master ^openwrt/master
d08bfd50aa Fri May 31 21:03:12 2019 +0800 ramips: mt7621 nand disable shift_on_bbt
6df9d3b945 Fri May 31 21:03:12 2019 +0800 kernel: macvlan forward promisc
4e51677bca Fri May 31 21:03:12 2019 +0800 kernel: Reimplement: bridge allow receiption on disabled port
5bd7021bd8 Fri May 31 21:03:12 2019 +0800 ar71xx: Allow port-to-port forward on vlan disable
jeff@deb-devel:~/devel/openwrt$ git diff --name-status openwrt/master xwrt/master | head
A	.github/ISSUE_TEMPLATE/bug_report.md
A	.github/ISSUE_TEMPLATE/feature_request.md
M	config/Config-images.in
M	feeds.conf.default
M	package/base-files/Makefile
M	package/base-files/files/bin/config_generate
M	package/base-files/files/etc/group
M	package/base-files/files/etc/init.d/done
A	package/base-files/files/etc/init.d/switch_ports_status
M	package/base-files/files/etc/init.d/sysctl

I've been having trouble with WDS client on all snapshot (4.14 kernel) builds. I think the problem is that the kernel bridge will not pass EAPOL packets to wpa_supplicant.

The connection repeatedly starts up then crashes with PREVIOUS AUTH NOT VALID on the client side.

1 Like

with x-wrt 4.14.121 no problem

with openwrt 4.14.102 no problem

with one box openwrt 4.14.102 and the other box in 4.14.121 no problem

with openwrt 4.14.121 and 2 * box i have this in WDS connection:

[ 96.503771] wlan1: send auth to d4:5f:25:eb:09:82 (try 1/3)
[ 96.517956] wlan1: authenticated
[ 96.526209] wlan1: associate with d4:5f:25:eb:09:82 (try 1/3)
[ 97.086156] wlan1: associate with d4:5f:25:eb:09:82 (try 2/3)
[ 97.200919] wlan1: RX AssocResp from d4:5f:25:eb:09:82 (capab=0x11 status=0 aid=1)
[ 97.208706] wlan1: associated
[ 101.312913] wlan1: deauthenticated from d4:5f:25:eb:09:82 (Reason: 2=PREV_AUTH_NOT_VALID)

It looks like we have the same bug. I've been attempting to do some controlled tests here to narrow it down. This belongs in a different thread as I don't think it has anything to do with the wifi driver (I have tried ath10k, ath9k, and mt76X2) or channel selection at all. Next I'm going to build x-wrt and try to see what the difference is.

1 Like

I'm having similar issues with an Linksys EA8300 (ath10k) running recent snapshot builds. I have a post with more details and logs.

Problem solved with last sources 4.14.123

I can use WDS in 5Ghz in channel mode auto

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.