Linksys MR8300 PPPoE slow

hello,
OpenWrt 23.05.2 with PPoE wan the download no more 200mbps Instead 1Gbps symmetrical.
With the stock firmware the speed is around 930mbps.

I read the possible problem with NAT Offloading and I try use some trick without success.

can you help me?

no,

you're not providing any useful info, and "it's slow" won't suffice.

1 Like

sorry,
I wrote that with stock firmware the download speed is around 930mbps and with openwrt is 200mbps.
what should I enter to be more detailed?

@ster1um

Take a look here: Distribute DSA across 2 different cores MR8300 SNAPSHOT

fwiw, I don't think you will achieve 1Gbps routed speeds using Openwrt on MR8300 with PPPoE. The device is not fast enough. There is a general post explaining why OpenWrt is slower on ultrafast broadband connections (eg. above 500 mbps) but I can't find it at the moment for you.

Try turning on Packet Steering (Interfaces menu) and Software Flow Offloading (Firewall menu) but it won't help PPPoE imho.

The MR8300 uses IPQ4019.

Here are some speed tests I did with EA6350 v3 IPQ4018 a few years ago. No PPPoE.

I don't think there has been any improvement with 22.03 and 23.05.

As far as I'm aware there is no hardware offloading on IPQ40xx devices. If you want best speeds for your Gb connection, use stock firmware.

3 Likes

thanks for suggest but I don't find any solution...

Try using firmware 22.03.5 you'll get more speed (but not the same speed as stock firmware).

https://forum.openwrt.org/t/so-you-have-500mbps-1gbps-fiber-and-need-a-router-read-this-first/90305

2 Likes

I read this post old on 2021.
Ipq4019 is quad core a7 not single core that explained in the post

ipq4019 and ipq4018 are both quad core ARM clocked at slow 717 MHz.

It is TOO SLOW if you want full 1Gbps speed with OpenWRT.

I believe PPPoE implementation in OpenWrt is software only using single core. Someone will correct me if I am wrong.

Use Linksys software on your MR8300 if you want best speeds on 1Gb ISP connection, or buy a new faster router/device for OpenWrt.

4 Likes

Ok I understand, quad a53@1,2GHz it sufficient for 2,5gbit gpon?

for 2.5Gbit you pretty much need/want x86.

2 Likes

imho, I don't think a53@1,2GHz can reach 400-500 Mbps routed speeds with OpenWrt when using PPPoE.....

Look at x86 mini computer/device for 1Gb, as suggested by @frollic

fwiw, similar query but at lower 500 Mbps
https://forum.openwrt.org/t/router-recommendation-for-3-bedroom-townhouse-is-netgear-r7800-a-good-pick/158487

I tried but the connection drop down with ppoe vlan taggaed 835...

The VLAN config from DSA (Firmware 23.05) to non DSA (22.03) is different.

My config for MR8300 in non DSA working (sensible data marked as "xxxx"):
Remove any config you don't need, it's just an example.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxxxxxxxxxxxxx'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'pppoe'
	option username 'xxxxxxxxx'
	option password 'xxxxxx'
	option ipv6 'auto'
	option device 'eth1.6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 0 1 2 3 4'
	option vid '1'

config device
	option type '8021q'
	option ifname 'eth1'
	option vid '6'
	option name 'eth1.6'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '6'
	option ports '0t 0t 5t'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '0t 0t 1t'
	option vid '10'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '10'
	option name 'eth0.10'
	option ipv6 '0'

config interface 'Guest'
	option proto 'static'
	option device 'eth0.10'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
1 Like

Thanks for share congratulation example .

I'll try and tell you how it goes!

This configuration work for Italy provider TIM FTTH with swconfig.
TIM does not support IPv6 well therefore I disabled it

config device
        option name 'eth1.835'
        option type '8021q'
        option ifname 'eth1'
        option vid '835'
        option ipv6 '0'

config interface 'wan'
        option proto 'pppoe'
        option username 'timadsl' #any user and pass is allowed 
        option password 'timadsl'
        option device 'eth1.835'
        option ipv6 '0'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '835'
        option ports '0t 5t'

Any improvement about speed? Remember to enable packet steering option.

Edit: Check cat /sys/devices/system/cpu/cpufreq/policy0/scaling_governor should be in performance

Yes I active packet steering and I installed irqbalance.

CPU governor it's set to ondemand.

with this configuration is able to put in download about 600Mbps

Did you install latest 23.05.2? Because it is set to performance by default, unless you kept the settings from a previous version.

That seems reasonable.