Linksys EA8300 wireless is broken, wired is pretty bad too

And from the history of past topics, it looks like it always has been. I picked up a new one the other day and it's been nothing but problems. My main router is set to and my wireless router is connected to it at 4.1. So I set the EA8300 to 5.1 and it's not reachable when plugged into my main router. My main router has openwrt and my wireless is another linksys (that doesn't support openwrt) but both are reachable through the ip address in firefox or chrome. This one isn't. My intention was to replace both routers for this one. The main router is an old archer c7 and the other one is a linksys mr9000. Although the wireless speeds are terrific, the stock firmware is shot to hell and there's no plans to build a cfw for it any time soon.

The wireless is broken, too. Screenshots attached, the first one where it's not using the qualcomm was before I set it to AC (it was blank, the other option being legacy). Still doesn't work. When I do get connected to the generic wireless, it works at regular speed (200mbps) for about 10 seconds then the whole router just dies for a few minutes. I tried a couple of the previous suggestions but nothing worked.

So, where should I start?

Do you have software flow offloading enabled by chance? I have an mr8300 which is essentially the same device from what I understand and the wifi is fine until software flow offloading is enabled and then pretty bad afterwards.

edit - if you don't have flow offloading enabled you might try the 21.02 snapshot which you can get from the firmware selector, it's what I'm using with the mr8300

Not enabled. Snapshot not available, either. The problems I'm having have been documented ever since it was supported (using the term loosely).

Ahh ok, just got the mr8300 last week so not really familiar with the history yet, the snapshot is there if you still want to try it, as you're typing in the model click on the dropdown that appears (set it to 21.02 first, just forgot to do that when taking the screenshot as an example) -

It's making progress, no longer seen as generic devices. When all three networks were broken up into different ssid's, speed maxes out but peters out after a short period. When I combined them all into one ssid, the speeds are completely unstable, less than 20mbit on usenet.

Edit: Also worth mentioning, I cloned my mac address then plugged it directly into the modem to eliminate the possibility of another piece of hardware causing issues. And I turned off my other routers to prevent any interference.


Sorry, but I'm not sure what the problem might be, my only suggestions would be to make sure your country code is set correctly and you've set a non-dfs channel manually rather than auto if you haven't already. I don't have access to my mr8300 to test right now, but I've had it set with the same ssid on all three radios with no problems, but, radio0 is slightly slower than I expect, meaning I get 160-170 instead of the expected 200 isp speed, but it's consistent. You might post the contents of /etc/config/wireless and maybe someone more familiar with the ea8300 can spot something unusual (make sure to remove passwords/macs) or have a better idea of what might be going on.

Changed the region to north america and didn't change much else but that seems to have made a significant improvement. Just downloaded about 30gb at full speed without any drop offs.

Check out the screenshots. One problem I'm having is the LibreelecPi4 is connecting to the bgn network and the speeds are pretty lousy, is there a way I can force that to connect to the ac network? It was this way before when I used another router, always connected to the slowest one.

And is there anything I should change for AC or Legacy? Channel/width?
Transmit power?

There's no such thing-- it is set by country not region e.g. US, CA, or MX. Not setting the wireless to a country will have poor performance.

Also since it is triple band the two 5 GHz radios must operate within the channel ranges of their respecitve hardware filters. One is for the low channels and one for high. I'm not sure what happens in the mid band.

You can lower the transit power on radio1 to help steer it towards 0 and 2, although I have all three of my radios transmit power set the same (20) and the a/c clients connect to 0 and 2 as expected, so it might be something specific to your environment. You can also try cell density coverage (network>wireless>device configuration>advanced settings), I haven't tried it yet, but it might also be useful for steering, more info on it here.

1 Like

If speed is the vital concern, have a separate SSID on 2.4 and use it only on clients that don't have 5 GHz.

Putting a floor on the rate from the AP (cell_density option) is a better way to control client distance than turning down the power. Though neither of those is a great way to control client distance.

In the image posted, one of the 5 GHz clients is at -91 dBm and that is not going to work well.

1 Like

Thanks Mike! I lowered the transit power from 30dbm/1000mw to 15dbm/31mw and it's fixed the raspberry pi issue in the other room. Speeds are much faster. Here's some pictures of the current status, is there something else I should change?

Seem you have my issue in MR8300.Actually i use a snapshot 21.02 but the problem persist. For now the solution is set manually the country code in the radio module affected.

No, it looks like everything's been covered, my old router is a linksy's wrt1200 and it had some problems when it first got supported too, but it only took one release cycle to get them fixed so the problems with the *8300 probably won't be around long either, seems like a pretty solid device worth sticking with.

1 Like

It's been working pretty nice, appreciate all the help. Hopefully the next person who can't get theirs up and running can just follow along. I was able to shelf the old c7 and the mr9000. Still waiting on a build for the nanopi r4s, there's a lot of activity going on over there.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.