Linksys ea8300 : it is possible to configure VLAN on eth1 : - )

Hello,
to add a little precision about this topic Linksys EA8300 tagged VLAN on eth1, it is possible to configure VLAN on eth1, by editing board.json

{
	"model": {
		"id": "linksys,ea8300",
		"name": "Linksys EA8300 (Dallas)"
	},
	"network": {
		"lan": {
			"ifname": "eth0",
			"protocol": "static"
		},
		"wan": {
			"ifname": "eth1",
			"protocol": "dhcp"
		}
	},
	"switch": {
		"switch0": {
			"enable": true,
			"reset": true,
			"ports": [
				{
					"num": 0,
					"device": "eth0",
					"need_tag": false,
					"want_untag": true
				},
				{
					"num": 1,
					"role": "lan"
				},
				{
					"num": 2,
					"role": "lan"
				},
				{
					"num": 3,
					"role": "lan"
				},
				{
					"num": 4,
					"role": "lan"
				},
				{ 
					"num": 5, 
					"role": "wan"
				}
			],
			"roles": [
				{
					"role": "lan",
					"ports": "1 2 3 4 0",
					"device": "eth0"
				},
				{ 
					"role": "wan", 
					"ports": "5", 
					"device": "eth1" 
				}
			]
		}
	}
}

I also did it on an AVM Fritz!Box 4040 based on ipq40xx target.

Powered by LuCI openwrt-21.02 branch (git-22.052.50801-31a27f3) / OpenWrt 21.02.1 r16325-88151b8303

Regards :grinning:

Making an interface at eth1.x doesn't work?

Of course it works !

Hi.
A tiny typo error in the thread title : it's ea8300.
I assume this tweak is also possible on the mr8300, which I own.

1 Like

I also can confirm, that with this board.json change the requested configuration from my post Linksys EA8300 tagged VLAN on eth1 works as expected.

WAN interface must be connected to Device eth1.101 in my example configuration to get connection to the tagged VLAN 101.

Thanks for the useful hint.

Additional question:
Before testing, I updated luci-base git-21.295.67054-13df80d » git-22.052.50801-31a27f3 as indicated in the configuration.

Is this update required to get it running or would the stock install of openwrt-21.02.1-ipq40xx-generic-linksys_ea8300-squashfs-factory.bin also work?

In fact, I know that it works with stock version of 19.07 and 21.02. May be it would be useful to push this board.json in the repository to include it for next delivery. But I don’t have a developer profile yet neither a operational build computer.

Could you also post your network file. I am not able to get it working for some reason.

Hi,

a partial content of my network file.

Fred


config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'

config interface 'lan'
	option proto 'static'
	list ipaddr '192.168.1.1/24'
	option device 'br-lan'
	option ip6assign '64'
	option defaultroute '0'

config interface 'wan'
	option proto 'dhcp'
	option broadcast '1'
	option device 'eth1.832'

config interface 'wan6'
	option proto 'dhcpv6'
	option reqprefix 'auto'
	option reqaddress 'none'
	option defaultreqopts '0'
	option device 'eth1.832'

config interface 'tvorange'
	option proto 'static'
	option ipaddr '192.168.255.254'
	option netmask '255.255.255.255'
	option delegate '0'
	option device 'eth1.840'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 1 2 3 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5t'
	option vid '832'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '19'
	option ports '0t'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option ports '0t 5t'
	option vid '840'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

1 Like