Linksys EA8300 tagged VLAN on eth1

I have a Linksys EA8300 router running OpenWrt 21.02.1.
I'm trying to connect a DHCP client interface to a VLAN ID 101 on eth1 (the internet connector at the EA8300 box). The eth1 is connected by a tagged VLAN connection to switch with a DHCP server connected to VLAN ID 101 (see network configuration below).

I tried several configuration options like the one below, but didn't succeed to get a network address from the DHCP server connected to VLAN ID 101. A similar configuration with the tagged VLAN connected to a port of the eth0 switch works fine, the DHCP client interface gets a network address from the the DHCP server.

Can someone tell me how to configure a tagged VLAN on eth1 at the Linksys EA8300 device?

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd25:562b:066a::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth1.101'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth1.101'
        option reqaddress 'try'
        option reqprefix 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'

config device
        option type '8021q'
        option ifname 'eth1'
        option vid '101'
        option name 'eth1.101'

There is a proper solution not tooo far away, but not quite available yet either.

Thanks @slh for the links.

I already found the IPQ40xx Switch Config Strangeness topic, but didn't understand the restrictions of this "strangeness". Moreover, from IPQ40xx: Is it possible to use vlans? I was not sure if there is a working solution for eth1.

What I can confirm, is that with OpenWrt 21.02.1 it is possible to configure VLAN on eth0/switch0. I successfully tested a configuration with 3 VLAN IDs, running untagged on 3 ports and tagged on the fourth port of switch0 in the EA8300. So I wondered, if some kind of driver level VLAN configuration would already allow to configure a VLAN on eth1.

The PR ipq40xx: introduce proper ethernet and DSA support doesn't mention the EA8300, so I'm not sure if it would address my specific problem.

IPQ40xx devices do not use DSA in 21.02 stable. However, the UCI syntax in /etc/config/network has changed from 21.02 onwards.

Best person to answer this question might be @NoTengoBattery.

You may wish to try his custom build which I recall fully supports VLANs etc.
https://forum.openwrt.org/t/optimized-build-for-ipq40xx-devices/44125

1 Like

Thanks for the links and hints.

So my summary is:

  • with OpenWrt 21.02, the DSA (Distributed Switch Architecture) is not implemented yet for openwrt-21.02.1-ipq40xx-generic-linksys_ea8300-squashfs-factory.bin
  • for switch0/eth0 in the EA8300 device, the old swconfig framework runs fine and can be used for VLAN configurations
  • eth1 in the EA8300 device can't be used in a VLAN configuration with OpenWrt 21.02
  • implementation of DSA for the EA8300 is work in progress and hopefully will be released in the near future (test builds are available)

For my EA8300 device, I will omit the usage of eth1. I tested my VLAN configuration successfully with the usage of the 4 ports of the eth0 switch.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.