Linksys EA8300 gets bricked if I change the LAN IP ( edited )


Sorry if this is the wrong place to post this topic but here goes:

I am using OpenWRT since yesterday, and I tried it in an old ASUS router I had, and... wow. This is amazing.

After sucessfully setting up that ASUS router, I proceeded with flashing my Linksys EA8300 with the latest version too.

The problem is, with the Linksys, if I change the LAN IP ( edit: I was referring to this as "vlan default gateway", which was not correct) ( I changed it from to ), I cannot access the device anymore ( no ssh, no ping, nothing ). I tried resetting it several times, and still nothing.

I thought I bricked it, but after lots of fiddling around I was able to boot from the 2nd firmware feature this model has ( after finding out about the on/off procedure 3 times ).

I flashed a factory firmware again in that slot, rebooted and flash openWRT again, and it is now working again ( I am posting this connected to it, bridged to my home router ).

The thing is, I am now concerned about doing any more changes in this model because I don't want to brick it.

Has anyone experienced any similar issues? Am I an idiot? With the ASUS router everything went absolutely fine and I was always able to reset it.

Thanks in advance!

Do you really mean "the vlan gateway" or "the WAN gateway"? Anyway, I think we need more info on why you need to change it.

I mean changing the vlan gateway, because with OpenWrt the default gateway is and my main router's gateway is also, so that there is no conflict I choose to change the OpenWrt's router gateway instead ( OpenWrt's router is connected to the main router as a client and all the devices connected to it have access to internet ).

I am not a network expert, so I don't exclude the chance that I am doing something stupid.

But, I decided to ask this because I had no problems with the first router, I am not an expert on the matter, and I am out of ideas.

The problem with the Linksys EA8300 is that if I change the default IP to access the configuration ( either through ssh, LuCI ,etc ), I cannot access the device anymore ( does not even respond to pings in both the previous and the current IP ), and the reset button doesn't reset the settings either. Only powering it on/off 3 times to switch to the 2nd firmware image brings it back to life, allowing me to write a new firmware again ( And still,if I simply write OpenWrt again after that it still won't work, I have to first write a stock firmware back, reboot, and then write an OpenWrt bin again ).

I had no such problem with the rt-n56u router and I did the same things, so I am just wondering what could have gone wrong.


what IP do you set your OpenWRT router to, for it to become unresponsive ?

I set the linksys to ( Default is ). The Asus was set to ( works absolutely fine).

But still, I could not access the linksys after pressing the reset button for 10 seconds.

If noone else experiencied this before, maybe I did something wrong.

I'm sure you mean "LAN IP". Did you hit the big red button that said "Apply Unchecked"?

Yes, that's what I'm changing, in Network->Interfaces->Lan->Edit

My apologies for the confusion of concepts.

I used "Save and apply", not "Apply unchecked".

Is there any method I can use to have a failsafe B plan in case something goes wrong?

The reset button does NOT restore the settings as I mentioned, so I am concerned about making more attempts.

How about a script that sleeps for 5 minutes and restores the lan's ip to if it cannot ping an ip of my choice? Is it a stupid idea?

Make only the one change of the IP address and click "Apply Unchecked". Then disconnect your PC from the router wait about 30 seconds then reconnect it so it gets a new IP address (which should be in the .3 range instead of .1). Enter the IP you set in the browser address bar.

You do not seem to be using VLANs, I do not think that term applies here.

When you configure a gateway in a router, you are merely informing the router of the IP address of another router, that can be used to forward traffic You are not changing the IP address of the router, you do not resolve a IP address conflict by changing the gateway.

if you change the IP from to, you will not be able to reach the router again, unless you change the clients IP (or get a new IP in the 192.168.3 range from the router)

Check your primary routers DHCP range, then set the Linksys IP in the same subnet, but outside the DHCP range. So ....

Another method is to set a fixed lease in the DHCP config, linked to the MAC address of the Linksys.
But then the Linksys have to be set up as a DHCP client on the LAN side, instead of static IP.

Thanks for the input. LAN IP it is. :slight_smile:

I found someone with the same problem:

I found that thread after noticing it that when I try change the LAN IP I get 2 pending changes, one is this one ( the difference here is that I cannot reset the settings, I need to reflash the firmware ):

and the other is the LAN ip change

So, now I know I am not crazy.

BTW, I want to share some additional info if someone needs it in the future... To switch to the backup firmware in the Linksys EA8300, turn it on, wait for the leds on the ethernet ports to go off and the Linksys letters light, shut it off. Do this 3 times ( no need to wait 15 seconds with it on and 10 with it off as I read somewhere ). The 4th time you turn it on it will boot the alternate firmware. At least this is the case with hardware v1 and stock firmware 1.5.

Ok, just an update, if I make this change through SSH ( editing /etc/config/network and re-starting the script ) everything works as intended. So, I will use this method instead in the future.
Thanks again!


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.