Linksys EA7500 V2 Installation Failing

While it would technically work, I'm unfortunately not in a position where I can leave the router offline for extended periods of time, which would be required for me to do that. If my only option is to use an additional router I think I just might be out of luck for using OpenWRT here.

Would it be possible to somehow use a VM running another instance of OpenWRT to assign an IP address to my physical router? Doing something like connecting the WAN port on the router to an Ethernet port which has been passed to the OpenWRT guest?

I've looked at the OpenWRT on VirtualBox HowTo page, but I'm not sure if it would allow me to solve my problem.

Using Virtual box is possible.

I don't know what OS you run? I wonder if it is possible to use a portable DHCP server app to run on a spare computer wired to EA7500 wan port?

Here's one I randomly found for Windows 10 for example.
http://www.dhcpserver.de/cms/

Random Google searched instructions for ubuntu
https://www.techrepublic.com/article/how-to-setup-a-dhcp-server-with-ubuntu-server-18-04/

As an alternative, could you ask friends and family to see if they have any unwanted router that you could borrow?

Also as the EA7500 is your only router, have you considered the small risk that if you totally brick the EA7500, it will leave you without internet access until you buy a new router?

I'm currently running Windows 10. I'm in a bit of a weird position right now that results in me only having access to this one router (unless I purchase another, which while its something I'd rather not have to do it's certainly not an impossibility). I have considered the risk of bricking my current EA7500, but from my understanding it is a pretty unlikely outcome, unless of course I've misjudged the risk. Like I said, I'd prefer not to spend the money for a second (or a replacement) router if I don't need to, but if push comes to shove I can.

With regards to running a DHCP server, I am correct in my understanding that I would have to connect the physical router to the server via its WAN port, right? What you're suggesting is doing what I described in my previous reply, just using a DHCP server running on a host machine, rather than a VM guest.

Looking at the wiki page I previously linked, would the correct VM configuration be to bridge my host's Ethernet port as the guest's third network adapter? That is what the wiki page seems to suggest. I tried this, but was met the same unsuccessful result as with my previous attempts. Perhaps I configured the VM incorrectly. What I had done was configure the first adapter to be host-only, the second to be NAT, and the third to be a bridge to the Ethernet port.

Sorry, I can't help with OpenWrt on VirtualBox.

I suggested DHCP server app on a spare PC, because using VirtualBox seemed like 'overkill', provided you can get it working.

This may be helpfull. It's not the same device, but the software and issue should be almost identical.

Fair enough. I had originally thought to look to VirtualBox because it was a tool set I already had set up, so why not try it? If you think using a simple DHCP server and connecting the router via the WAN port is my best bet, that's what I'll go with. I really appreciate your help. Thank you!

I'll provide my procedure here for others in the future with this problem if I get it working.

I had looked over that page and aside from the odd bootcounter bug with the EA7300 V2 the EA7500 V2 looks nearly identical. From my understanding of the bootcounter issue, it is possible to install OpenWRT (after manually reflashing the OEM firmware), but unless the S_ENV partition is removed OpenWRT will become unbootable after three power cycles, meaning that the bootcounter is incorrectly incremented on successful boots of OpenWRT. There is no mention of this issue on the EA7500 V2 wiki page, but if I run into it I'll reference the EA7300 V2's page. Thanks for the link!

Despite being flashed and bootable, the OpenWrt partition is not declared as valid. And so after three boots, the booloader switch to the other partition. The goal is to install OpenWrt on partition A while Linksys firmware is on B.
Of course I can't guarantee that this trick will work onto the EA7500v2, but it may be a clue.

Ahh. Alright that makes sense to me. I had misinterpreted what that page said. I'm glad I restated it so you could point out I was wrong. I imagine that if I go this route I run the risk of bricking the router because I won't be able to "reset" or boot back to the OEM firmware, right? Like you said, this fix may not even apply to the EA7500 V2, or at least my situation.

no I never got it installed. I suspected somethings up with this particular hardware so need to add a serial cable to debug.

Although, come to think of it I did the original working install on my other device via a snapshot build (as at the time, the 7500v2 wasn't yet fully supported). I'm wondering now if maybe something got broke in the latest official release... it's not a high priority for me now but maybe I'll try using an old snapshot or something one time.

Yes I can't guarante that the fix could apply to the EA7500v2, although both devices are very close.
If you flash OpenWrt on both partitions, I don't know if any will still be declared valid after three reboots. I didn't dare to try, I don't have much experience with Linksys double partitions. The only other Linksys device I have (MR8300) has no such issue.

I wanted to leave a final reply for anyone in the future encountering the same issues as I did with the EA7500 V2. As it currently stands, I've given up/postponed installing OpenWRT on my router. If at some point in the future I try again and manage to get OpenWRT installed successfully, I'll share what worked for me and update the EA7500 V2 wiki page. Until then, assume I haven't tried @badulesia's suggestion or otherwise gotten OpenWRT to work on my device. Thank you all so much for your help!

1 Like

I flashed EA7500 V2 with OpenWRT factory version successfully today with the instructions here I found. 1. Flash back the OEM firmware. 2. Reset the router to original setting in GUI. 3. Flash the OpenWRT firmware, the router will restart and wait for the light to be stable. Logging with 192.168.1.1, then the OpenWRT GUI came out.

That means that you have installed Linksys firmware on partition B, than OpenWrt on partition A.
You can now boot OpenWrt on partition A but ... did you reboot several times ? That is when the issue apparead. After 3 boots, that seem valid as you start on OpenWrt, the bootloader will switch to Linsys firmware on partition B.

I didn't boot several times. Just one time. But, before I knew this method(flash back to OEM), I failed to boot from openWRT, I have restarted the router some times to check.

I also faced this problem but managed to successfully install openWRT, posted my steps here: Problem installing on Linksys EA7500v2 - #15 by banisodaro

The solution for OpenWRT on Linksys EA7500 v2 is:

  1. Download the latest Linksys EA7500 v3 firmware from Linksys
    https://www.linksys.com/us/support-article?articleNum=183933
  2. Download the latest OpenWRT firmware from this site.
  3. Connect your laptop/desktop to EA7500 via Ethernet cable; log in as the router admin.
  4. Flash the Router with Offical Linksys Firmware; the router will reboot
  5. Flash the Router with OpenWRT Firmware; the router will reboot again
  6. While connect to the router, find the new IP address and connect via browser; you should be able to configure the OpenWRT router now

All the best!

Hi.
Doing so mean that you installed OpenWrt on partition A. Does it boot several times than, at least 3?

Hi, sorry just do I got it correct. Do you mean v2 or V3 firmware? If it v3, wouldn't I brick the router? Thank you.