Problem installing on Linksys EA7500v2

Hey folks I've been trying to install OpenWRT on an EA7500v2 but haven't been able to get it to work.

I followed the guide here This is actually my second EA7500 v2. The first one was able to flash without any issues.

The first device (which I acquired a while ago) I had a temporary hiccup because the flash seemed to fail. As described in the docs I realized it was due to the dual-boot issue and then flashed the stock firmware, before getting a success.

The first one worked so well I ordered a second EA7500v2. This new one I just got however I haven't been able to successfully flash to OpenWRT. It just keeps going back to the stock firmware. I've tried several cycles of flashing the stock firmware and then flashing OpenWRT as described in the guide with no success. Any ideas? Is there any way to see some kind of debug log from the stock firmware?

Bump in case anyone can help :pray:

You'll probably need to use the serial console to see what's going on ...

You could however try to use an older version of the openwrt install image, just in case there's something wrong with the most recent one(s).

Read this.

Ok it's for the EA7300 and you have an EA7500, but the issue is probably the same.

The goal is to flash stock firmware on partition B from partition A. At next boot, it will be on partition B. Flash OpenWrt, it will be on partition A. Reboot, you should be on OpenWrt. Reboot several times. At the 3rd, you should not boot on OpenWrt, but into the stock firmware. This means that you have the same bug that on the the EA7300. The solution should work as both devices are almost identical.

Complete infos in the link above, and on this thread Can not install OpenWrt on Linksys EA7300 v2 - #11 by thosmos

@frollic might have to use a serial cable.

@badulesia the same instructions are in the EA7500 guide and I had to use that to flash my first one. But as I mentioned I've flashed this one several times and it continuously fails. I think possibly even the stock firmware flash might fail, I have no way of knowing it succeeds

Do you mean that ...

  • Linksys GUI refuses to process the flashing, or cancel while flashing ? Any error message ?
  • the flash process can be done, the device reboots, but you don't get openWrt. So it boots again on Linksys ?

It seems to be the 2nd case. Can you confirm that you can enter Linksys GUI, and flash again Linksys GUI with it ?

@badulesia yes within the Linksys GUI I'm able to trigger a flash and the device reboots.

I've tried several cycles of flash linksys firmware, flash openwrt, flash linksys firmware, flash openwrt, flash linksys firmware twice, flash openwrt, but it still always reboots back to the default linksys firmware.

As far as the stock linksys firmware goes since the router is already at latest it seems hard to confirm if that flash was even successful. If I had an older version of the stock firmware I could downgrade/reupgrade but I haven't been able to find one.

Ok, you have done every combinations.

I don't know if there is a possibility within Linksys GUI to know which partition is booted.
You may use a serial cable to monitor the boot process.

Agreed. This also can interfere.

On a Linksys EA7300 v2, I noticed that my flashes seemed to work but the Main "Linksys" LED would flash for several minutes and then boot into the fall-back OEM firmware. This did not happen with my DSL modem router. For me, the new cable modem only provided a DHCP IP address within a limited time window during modem boot and without an IP address on the WAN side, the OpenWRT firmware would fail to load and make 2 more attempts. My old DSL modem had router capabilities and was setup to provide the router w/ an IP address - OpenWRT would boot without issue..

My work around was to have a modem to router ethernet cable in place and power on the modem as I started the router. Since then, I've been running without issues.

So the device fails to boot safely OpenWrt if no IP is provided quickly by DHCP? What is happenning if there is no WAN link ? I have flashed and setup a EA7300v2 without WAN link. The idea was to avoid Linksys GUI from self-upgrading just in case it has an automatic process. I remember connecting WAN after the device succesfully booted 4 times Openwrt.
The device is now in a relative's home and it works fine but ... it is behind a modem that provides IP by DHCP ! Exactly what you describe.

I'm not sure where the problem occurred. I built, installed, tested and submitted the EA7300 v2 at a time when I had slow DSL (4.5Mbps down) and once I had it running, shelved the router in favor of a Trendnet TL-810DR. The 810 could handle the meager speed easily. My DSL modem was set up to provide a Single DHCP IP address to the router and I did not have issues with the EA7300 v2.

I since changed ISP's to one that provided about 120Mbps down and would benefit from 10/100/1000 WAN/LAN ports. I transitioned the router from my snapshot build to the 21.02.1 binary, previously downloaded on the DSL connection, when I noticed the problem with failed boots.

I threw this out to see if the OP noticed that the LED flashing occurred with 3 cycles and went on for an abnormally long time. This scenario also suggests that the problem is not with the flashing procedure but 3 successive failed boots falling back to the OEM firmware. For me, this all went away when I powered up the modem and router together.

I would also not infer that all modems are equal. My DSL modem (Netis DL-4201) had multiple configuration options/services. I think I was double NAT'ing until I DMZ'd the router. My cable modem only allows the setting of a username and password. I'm still not sure what my cable modem/router link is, ?PPP, although my router uses the stock OpenWRT dhcp IP setting.

The other thought is if the system jack senses the WAN port and there is an issue with a sensed port but no WAN?

The modem I use is an ADSL freebox (french ISP Free), it provides a full service (DHCP, DNS, NAT). There is no need of any config: just plug and it works. It self identifies and configures with the ISP proprietary network. The OpenWrt router is configured as a client and DMZ. Nevertheless when I configured it, it was with no WAN link.

The original firmware definitely has issues if it can't find a WAN link. I moved my main router to a different subnet to avoid conflicts and had the second one connected to that, and was able to obtain DHCP no problem at least with the stock firmware.

I would guess that the stock oem overwrite followed by OpenWRT flashing would now work with the device on the subnet.

Another caveat, on my 21.02.1 install, the /etc/rc.local hack described in the toh did not initially function. On review, /etc/rc.local did not have execute permissions on initial install:

To fix
chmod a+x /etc/rc.local

I just managed to successfully flash openWRT on my EA7500v2.

I flashed the OEM firmware "FW_EA7500v2_2.0.8.194281_prod.img" 4 times. As of this posting, its the one linked in the installation guide.
Then I flashed openWRT "openwrt-21.02.3-ramips-mt7621-linksys_ea7500-v2-squashfs-factory.bin".
The WAN port was not connected at any time and I did not need another device for DHCP assignment.
After successfully installing openWRT, I tried rebooting 3 times and never got booted back into the OEM firmware.

I had previously followed the installation guide and other comments about following a particular sequence but it did not work and I kept being rebooted back into the OEM firmware. Hope this helps others looking for a solution. Best of luck!

1 Like

My God, I have tried EVERYTHING that was described here, including the "solution" for EA7300. I tried rebooting the router 3 times, installed OpenWRT, install stock firmware 4 times, then install OpenWRT, SSH in and edited the file as described for EA7300, and every time I rebooted the router, it will go back to stock firmware!

I have exhausted all options and frankly, I'm quite fedup. There must be a more surefire way to do this. Help!