Linksys EA7300 safe to use OpenWrt

i see that the 7300 is supported, but before i execute the upload, i get a warning that the file is unrecognized and before i brick my router and have to get another one, is it okay to ignore this warning?


Mega Thanks to @ergamus for remoting in and assisting me!

Suggest that you double check the hardware revision of the router.
According to OpenWrt Techdata,
Versions 1 and version 2 has different WLAN hardware.

ive confirmed its a V1, via Linksys and a supported firmware is here on OpenWRT.

Straight from Linksys

" The Output voltage for the Linksys EA7300 v1 is at 12 V, 2.5 A while the Linksys EA7300 v2 is at 12 V, 2 A ."

my power is 2.5A , serial number also confirms a V1 package.

and that does not answer my question concerning loading in the firmware for OpenWRT and the router throwing me that error.

i tried the V2 package and it gave me the same error.

okay so it works, i flashed over to OpenWrt, but now it refuses to allow me to connect to despite my IPV4 Default Gateway is in fact

uuugh, yet im 100% Connected to the internet..... lol

any ideas anyone?

im obviously connected to the internet, also, i noticed my Connection Specific DNS Changed, it just says "lan" now, with the Linksys it had something completely different. gives me this on 5 different browsers

Ive rebooted the PC, rebooted the route, 10 second reset button on the router, netsh reset my ip, tcp and winsock.

yes, i verified three times, this is a EA7300 V1, and confirmed the firmware as the one for the 7300v1

im at a loss now.

Can you connect to via SSH? Use PuTTY if you don't have a good SSH client on hand.

Can you link the firmware you flashed? It's possible that it's a snapshot version, which doesn't have the LuCi web interface installed by default.

login as:

is what it says

Try root, empty password.

putty works

returned this

Try this, I hope it'll work for you:

ive forgotten my SSH stuff, lord

so with the SSH Command line, how do i grab the updates?

I'd try the steps ReDaLeRt posted in the link above:

# opkg update 
# opkg install opkg
# opkg update
# opkg install luci

First command fetches the package repository information.
Second command tries to install the latest version of opkg.
Fourth command tries to install the LuCi web management interface.

oh okay, i was unaware those were commands, i have literally zero linux experience

the update command threw me a bunch of stuff, and resulted in the last line saying this:

did the second update, got that same SRC Declaration, moved on to the second update command, got a bunch more output, then tried the install luci, and got this:

I guess ill sit out using wifi for a bit, everything wired is working fine.

how do you copy from Putty? cant seem to get that

Based on this topic:

There is a duplicate line in one of the files in /etc/opkg/, either in customfeeds.conf or distfeeds.conf.

I'd move to that folder with: cd /etc/opkg, and then look at the content of each file with:
less customfeeds.conf
less distfeeds.conf

One of those files will contain a duplicated entry with the text: openwrt_kmods. Possibly the entire line you see in the error message. Try to find which file it is, and I can try to guide you on removing the duplicate line.

Sorry for being so vague, I'm working blind, as I don't have the same file contents you do.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.