Opkg doesn't install dependencies, or get configured

Hmmm.. maybe. It was 2 days ago, while my snapshot was from yesterday.

I see there was a kernel change in the last 4 hrs or so, anyone try a fresher snapshot than that to see, or am I going to be the test animal? :confused:

Other than the general danger of newb updating firmware from the command line (for the first time), is there any other danger in this particular situation? In other words, should I wait till things are "normal"?

Well, bit the bullet and installed Nov 1 snap. Same issue, two kmods locations.
Remove one of them, update, opkg install luci... still single line response and no functional Luci. This is the first time I've had this problem with snapshots and the C7.

Going back to 19.07.4, and forgetting about chasing the C7 wifi/memory issues for now, as well as exploring some improvements to the wifi airtime fairness and quality management. :frowning_face:

On the NanoPI R2S (with snapshot built from 30-10 and 1-11) I have the same error.
Hope a fixx will be released soon!

After a snapshot upgrade, I lost luci and there is another bug related to opkg config: https://bugs.openwrt.org/index.php?do=details&task_id=3422&order=dateopened&sort=desc

After many hours trying to get this last snapshot working and failing to do so and reverting to the previous one and getting errors about the newer kernel dependencies, I had to revert to stock firmware.

This is a mess! -.-'

This was just fixed by dangowrt and is already pushed to opkg.git. next snapshot tomorrow is hopefully fixed.

Sorry for the inconveniences and thanks for testing!


Glad for your precious help and effort! @aparcar

Kudos to you!

1 Like

Thank you for the update and the hardwork @aparcar

1 Like

The fix has now been pushed in the main OpenWrt repo:


And another fixup. Sorry for the issues, opkg is heavy legacy code with many sticks and stones to break our bones.

1 Like

Wow, everything is working so much better now!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.


I have the same problem, still after the update.

Running x86-64 OpenWrt SNAPSHOT, r14850-f5c5a8abd2, from generic-ext4-combined.img.gz

As today (November 3rd, 2020 - r14850-f5c5a8abd2), the snapshots don't have the latest opkg package installed.

Experiment this as final solution on your snapshot image:

# opkg update
# opkg install opkg
# opkg update
# opkg install luci

Have fun.

1 Like

Will the tomorrow snapshot have the issues mentioned here resolved?

Buildbot continuously builds images after changes, and right probably half of the target images already contain the newest version.

1 Like


But regardless that, you may install any snapshot available and execute this:

OK, in trying to follow the directions you linked to mark it as solved, I am unable to edit the title to put [solved] into it, and the three-dots menu with 'mark as solution' doesn't match what is on this page, so I just checked "Solution" on the most pertinent posts.

Thanks again!

1 Like

Perfect thank you !

opkg install opkg
is like apt-get install aptitude
is like internet-explorer downloading chrome/firefox

Opkg is installing dependencies in latest snapshot squashfs image for nanopi r2s. I was into the luci interface without issues, in just a minute or two after booting a fresh snapshot image.

root@OpenWrt:~# opkg update
root@OpenWrt:~# opkg install opkg
Package opkg (2020-11-03-da9746aa-2) installed in root is up to date.
root@OpenWrt:~# opkg install luci
Installing luci (git-20.308.22927-855e724) to root...
Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_generic/luci/luci_git-20.308.22927-855e724_all.ipk
Installing uhttpd (2020-10-04-14a3cb42-2) to root...
Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_generic/base/uhttpd_2020-10-04-14a3cb42-2_aarch64_generic.ipk
Installing uhttpd-mod-ubus (2020-10-04-14a3cb42-2) to root...
Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_generic/base/uhttpd-mod-ubus_2020-10-04-14a3cb42-2_aarch64_generic.ipk
Installing liblua5.1.5 (5.1.5-7) to root...
Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_generic/base/liblua5.1.5_5.1.5-7_aarch64_generic.ipk
Installing lua (5.1.5-7) to root...
Configuring luci-mod-network.
Configuring luci-mod-admin-full.
Configuring luci-proto-ipv6.
Configuring uhttpd.
4+0 records in
4+0 records out
Configuring uhttpd-mod-ubus.
Configuring rpcd-mod-rrdns.
Configuring luci.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.