LAN speeds are horrible after upgrade to 21.02.1 (wrt32x)

I see. I am a firm believer in "If it aint broke don't fix it" mentality, but I do also like to stay as up to date as I can.. :slight_smile: I appreciate the advice.

That might come in handy if I get this LAN speed issue worked out, but its not doing anything at the moment. :frowning:

Linksys devices are a "special case" when upgrading from 19.07.8 to 21.02.1

So I suspect 2 things happened...

  1. You upgraded 19.07.8 to 21.02.1 using the sysupgrade image.

  2. You kept the configs from 19.07.8

All that that your on 21.02.1 (which may be partially broken), I would suggest re-flashing with the 21.02.1 sysupgrade image, and re-configuring from scratch.

Failing that, you may need to downgrade to 19.07.8 (using the factory image) and then upgrade to 21.02.1 using the correct steps (factory instead of sysupgrade) outlined above.

You would not keep the configurations in this case as well.

All this should be done on a wired connection.

The advice is right, he needs to use "factory", but the reason is wrong...
DSA config does not force any need to use the factory image. DSA change causes just the need to wipe the config (at least the network and system config files).

But as a specific case, wrt32x and wrt1900acv1 needed bigger kernel partition, and that change requires the factory image. So yes, the OP needs factory image to sysupgrad from 19.07 to 21.02.

Sounds right.
If OP is already running 21.02, doing a sysupgrade from "possibly broken" 21.02 to second 21.02 should work ok with the sysupgrade image, as the currently running 21.02 already knows the new partition structure ( in the current DTS). Doing a sysupgrade without keeping settings or restoring them afterwards sounds right.

Wrong. Should not work due to the partition size change. Factory image would be needed for the downgrade to 19.07.

I'll modify my post...but it sounds like the wiki needs to include that info since I've seen different explanations and advice.

Like already said by others, your problems likely started with keeping/restoring incompatible settings from 19.07.

Regarding wrt32x, please be advised that the mvebu mwlwifi WiFi is somewhat more unstable with 21.02.1 than with 19.07.x releases.

The reason is an upstream Linux bug that was found by OpenWrt two months ago. The bug has already been fixed in master and 21.02 branches, but not in the old static 21.02.1 release. Link to discussion below.

If your family already had WiFi connectivity trouble with 21.02.1, you might stay with the (ok working?) 19.07 until the 21.02.2 with the fix gets released.

The other option is to sysupgrade to the daily 21.02-snapshot. Link to the 21.02 snapshot in the discussion below.

Edit: I think that the 21.02 snapshots actually have LuCI, so I removed the part saying that you might need to opkg install LuCI manually.

Ok, I have flashed a the sysupgrade file, and performed a hard reset from within LuCi..I've made no other adjustments to the router except adding an admin password. I have disconnected as much "extra" stuff from the network to simplify my trouble shooting. I have not setup wifi, but wifi was screaming fast, even with my VPN running.
Here is the layout, presently. Cable modem into Linksys WRT-32X, that goes downstairs into a Netgear gigabit switch, that feeds into this room into a Netgear R6200 setup as an access point. 2 computers on this network, again, feeding from the R6200, show radically different speeds. PC A, full speed from the ISP, and then some, about 225mbps. PC B gets around 120mbps. Both have static IPs, and both have been rebooted and reconnected. PC C is attached to the network thru an 8 port switch, which is attached directly to the router, and in the same room. Its getting pretty much the same half speed of what the ISP has available.

The connectivity issues I spoke of were not wifi related. My partners home office PC is attached directly to the primary router, the WRT-32X. Her connectivity issues seemed to have ceased with the hard reset on the new firmware a couple of days ago, when I reflashed the new 21.x.x firmware and completely reset it. I have no speed data on her PC, as I don't like to mess with it. I just have to make sure it has rock solid internet so she can do her job. :slight_smile: -)

I read about the wifi issues being fixed in the snapshot image. I wasn't having wifi issues, per se, but would you suggest I flash the snapshot image? I've worked with networking over the years, not to the extent of you knowledgeable folk, but enough to be baffles by this current anomaly.. I really appreciate everyones assistance with this.

Ok, so you are saying I need to flash again, but using the factory image, and not the sysupgrade image? Is there anything special that needs to be done to flash that one? Can it be flashed from LuCi?

I'm glad I don't have to go backwards, aside from the pain in the arse it sounds like, I would prefer to move forward and fix the most recent "stable" or snapshot, whichever will fix this issue..

If everything seems to work, just be happy with the current 21.02.1
Wait for the 21.02.2 and sysupgrade then.

Regarding images:

  • If you are running 21.02.x and are sysupgrading to 21.02.x, use sysupgrade.
  • If you are running 19.07.x and are sysupgrading to 21.02.x, use factory.
  • If you are running 21.02.x and are sysupgrading (downgrading) to 19.07.x, use factory.

Everything does not seem to work. At least not properly, as it did prior to the upgrade. At least 2 of my PC's are still only able to get half the speed they should be getting, and like I said 2 PCs on the same secondary router getting night and day different speeds. Very confusing to say the least.

I'd like to flash the factory, if that will possible get me to the proper setup, and partition configuration going forward.

It likely won't help, as if you are able to run 21.02 successfully, you likely already have the correct partition structure. Otherwise the rootfs would not be properly readable as it would start from a wrong location.

And you have done reset already. So, another sysupgrade to 21.02 might not help much.

Is it flashable from the web gui in 21.x.x? Or does it have to be downgraded and then reupgraded? I don't wanna dick it up any more, but this issue really sucks, and I would like to get it resolved..

I have found the answer to the issue I was having. I am more than a little embarrassed by the discovery, however I feel I have to share so that others can learn from it.
I'm going to upload a picture of 2 speed tests, on the same computer. One test conducted in the windows version of the by ookla app, and the other test was ran at the actual website of the As you will see the difference is almost exactly the difference I was seeing between the 2 PC's I've been testing. PC A didnt have the app installed so I just ran the test thru the browser..not thinking anything of was showing full throttle speeds as expected. The other PC B, was tested thru the app.
I am just blown away by this. I hope my frustration can benefit others.
Thanks again to you all that provided your assistance in this matter..I appreciated it very much.

So enjoy it

And the last tip, check if the cable is OK with status errors:0, else replace it.

root@OpenWrt:~# ifconfig br-lan|grep dropped
          RX packets:1284274 errors:0 dropped:215 overruns:0 frame:0
          TX packets:2169175 errors:0 dropped:0 overruns:0 carrier:0

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

In theory the app should be more efficient, maybe try using the CLI .exe

The main reason for this being "a bad idea" in the article seems to be the limited amount of disk space that could run out when downloading/installing the packages in the r/w overlay. On my routers, I usually have an external USB drive with plenty of space as an overlay filesystem (gigabytes), which allows me to actually keep my packages up to date.

When doing the full upgrade, I have to do it from scratch, which is the downside... I documented it well, can just copy and paste the script, bit by bit. With major upgrades, I'll have to apply any necessary changes to those scripts, though.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.