LAN speeds are horrible after upgrade to 21.02.1 (wrt32x)

I upgraded to 21.02.1 a day or so ago. LAN speedtest are like 12-15 mbps, but WIFI is showing the "normal" speed of my provider, around 225mbps. Tested on several computers throughout the house, same performance. I've been adding a few routers and switches around the house, so I thought that could somehow be an issue, but one PC is 10 ft from the router, going thru a simple gigabit switch, same configuration that a few days ago worked as expected, speeds as expected. I sure hope someone can help with this. Thanks.

Upgraded from what?

And you have reconfigured to DSA setup?

What is your speedtest result when connected directly to the router?

Possibly a collision issue or spanning tree / switching loop problem. Or you have multiple routers advertising dhcp.

With so little info it’s hard to know

1 Like

I upgraded from OpenWRT version 19.8, I think it was. The second part, I'm afraid I don't know anything about that, but if it needs setup, I'll be happy to do it.

There is no such version. Maybe 19.07?

What device are you using? When you did the upgrade, did you keep settings?

What type of info would you like? I'll be happy to oblige. Its rather difficult to get a computer connected directly to the router, but there is a PC that goes into an 8 port gigabit switch, and that goes directly into the router. Its speeds are the ones I mentioned...12-15 mbps. WiFi speeds seem to be fine. I don't recall what my 2.4 ghz was normally getting, its currently getting 64.3 down, and 9.27 up. 5 ghz is getting full speed from my ISP (200mbps), 217 down, and 9.42 up.
I was suspecting a DHCP issue, as well, and began checking all of the routers around the house. I believe that they had all been setup correctly when they were put into service. However, I've been unable to connect to one of them, it has no IP on my network. One PC connected thru it has blazing fast, full ISP speed, and another has the same pitiful 12-15mbps speeds. I swapped the ports, and each one retains its same speeds.
If I can't get logged into it pretty quick, I'm going to remove it from the network, and do additional testing. Probably end up just resetting it back to factory, and reconfigure it.

Could you draw a diagram of your network? That might help us understand how things are connected, especially if you have additional routers/APs in your network.

1 Like

Ok, 19.07.8 maybe? I thought I remembered seeing an 8...anyway, upgraded a day or so ago. Its a Linksys WRT-32X. Originally, kept settings, or restored a backup of settings I don't remember which, now. I was having some connectivity issues, and switched to the other partition, and was using the old firmware. My partner works from home, and she was having connectivity issues, and I decided to just do a hard reset on the router in an effort to keep her connected and able to do her job. After she got off work that day, with 2 days vacation coming, I had time to switch back to the upgraded firmware, and again I did a hard reset to start with what I hoped would be a clean slate, and I like to keep up to date on firmware, and I liked some of the new features. so, here I am. :slight_smile:

did not catch it earlier...

did you use a stock (original) 21.02.1 image or an imagebuilder based image?

Reset your router to defaults and configure from scratch. The upgrade from 19.07 > 21.02 involves a major change to how the ethernet ports are managed, and your previous configuration is not compatible.

1 Like

I followed a link to the upgrade file for my device. I don't know the difference between those types you mentioned, sorry..

1 Like

They are pretty much just as they were after I did the hard reset except for some devices having static IPs, and some port forwarding entries. I was trying to read up on that DSA the other fella/person was talking about. sounds like it could definitely contribute to some issues if its not right. I'm going to read some more, and hopefully I'll be able to figure it out, and get it all setup properly. So, I just read your message again, to make sure I didn't miss replying to something, and I want to make sure I understand what you mean. Do I have to configure that DSA myself, or is it preconfigured by default? I flashed the firmware, and did a hard reset on the back of the router. Thank you .

If you aren't running VLANs or anything more complex than a basic network, the default configuration will be mostly what you want. At this point, the best way to handle this is to go to System > Backup / Flash Firmware > Restore > Reset to defaults -- after the reset is complete, your router will be in the default configuration. You can then go in and setup wifi and other basic things. Check back here if you plan to make any changes to the basic networking.

1 Like

The base image is a bit slow as you reported.

Recently I did a reset and my link 600d/300u was horrible... only 380/300. After upgrade to the current update, the connection was fixed.

opkg update
opkg list-upgradable | awk '{print $1}' | xargs opkg upgrade


I did the reset to default that the other person suggested, and I tried the commands you gave me. The first one completed fine, but the second one had errors. Looked like it had trouble downloading some of the files, and I saw a few "operation not permitted" lines. Do I have to configure the wifi before I run that? I'm working on it from a wired connection..

This is a bad idea.

Upgrading packages (via the CLI opkg upgrade command or the LuCI Upgrade... button) can result in major problems. It is generally highly discouraged, unless you know what you are doing or if there is specific instruction to do so.


Reset again. Please do not run the opkg upgrade command.

Ok. Its reset....again. So, if you can't upgrade from the CLI, and you can't upgrade via do you upgrade? That seems a little confusing. :frowning:

You use the sysupgrade feature to flash a new image. For most users, this means when there is a new stable release (i.e. 21.02.1 > 21.02.2 when it comes out).

You do not need to upgrade packages in 99.9% of the instances, unless there is a specific reason to do so (a bug fix, feature addition, or security patch). In those specific cases, you'll know what you are targeting and there will be instructions to do the upgrade safely if that is ever necessary.

The key takeaway should be not to blindly mass update your packages. Targeted packages, sometimes (but rarely), will be useful or necessary.

The second command just filter the package name to run all-in-one step of the upgrade.

If you already upgrade all avaliable package, then all is right.

Try enable packet steering (Use every cpu to handle packet traffic)

uci set network.globals.packet_steering='1'
uci commit network