LAN speed and smart connect enabled Problem 22.3.3 to 22.3.5

Hello sir, I am facing network problem after upgrading from OpenWrt 22.3.3 to 22.3.5. Seems to be experiencing a slow internet connection and a LAN-to-PC connection problem Before the upgrade, the Pc LAN link speed was 1000/1000 Mbps, but after the upgrade, it dropped to 100/100 Mbps. Additionally, wireless connectivity uses Smart Connect, which combines both the 2.4 GHz and 5 GHz bands. However, I prefer to keep the 2.4 GHz and 5 GHz bands connected separately and so would.

Tp Link Archer C6 V3

Normally (and now, too), I'd suggest checking the cables. Even high-spec cables that are new can be faulty. Also check the ports for any physical issues such as bent pins or debris. If you have any intermediate cables or connections (i.e. structured wiring, patch panels, couplers, etc.), check those, too.

Also, I'd say you should check your PC's settings to make sure it is set to gigabit/auto-negotiate.

If those don't help, I'd recommend rolling back to 22.03.3 to verify that you are indeed getting gigabit connectivity between the router and your computer. It is pretty rare for the firmware version to be the factor here, but in some rare instances it can happen. In the case of the C6, there is a hardware switch chip inside the device that is connected to the lan ports, so it seems really unlikely that it is firmware version related unless there is a serious misconfiguration of the switch chip (could happen, but I'd be a bit surprised).

Thank you very much, my problem has been solved. This way you will always be by your side. Using Openwrt, I am satisfied. I want to thank you again

Can you explain what the actual problem was? This will help future readers.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

It stopped Windows 11 update on my PC, due to which many drivers were not working properly. I faced many more problems. Later I downgraded to Windows 10, since then the LAN connection on my PC is working fine. And the ssid of 2.4GHz and 5GHz were same, so 2.4GHz and 5GHz are showing ssid together.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.