Kong pro firmware for IPQ806x (R7500, R7800, EA8500, ...)

OK, I just connected the EA8500, the problem is the switch config for the EA8500, it was changed a while ago in master, the change also did a change to the dts file and since we are still using 5.4 for nss the change is not in our dts. I'm going to set the switch config to the old setting as I'm not sure if the new way will interfere with nss setup. Fixed build for te EA8500 is up.

@immi803 , added it.


Thank you sir

Thanks, I'll try it out when time permits.

Edit: Working great, thanks @KONG

Hi Kong. Is it possible that lastest nss build (for ea8500 at least) is missing host and/or nslookup while it should be shipping with? I am having trouble getting DDNS to work due to " Error in 'get_registered_ip()' - no supported Name Server lookup software accessible - TERMINATE". For what I see in DDNS scripts, it checks for Host or NSLOOKUP binary but both are missing. Thank you

Let me update my config, I know this problem, I had the same issue when I tested my 21 build, it comes from a change in the package, which allows to select individual ddns provider support.

1 Like

I think I solved it just installing bind-host

EDIT: still not, with bind-host the DDNS daemon is able to run (unlike before), but it's not capable of reading the registered ip address (it shows No data).

With your new trunk build and installing also bind-host, DDNS works now. Thanks a lot KONG!

I removed dns proxy and installed unbound, everything's working, except i can't see unbound log , not in system log, neither in unbound log? Is some thing missing? I'm referring to minimum level unbound generates for informing that service is started, nothing about unbound-control and detailed log etc

Sir couldn't find kmod-ipt-nathelper-rtsp
Thank you in advance for adding but I'm not finding it

hi, can You add support for Trendnet TEW-827DRU v1.0R for You custom image? Thanks

@KONG latest nss.qos r17787 11/06

46.068778] nss_qdisc_init[1992]:NSS qdisc c208c522 (type 1) used along with non-nss qdiscs, or the interface is currently down
[   46.092106] 36ae383d: Found net device [nssifb]
[   46.102471] 36ae383d: Net device [nssifb] has NSS intf_num [28]
[   46.106978] 36ae383d: Sending message failed, cannot change nexthop for [nssifb]


$IP link set up nssifb

ipq806x_ nss

$IP link set dev $DEV up

Thanks for the info. I was too fast on cleaning up the code. I just fixed it. Will upload builds later on.

" $IP link set dev $DEV up" is not the problem. The problem is:

It tells the driver the actual interface, e.g. eth0

[   46.606190] nss_qdisc_init[1992]:NSS qdisc 7f43d6b4 (type 1) used along with non-nss qdiscs, or the interface is currently down
[   46.625788] ea5c20ea: Found net device [eth0]
[   46.636162] ea5c20ea: Net device [eth0] has NSS intf_num [1]
[   46.648115] Nexthop successfully set for [eth0] to [nssifb]


Thanks so much for this firmware - it's very stable!

Is there any chance you could include the miniupnpd-igdv1 package in your repo for 21.02?

Thanks! :slight_smile:


If you are building from source and you download the latest feeds and run menuconfig it will give you the new upnp v1 package as the feeds are just the normal ones from master.

It worked for me on another device.

First of all, thank you @KONG. I've been running your builds for quite a some time.

Recently switched r7800's to the build 21.02/

Wifi runs slow when 802.11w Management Frame Protection is set to Optional.
Networks are set to WPA2-PSK/Force CCMP (AES). Experiencing on 3 different r7800's.

Anyone else experiencing this issue?

Thanks again @KONG, the latest release resolved the issue with Wifi speeds.

1 Like

Still using November's 21.02 build. Has anyone else experienced Wireguard now not working ? When I say not working I mean it seems VPN policy or bypass has suddenly for no reason stopped routing via my Wireguard iface

Next Issue:

I also have 3 different EA8500's experiencing the slow wifi speeds with 802.11w Management Frame Protection set to Optional.

Freshly patched using
KONG 21 r16392+1-36848e2c29 / LuCI branch git-21.327.65561-7f37a58

Is it possible to add the packages kmod-usb-net-rtl8150 and kmod-usb-net-rtl8152? I would like to use realtek based usb to ethernet adpater.