Is my Archer C7 V2 dead? TFTP flash failure

After a sysupgrade gone wrong I had tried to TFTP into my router but it just boot loops now. I've tried flashing a few firmwares including the stock one but it doesn't seem to take, and tftpd64 shows the transfer at 0% (or sometimes 60%) and then the entry disappears and the router reboots.

Is it dead? I don't have the equipment to break out a serial connection and I've been using this as a repeater so it's not really worth buying the equipment to save it. It's a shame to let it go to waste though.

Hey there. Have you tried to use TFTP to go back to stock first?

Yep, I've tried both Archer C7(US)_V2_180114 and Archer C7(US)_V2_170525 (stripped) from the TP Link website and it gives the same result. tftpd64 sees the router and tries to send the file, but it stays stuck at either 0% or 60% then the router reboots before the transfer completes and boot loops.

try putting a switch in between the router and the computer, if you've got one.

1 Like

I put a switch in between and managed to get the transfer up to 94%, but then the pop-up disappeared again and it went back to bootlooping.

You need to manually adjust product id and manufacturer id in the firmware file. Had this on some flashes in the past where it got flipped in the boot block (no idea why) whilst upgrading and serial showed that uboot refused the tftpd flash after download ( the 64% means it got through) because of wrong ids.

You take the openwrt factory bin, edit it with xvi32 and shoot it on the box to repair it. Then you can force sysupgrade to the original downloaded sysupgrade image without modifications and are fine for future updates again. I've somewhere explained it in the past on this forum (pls search).

Made three of my archers live again until today

Pls rename the topic to tftpd flash failure on archer c7 boot loop fix to help others find it.

The fact it is boot looping suggests it isn't completely dead. I had one a few years ago that went bootloop AWOL after a flash, it bootlooped even with stock firmware. Recovered it by getting into bootloader and manually clearing the firmware. Realistically you'll need serial console access to progress this further.

After trying quite a few times, I managed to get it to hold ArcherC7v2_en_us_180114.bin with the VID and PID set to 0xFFFFFFFF, with a switch in between.

Thanks everyone!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.