Another archer C7 v2 bricked :(

Hello,

I mistakenly bricked my archer v7 v2 router.

  1. I first flashed to the openwrt image. Tried it a bit..
  2. Then I wanted to try dd-wrt.
    That last step didn't go well apparently. Not usre what happen exactly.

Anyways, so the router seem recoverable because it tries to download via TFTP using the reset+power button pressed together.

However, I still can't make it work.

I tried mutliple images, including the one from this post (and the precious help from @juppin ).

Based on what I read, probably the image I try doesn't match the product ID.

I would think that installing the image from @juppin - an edited 19.07.03 factory image with hwid (offset 0x40) and product id (offset 0x44) set to 0xffffffff - would help but no success so far :frowning:

The wireshark trace looks always good: it downloads each time whatever image I put. But after that the router stays like this (see picture) (these 3 leds stay fixed lit up and nothing happens).

Any help appreciated :pray:

[https://ibb.co/H430Z9q](https://3 leds always on)
[https://ibb.co/kBf0Nyk](https://end of tftp trace)
[https://ibb.co/rdpzjMg](https://begin of tftp trace)

Thank you!

Hi,
maybe try 0x00000000 instead of 0xffffffff for vendor and product id.

1 Like

It worked! Thank you @Catfriend1 !

Here is the file for those in same situation (Archer C7 v2): https://gofile.io/d/qyWQHF

This image (link above) is an edited openwrt version19.07.03 factory image with hwid (offset 0x40) and product id (offset 0x44) set to 0x00000000.

Many tanks!

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.