Is Mikrotik RB952Ui-5ac2nD fully supported?

I can't figure out if Mikrotik RB952Ui-5ac2nD is "fully" supported or not before buying a few of them. The "techdata page" says it's supported since 18.06.0, but there is no "device page", and searching this forum says that in March 2019, most features were not working:

  • No image available, must use imagebuilder
  • Flashing requires trickery
  • Switch only partially working
  • 5 GHz wireless not working

I guess the situation has probably changed in the last year, but could someone confirm it? Does absence of a "device page" mean that the device is not fully supported? Is there maybe a summary page with the current status of what works and what is still not completely working?

No, the absence of a devicepage says nothing about the degree of OpenWrt support.

At least it is supported on the deprecated ar71xx target...
Deprecated means that 19.07 will be the latest stable release for this device as long as anyone port this device to the device tree based ath79 target.

The platform code/mach file doesn't look that bad and i don't know why the important hw parts like ethernet and wifi shouldn't work.

1 Like

It was already listed as "supported" by ar71xx in March 2019, which apparently means that it's at least possible to run OpenWRT on this device (if you build the image with imagebuilder from ar71xx target and trick the firmware to detect the SoC properly):


But after that, "there is no switch configuration and port LEDs, WLAN 5g (QCA9887) does not work, USB does not have a power port, port 5 is lit red".

So now I'm wondering if the situation has changed since then.

Apparently, 5 GHz wireless hardware in this device is QCA9887, which is driven by ath10k, and it requires non-free firmware, so basically we shouldn't count on 5 GHz even if everything else works. Is my understanding correct?

Probably this fixed it:

What about this?

Probably you only need to install the required driver/firmware packages like:
kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct ath10k-firmware-qca9887-ct
The device config doesn't define any wifi drivers/firmwares, probably because it's not working...?

For more info: https://github.com/openwrt/openwrt/search?q=952Ui&type=Code

I thought OpenWRT did not allow non-free blobs?.. And according to this, ath10k requires one.


Or was I wrong, and OpenWRT still does include non-free blobs as long as they do not require any other compromise?

There is no ac wireless chip that doesn't require a firmware blob.
The ath9k/ath10k drivers are open source and are running on our main cpu in kernel space.
The firmware is almost any time closed source and runs on the wireless chip itself.
If the chip vendor would open source also the firmware, they would give a huge insight in the hw implementation of the chip and this isn't desired.

So OpenWrt does use binary firmware blobs but only runs open source drivers.

1 Like

Hey. At the moment, version 18.06.8 works well on this router, I checked!

Including 802.11ac ?

Oh! Thank you for the explanation. I thought, "apparently almost all ac chips require blobs - there are no blobs in openwrt - so no ac in openwrt".

Thank you for confirming! I just considered writing you a PM asking to confirm it since you seem to have one. :slight_smile:

So the problems you encountered in Mikrotik RB952Ui-5ac2nD are fixed by now? Did you use the prebuilt 18.06.8 image or did you have to use imagebuilder for this device specifically?

Yes 5G works, USB also works with the necessary packages

Yes problems fixed!
In the finished assembly 18.06.8 there is no support for vlan (Menu Switch). You need to edit the config, but Lucy will swear.
I built myself an image from the source with the necessary packages.

@Pahalan, is there any guide to get 18.06.8 installed on this device?

I have not seen a "guide for this device", but here is what I would try (in case you don't get a better guide):

Here are the downloads for Mikrotiks:
https://downloads.openwrt.org/releases/19.07.2/targets/ar71xx/mikrotik/
And here is the "common guide for installing on Mikrotiks":
https://openwrt.org/toh/mikrotik/common
Get the generic Mikrotik firmware (-ac-initramfs-kernel), try to pxeboot it and see if it works.

If it does not, get the imagebuilder (on the same downloads page) and try to build an image. Here is the imagebuilder manual:
https://openwrt.org/docs/guide-user/additional-software/imagebuilder

If that does not work either, then you'd have to build an image from source; there are manuals about that, too. I'm not sure if @Pahalan meant actually "built from source" or "build with imagebuilder" - let's hope you can get away with just the imagebuilder...

There is a good instruction with screenshots, but it is in Russian, use a translator)
https://global-hotspot.ru/прошивка-mikrotik-в-openwrt/

You will need these images, link below
https://downloads.openwrt.org/releases/18.06.8/targets/ar71xx/mikrotik/openwrt-18.06.8-ar71xx-mikrotik-rb-nor-flash-16M-ac-initramfs-kernel.bin
https://downloads.openwrt.org/releases/18.06.8/targets/ar71xx/mikrotik/openwrt-18.06.8-ar71xx-mikrotik-rb-nor-flash-16M-ac-squashfs-sysupgrade.bin

Basically, that means you don't need an imagebuilder or sources - just follow the "common guide for installing on Mikrotiks" and use the generic images, and it should work. Maybe you will have to install some additional packages after that, but there is enough flash for that.

1 Like

Nice one, thanks guys!

Feel free to add usefull information regarding installation of OpenWrt on the devicepage https://openwrt.org/toh/mikrotik/mikrotik_rb952ui-5ac2nd_hap_ac_lite

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.