IPv6 upstream is not connected. How to troubleshoot?

I have connected my ISP's modem/router on the WAN port of my router.

ISP --> ISP modem/router (technicolor) (not bridged) --> WNDR3700 router (OpenWrt 18.06.5) --> LAN, wifi & wifi guest.

TV, XBOX and Hometheatre are connected on the ISP's modem /router
PCs, laptops, phones and other devices on the WNDR3700 router (OpenWrt)

I haven't changed the ISP modem/router's configuration. Router mode is set to "ipv4/ipv6".
My device (tv, xbox, etc) get an ipv6 address, no problem. If I connect a laptop on the ISP modem/router, result from https://ipv6-test.com/ are OK. No issue.

The setup should be quite simple: DHCP for the IPv4 wan, DHCPv6 for WAN6.
I have no issue with ipv4 different network part than my ISP modem). This is running since 3 years.

I never paid attention but for IPv6, I can see in the Lucy Overview page, that the IPv6 Upstream is NOT connected. And now I would like to have my setup working in both IPV4 and IPV6....

root@WNDR3700:~# ifstatus wan6
{
"up": false,
"pending": false,
"available": false,
"autostart": true,
"dynamic": false,
"proto": "dhcpv6",
"device": "br-wan6",
"data": {

    }

I'm new to IPV6, I've just starting to read some online trainings but can't figure out what is wrong with the standard config I applied

***** Nnetwork.com
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd99:3f33:XXXX::/48'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option ifname 'eth1'
option proto 'dhcp'
option type 'bridge'

config interface 'wan6'
option ifname 'eth1'
option proto 'dhcpv6'
option type 'bridge'
option reqaddress 'try'
option reqprefix 'auto'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
option blinkrate '2'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5t'

config switch_port
option device 'switch0'
option port '1'
option led '6'

config switch_port
option device 'switch0'
option port '2'
option led '9'

config switch_port
option device 'switch0'
option port '5'
option led '2'

config interface 'guest'
option _orig_ifname 'wlan0-1'
option _orig_bridge 'false'
option proto 'static'
option ipaddr '192.168.3.1'
option netmask '255.255.255.0'

**** dhcp.conf
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option expandhosts '1'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option localservice '1'
option domain 'mydomain.be'
option nonwildcard '0'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'
option force '1'
option ra_management '1'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config dhcp 'guest'
option start '100'
option interface 'guest'
option limit '10'
option leasetime '1h'
option force '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'

config host
...
...
...

What am I missing?

I didn't find a post with similar setup decribing my problem and how to fix it. Nor on my ISP forum, they all mention config with ISP Modem/router in bridge mode (but no option for me as I need the extra Ethernet ports)...

How can we debug this? Is there specific logging to see what is happening for the establishment of the IPv6 upstream?

Thank you,

Probably missing correct DHCPv6-PD support in your upstream router. If you can't enable that, there's little you can do on the OpenWrt side.

I don't quite understand this though...
Yes, reconfiguring your upstream router to bridge-mode (pure modem) and terminating your WAN IP on your OpenWrt router should indeed avoid this problem - and unmanaged 8-port 1000BASE-T switches start around 15 EUR, which would be an easy/ cheap fix for 6 additional ports.

1 Like

Not only do I not understand it. I'm lost as to how you found the solution in your ISP's forum; but came here as if the OpenWrt was at fault, and needs debugging, etc...merely because you want more Ethernet ports...?

I'm also lost how you will use those Ethernet ports on the Technicolor - for what I assume was a LAN created on the OpenWrt.

The solution is the same, and your fix for the Ethernet ports is as @slh noted:

  • Or instead purchase an OpenWrt-compatible device that contains more ports

Otherwise, you could just put all the OpenWrt's ports on LAN, disable the DHCP server, etc.; and use that as your managed switch/"dumb" AP (for extra Ethernet ports).

Maybe you don't really want or desire a downstream:

ISP<>Technicolor_LAN<>OpenWRT_WAN<>LAN on the OpenWrt...

and instead want:

ISP<>Technicolor_LAN/OpenWRT_LAN?

From what I have read on ISP forum, when configured in bridge mode the upstream router (ISP) supports DHCP-PD. Prefix delegated is only /64.

I will do some testing with bridge mode to see if my OpenWrt can get Ipv6 upstream in that configuration.

Well, that's what I'd consider to be 'broken'. What's left to delegate, if all your upstream router can offer, is a single prefix that's already wasted on the (OpenWrt-) WAN interface, leaving 0 prefixes to delegate to your OpenWrt router's LAN side.

I didn't find a solution.... I'm cascading the 2 routers in a LAN to WAN way. On the ISP forum, posts always relate to bridge mode (LAN to LAN)...
The ISP modem/router is in my living room; while my OpenWRT router is in my office.
The ISP modem/router (192.168.0.1) and the OPenWRT router (192.168.1.1) have different IP segments. My TV, xbox and hometheater all connect to the ISP modem/router (wifi disabled). All the rest on the OPenWRT router.
My setup is working fine in IPV4 since years.

You don't have to use use multiple postings to respond. We can all see.

This is how it was initially configured. Now I want to see if this can work also in IPv6. Curiosity and good exercise to learn a little bit on IPv6...

Please provide the method in which your ISP provides IPv6.

Now I'm also afraid you have no ability to help.

This is rather important to know.

So if you can tell us, it would be helpful in assisting you.

So what do you want us to help you with?

Yes, while typing the reply, I realized that was probably the issue...
So apart if the ISP can provide something else for the prefix delegation, the only way would be to use bridge mode (and a switch)?

Are we in a time loop?

:man_facepalming:

isn't there a way to use link-local to talk ISP router and use /64 for ourselves?

How are WAN and LAN on the same link?

But I did hear of someone NATing/mangling packets to do this somehow...

oh there was technicolor router not bridged.

Maybe we're talking about the same thing; because I don't understand what that "for ourselves" means.

Do you mean somehow forward the /64 to LAN?

a router doesn't need a public address for itself - just a address valid for neighborhood routers.
so if the ISP router listen on link local (or unique local) address, it can talk with that address for upstream talk and use entire forwarded range.
but it looks like technicolor router just give a single address from 64 to openwrt. so it doesn't matter here

Not if the upstream router doesn't support this (and doesn't even implement DHCPv6-PD properly), which is the problem at hand. Neither if there are devices connected to said upstream router, which are getting their connectivity (including IPv6) from said upstream router, in parallel to the OpenWrt router's WAN. The trick is to get this faulty device out of the chain, out of the picture - by relegating it to pure modem (or media converter) uses and terminating the connection on a device that can do this properly instead (e.g. OpenWrt).

With dynamic IPv6 prefixes, which are the norm for consumer contracts, there no way around proper DHCPv6-PD support all the way down the chain. Static configuration doesn't work, as the prefix will change and the upstream router also needs to accept the configured range (guess what, if it doesn't even support DHCPv6-PD properly).

If your upstream router gives you just one /64 prefix, you might try the "relay" mode in OpenWrt ipv6 , which is meant for those situations. It is explained in the wiki:
https://openwrt.org/docs/guide-user/network/ipv6/start#router_advertisement_dhcpv6
(read the "Example configuration section for relaying" for ipv6 related options in /etc/config/dhcp)

Thanks, I will have a look...

Btw, I have asked my ISP more details about DHCPv6-PD and if they can delegate a /56.