IPv6 issues for internal network


since a couple of weeks I have an openWRT accesspoint running as wireless repeater.
this works great, except for one thing.
Locally I have IPv6 disabled, because my ISP doesn't allow me to override the IPv6 dns server.
for IPv4, I was able to change this by changing the DNS server.
Locally I have a Pi.hole running as DHCP and DNS server.
this works fine, and still does using the accesspoint.
however, before I was able to access my pi.hole using http://pi.hole.
but now pi.hole wouldn't resolve.
I asume this is because openWRT also supplies an ipv6 dns server.

DNS Servers . . . . . . . . . . . : fd4f:da46:94a2::1

for somehow this messes up my ipV4 routing for internal addesses.
what can I do to resolve this issue?
I tried disabling ipV6 completely like this

sysctl -w net.ipv6.conf.all.disable_ipv6=1
echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6
sysctl -w net.ipv6.conf.default.disable_ipv6=1

but that for some reason breaks by repeator bridge I have to go back to factory settings.
does someone know a solution for my problem?

You can advertise the IPv6 of pihole as nameserver, or advertive an IPv4 nameserver in IPv6 or disable IPv6 on this interface.


thank you.
IPv6 is already disabled in my pi hole,
now in openWRT in interfaces is disabled it everywhere(at first I missed some places under LAN/DHCP server)
and I removed "WAN6" was not allowed to stop it.
now the issue seems to be gone.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.