IPV6 configuration in pppoe

I am noob when it comes to ipv6 and I am struggling for past 2 days to get ipv6 working on my openwrt router.
I test for ipv6 by either ping or using websites for ipv6 test such as test-ipv6.com

The openwrt router is connected to a ISP router using bridge mode. ( I had issue earlier connecting bridge mode which was solved in this post PPPOE on 21.02 )

I have tried different options in Luci as well as following the guide in wiki but no luck. Finally i reset the whole router and reconfigured again just to make sure i didnt accidentally change any value.

I also tried manually creating WAN6, also tried disabling global network settings.

I can successfully ping to Google's ipv6 2001:4860:4860::8888 when i connect to the router ssh terminal. But cannot ping from lan side.

Here are my network and DHCP configuration.

cat /etc/config/network

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:~#
cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

#config globals 'globals'
#       option packet_steering '1'
#       option ula_prefix 'fd11:a754:cbda::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.200.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'WAN'
        option proto 'pppoe'
        option device 'wan'
        option username 'xxxxx'
        option password 'xxxxx'
        option ipv6 '1'

config device
        option name 'wan'
        option macaddr 'xxxxxx'

config interface 'WAN6'
        option proto 'dhcpv6'
        option device 'pppoe-WAN'
        option reqaddress 'try'
        option reqprefix 'auto'

I managed to restore ISP router to route mode again, just to get the configuration.
Here is a picture of configuration.

Can somebody help me translate the configuration from attached stock config to openwrt config. (Luci or modding files)``

See the PPP (pppoe and pppoa) section of the IPv6 configuration docs on the wiki -

It seems that your ISP is only assigning a /64 to the wan interface. That's pretty lame. You can contact them and confirm it. If so, you should use the IPv6 relay as workaround.

This is the response i got from my ISP.
"We inquired with our NOC engineer, we do not provide /48 or /64 for broadband connection, you have go for corporate/ lease line connection for /48 or /64 IP"

Anyways i tried using relay and my devices gets 2001:xxx ip address now. But still ping fails to 2001:4860:4860::8888.

I would like to know.
If i add option disable_ipv6 '1' in firewall defaults, will it accept all incoming outgoing traffic or block all incoming outgoing traffic?

I just want to temporarily "allow" all ipv6 related incoming/outgoing traffic just to make sure firewall is not causing an issue.

If you didn't change anything to the firewall, it allows the outgoing connections. You can post here the uci export firewall to verify.

I seemed like an issue was with bridge router and also my configuration in openwrt.

My mistake was thinking that, if i manually configure wan6(protocol:ppp) i don't need a duplicate wan_6(protocol: virtual dynamic interface) and i deleted this interface.

Turns out openwrt needs both interfaces for ipv6 to work properly.

Thank you for all help and support.

You need only one interface for IPv6. wan6 is manually configured dhcpv6 protocol, while wan_6 is automatically spawned when ipv6 option of wan pppoe is set to auto and uses the dhcpv6 protocol with most common settings.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.