IPTV config for OpenWrt

Hi,

I just installed openwrt on my router tplink acrcher c7 and i configure router to use pppoe for internet.
With default tplink firmware IPTV was working fine without doing anything. I used to dial internet pppoe from router and it was working fine internet with IPTV.
My modem is in bridge mode for internet and IPTV both.
After Installing openwrt I was able to config pppoe connection for internet but my IPTV is not working anymore.
I am noob here Please don't mind my silly questions.
Please help me.

Usually IPTV works in a different VLAN, different path in xDSL and possibly different PPPoE.
Do you remember what was the case in the stock firmware, so that we can help you replicate it in OpenWrt?

1 Like

it was just dialing pppoe connection for internet. I did the same in openwrt. Yes internet and iptv has different vlans id i think. And igmp proxy was enabled in lan settings

here is the emulator link tplink archer c7 v1


i just went to network >wan and changed it to PPPOE connection after username password, everything started working and i don't remember doing anything else.
So please help me to setup IPTV in openwrt.

If that is all you did, then changing the protocol of wan to PPPoE and adding the username and password will have the same result. However if we don't know the specs of the IPTV, we cannot help you further.
There is a page with ISP configurations and some of them have examples for IPTV. In some cases igmpproxy is necessary.
You could name here your ISP in case some other OpenWrt user has managed to make it work.

I have already done settings for pppoe and internet is working fine. But i dont know why IPTV is not working.
I can access internet on IPTV but there are not streams for channels. only black screen.
yes i have already done it installing igmpproxy but i dont know how to do settings via command line. Is it possible to do it via accessing 192.168.1.1?

You need add new interfaces on same as physical of pppoe interface, set with any static private ip address (ex: 10.10.10.1/24), assign it to wan zone. And following this guide to configure igmpproxy: https://openwrt.org/docs/guide-user/network/wan/udp_multicast

I only need to edit this file?
You need to edit /etc/config/igmpproxy
and type everything same as mentioned in the link you posted? for this file?
do i need to add this 0.0.0.0/0 too?
list altnet 0.0.0.0/0
and enable igmpproxy?

igmpproxy is not always needed, sometimes IPTV works fine without it (tested by me). But you need to add the config for IPTV, for instance my ISP allows IPTV to work with 0/102 config and internet works on 0/103 VPI/VCI config over ATM.

1 Like

Please post your /etc/config/network & /etc/config/igmpproxy (remove username & password of pppoe connection)

igmpproxy

igmpproxy
config igmpproxy                                                                                                                                                                                                                                      
option quickleave 1                                                                                                                                                                                                                  
#       option verbose [0-3](none, minimal[default], more, maximum)                                                                                                                                                                                                                                                                                                                                                                                                                       
config phyint                                                                                                                                                                                                                                        
option network wan                                                                                                                                                                                                                           
option zone wan                                                                                                                                                                                                                              
option direction upstream                                                                                                                                                                                                                    
list altnet 192.168.1.0/24                                                                                                                                                                                                                   
list altnet 0.0.0.0/0                                                                                                                                                                                                                                                                                                                                                                                                                                                             
config phyint                                                                                                                                                                                                                                        
option network lan                                                                                                                                                                                                                           
option zone lan                                                                                                                                                                                                                              
option direction downstream

network

config interface 'loopback'                                                                                                                                                                                                                          
option ifname 'lo'                                                                                                                                                                                                                           
option proto 'static'                                                                                                                                                                                                                        
option ipaddr '127.0.0.1'                                                                                                                                                                                                                    
option netmask '255.0.0.0'                                                                                                                                                                                                                                                                                                                                                                                                                                                        
config globals 'globals'                                                                                                                                                                                                                                                                                                                                                                                                                                                                  
config interface 'lan'                                                                                                                                                                                                                               
option type 'bridge'                                                                                                                                                                                                                         
option igmp_snooping '1'                                                                                                                                                                                                                     
option ifname 'eth1.1'                                                                                                                                                                                                                       
option proto 'static'                                                                                                                                                                                                                        
option ipaddr '192.168.1.1'                                                                                                                                                                                                                  
option netmask '255.255.255.0'                                                                                                                                                                                                               
option ip6assign '60'                                                                                                                                                                                                                                                                                                                                                                                                                                                             
config interface 'wan'                                                                                                                                                                                                                               
option ifname 'eth0.2'                                                                                                                                                                                                                       
option proto 'pppoe'                                                                                                                                                                                                                         
option password '**************'                                                                                                                                                                                                                      
option ipv6 'auto'                                                                                                                                                                                                                           
option username '******************'                                                                                                                                                                                                                                                                                                                                                                                                                                                    
config interface 'wan6'                                                                                                                                                                                                                              
option ifname 'eth0.2'                                                                                                                                                                                                                       
option proto 'dhcpv6'                                                                                                                                                                                                                                                                                                                                                                                                                                                             
config switch                                                                                                                                                                                                                                        
option name 'switch0'                                                                                                                                                                                                                        
option reset '1'                                                                                                                                                                                                                             
option enable_vlan '1'                                                                                                                                                                                                                                                                                                                                                                                                                                                            
config switch_vlan                                                                                                                                                                                                                                   
option device 'switch0'                                                                                                                                                                                                                      
option vlan '1'                                                                                                                                                                                                                              
option ports '2 3 4 5 0t'                                                                                                                                                                                                                                                                                                                                                                                                                                                         
config switch_vlan                                                                                                                                                                                                                                   
option device 'switch0'                                                                                                                                                                                                                      
option vlan '2'                                                                                                                                                                                                                              
option ports '1 6t'                                                                                                                                                                                                                                                                                                                                                                                                                                                               
config interface 'modem'                                                                                                                                                                                                                             
option ifname 'eth0.2'                                                                                                                                                                                                                       
option proto 'static'                                                                                                                                                                                                                        
option netmask '255.255.255.0'                                                                                                                                                                                                               
option ipaddr '192.168.10.7'                                                                                                                                                                                                                                                                                                                                                                                                                                                      
config interface 'IPTV'                                                                                                                                                                                                                              
option ifname 'eth0.2'                                                                                                                                                                                                                       
option proto 'static'                                                                                                                                                                                                                        
list ipaddr '10.10.10.1/24'

is it for modem or router?
My modem is using default firmware it was came it.
All connections are in bridge mode Internet and IPTV in the modem provided by the ISP.
I have installed openwrt on my router.

Hi,
If you need screenshots of the my modem settings, please let me know.

Try edit /etc/config/firewall like this:

config zone
        .......................
        option name 'wan'
        option network 'wan IPTV'

and /etc/config/igmpproxy

config igmpproxy
        option quickleave 1

config phyint
        option network IPTV
        option zone wan
        option direction upstream
        list altnet 0.0.0.0/0

config phyint
        option network lan
        option zone lan
        option direction downstream

/etc/config/network

config interface 'IPTV'                                                                                                                                                                                                                             
        option ifname 'eth0.2'                                                                                                                                                                                                                       
        option proto 'static'                                                                                                                                                                                                                        
        option netmask '255.255.255.0'                                                                                                                                                                                                               
        option ipaddr '10.10.10.1'
3 Likes

I think your WAN port is already receiving IPTV signals from your modem and it should work but I'm not sure why. Try @leeandy's suggestion and see if it works.

Thank you so much it is working now. Again Thank you so much.
I have one more question. Can you help me fine tune the stream?
There is occasional frame drop and pixelated frames.
Is it back end issue from ISP or we can fine tune it in openwrt?

which version of openwrt you are using ? Issue occur when using wifi or wired ?

i am using the latest i think 19.07.2 and i have connected TV device via Ethernet

See iptv docs link above, section " Firewall settings" & " Force IGMP version". Just try one by one step.
On your config above i see interface 'modem', try delete it.

ok Thank you. I read somewhere that you can make packets for TV stream to stay longer instead of dropping them earlier. But i am unable to find it now.