Rpi4 < $(community_build)

i rebooted pi4 couple of times. Still nothing changed

1 Like

I created backup using this

and i am lucky I created backup in November and it became useful now.

1 Like

this may or may not work;

diff -Naur /etc/config $(find /restorefiles/config-firstboot-post-* -type d | tail -n1)

@anon50098793
my firewall settings are ok?

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 modem'

config zone
        option name 'wan'
        option network 'wan IPTV'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

Not ok. Maybe you should start a new topic as these issues are not build related?

1 Like

ok sorry
it is from here

Try edit /etc/config/firewall like this:

config zone
        .......................
        option name 'wan'
        option network 'wan IPTV'

when IPTV and modem were not working
firewall was like this and i think it was the issue?

config zone
        option name 'wan'
        option network 'wan IPTV'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

and i have fixed it now added in the zone with

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 modem IPTV'

@trendy sorry for off topic and my stupidity to create separate zone for it.

1 Like

He told you to add the iptv interface in wan zone. You have created another wan zone without input/output/forward with wan and iptv.
Anyway this topic is about the build, try to keep it clean so we don't get all the notifications every time there is some issue.

2 Likes

@anon50098793 The build of today doesn't have sqm-scripts installed by default. (it has the extra and luci packages tho.), although is not critical. Ok, now things are getting weird, there must be a bug somewhere in opkg or the luci counterpart. It doesn't reliably shows what packages are installed and what are not. (Or my pi is bugged, worst case scenario).

For the rest of you guys: Don't update the packages using opkg or luci updates, there's a package that can break dnsmasq (i ignore what, i just reinstalled everything from scratch). I lost around 3 hours trying to debug it to no avail. Leave things as they are by deafult with the installed fac img, or updated sys img.

Best Regards!

1 Like

Upgrading packages (via the CLI opkg upgrade command or the LuCI Upgrade... button) can result in major problems. It is generally highly discouraged, unless you know what you are doing or if there is specific instruction to do so.

1 Like

I'm trying out ctinfo_4layercake.qos which is included in this build,

however when I select this as my sqm script, i'm getting a bunch of failed iptable invocations in the log. Is there an init script I'm missing?

Sat Jan 16 17:40:00 2021 user.notice SQM: Using generic sqm_start_default function.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Bulk4 dst -j DSCP --set-dscp-class CS1 -m comment --comment Bulk CS1 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Bulk4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Bulk4 src -j DSCP --set-dscp-class CS1 -m comment --comment Bulk CS1 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Bulk4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set BE4 dst -j CONNMARK --set-xmark 0x01000000/0x01000000 -m comment --comment Best Effort CS0 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set BE4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set BE4 src -j CONNMARK --set-xmark 0x01000000/0x01000000 -m comment --comment Best Effort CS0 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set BE4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Vid4 dst -j DSCP --set-dscp-class CS3 -m comment --comment Vid CS3 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Vid4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Vid4 src -j DSCP --set-dscp-class CS3 -m comment --comment Vid CS3 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Vid4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Voice4 dst -j DSCP --set-dscp-class CS4 -m comment --comment Voice CS4 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Voice4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Voice4 src -j DSCP --set-dscp-class CS4 -m comment --comment Voice CS4 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Voice4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -p tcp -s waldorf -m tcp -m multiport --sports 6981,4433,4434 -m comment --comment BT DSCP LE -j DSCP --set-dscp 1
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): host/network `waldorf' not found Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -p udp -s waldorf -m udp --sport 6981 -m comment --comment BT DSCP LE -j DSCP --set-dscp 1
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): host/network `waldorf' not found Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Bulk6 dst -j DSCP --set-dscp-class CS1 -m comment --comment Bulk CS1 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Bulk6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Bulk6 src -j DSCP --set-dscp-class CS1 -m comment --comment Bulk CS1 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Bulk6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set BE6 dst -j CONNMARK --set-xmark 0x01000000/0x01000000 -m comment --comment Best Effort CS0 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set BE6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set BE6 src -j CONNMARK --set-xmark 0x01000000/0x01000000 -m comment --comment Best Effort CS0 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set BE6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Vid6 dst -j DSCP --set-dscp-class CS3 -m comment --comment Vid CS3 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Vid6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Vid6 src -j DSCP --set-dscp-class CS3 -m comment --comment Vid CS3 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Vid6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Voice6 dst -j DSCP --set-dscp-class CS4 -m comment --comment Voice CS4 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Voice6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Voice6 src -j DSCP --set-dscp-class CS4 -m comment --comment Voice CS4 ipset
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Voice6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -p udp -m udp -m set --match-set Zoom4 dst -m multiport --dports 8801:8810 -j DSCP --set-dscp-class CS3 -m comment --comment Zoom CS3 VI
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Zoom4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -p udp -m udp -m set --match-set Zoom6 dst -m multiport --dports 8801:8810 -j DSCP --set-dscp-class CS3 -m comment --comment Zoom CS3 VI
Sat Jan 16 17:40:01 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Zoom6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 17:40:01 2021 daemon.debug dnsmasq[7954]: listening on ifb4eth1(#30): fe80::94ee:67ff:fec1:755d%ifb4eth1 port 53
Sat Jan 16 17:40:01 2021 user.notice SQM: ctinfo_4layercake.qos was started on eth1 successfully

Edit - Build is 2.3.656-15

1 Like

apologies... that is one I was messing around a while ago and I should have renamed it... to get the vanilla .qos code something like this should do the job...

curl -L https://raw.githubusercontent.com/ldir-EDB0/sqm-scripts/exp/src/ctinfo_4layercake.qos > /usr/lib/sqm/ctinfo_4layercake.qos

( i've replaced that file now with the original code in case you upgrade etc. )

2 Likes

Thanks @anon50098793 - however, just replaced the code with original from github (just ctinfo_4layercake.qos) and still see the same issue (same logs).

Sat Jan 16 18:12:30 2021 user.notice SQM: Using generic sqm_start_default function.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Bulk4 dst -j DSCP --set-dscp-class CS1 -m comment --comment Bulk CS1 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Bulk4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Bulk4 src -j DSCP --set-dscp-class CS1 -m comment --comment Bulk CS1 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Bulk4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set BE4 dst -j CONNMARK --set-xmark 0x01000000/0x01000000 -m comment --comment Best Effort CS0 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set BE4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set BE4 src -j CONNMARK --set-xmark 0x01000000/0x01000000 -m comment --comment Best Effort CS0 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set BE4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Vid4 dst -j DSCP --set-dscp-class CS3 -m comment --comment Vid CS3 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Vid4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Vid4 src -j DSCP --set-dscp-class CS3 -m comment --comment Vid CS3 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Vid4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Voice4 dst -j DSCP --set-dscp-class CS4 -m comment --comment Voice CS4 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Voice4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Voice4 src -j DSCP --set-dscp-class CS4 -m comment --comment Voice CS4 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Voice4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -p tcp -s waldorf -m tcp -m multiport --sports 6981,4433,4434 -m comment --comment BT DSCP LE -j DSCP --set-dscp 1
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): host/network `waldorf' not found Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -p udp -s waldorf -m udp --sport 6981 -m comment --comment BT DSCP LE -j DSCP --set-dscp 1
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): host/network `waldorf' not found Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Bulk6 dst -j DSCP --set-dscp-class CS1 -m comment --comment Bulk CS1 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Bulk6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Bulk6 src -j DSCP --set-dscp-class CS1 -m comment --comment Bulk CS1 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Bulk6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set BE6 dst -j CONNMARK --set-xmark 0x01000000/0x01000000 -m comment --comment Best Effort CS0 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set BE6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set BE6 src -j CONNMARK --set-xmark 0x01000000/0x01000000 -m comment --comment Best Effort CS0 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set BE6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Vid6 dst -j DSCP --set-dscp-class CS3 -m comment --comment Vid CS3 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Vid6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Vid6 src -j DSCP --set-dscp-class CS3 -m comment --comment Vid CS3 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Vid6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Voice6 dst -j DSCP --set-dscp-class CS4 -m comment --comment Voice CS4 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Voice6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -m set --match-set Voice6 src -j DSCP --set-dscp-class CS4 -m comment --comment Voice CS4 ipset
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Voice6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: FAILURE (2): /usr/sbin/iptables -t mangle -A QOS_MARK_F_eth1 -p udp -m udp -m set --match-set Zoom4 dst -m multiport --dports 8801:8810 -j DSCP --set-dscp-class CS3 -m comment --comment Zoom CS3 VI
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: iptables: LAST ERROR: iptables v1.8.4 (legacy): Set Zoom4 doesn't exist.  Try `iptables -h' or 'iptables --help' for more information.
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: FAILURE (2): /usr/sbin/ip6tables -t mangle -A QOS_MARK_F_eth1 -p udp -m udp -m set --match-set Zoom6 dst -m multiport --dports 8801:8810 -j DSCP --set-dscp-class CS3 -m comment --comment Zoom CS3 VI
Sat Jan 16 18:12:31 2021 user.notice SQM: ERROR: cmd_wrapper: ip6tables: LAST ERROR: ip6tables v1.8.4 (legacy): Set Zoom6 doesn't exist.  Try `ip6tables -h' or 'ip6tables --help' for more information.
Sat Jan 16 18:12:31 2021 daemon.debug dnsmasq[7906]: listening on ifb4eth1(#38): fe80::248f:dff:fe94:8be9%ifb4eth1 port 53
Sat Jan 16 18:12:31 2021 user.notice SQM: ctinfo_4layercake.qos was started on eth1 successfully
1 Like

been a while since i've messed with that script... but as a really quick workaround ( while I look into it ) you can paste this at the top of the ipt_setup function in that script...

ipset -q create BE4 hash:ip
ipset -q create Voice4 hash:ip
ipset -q create Bulk4 hash:ip
ipset -q create Zoom4 hash:ip
ipset -q create Vid4 hash:ip

ipset -q create Voice6 hash:ip family inet6
ipset -q create Zoom6 hash:ip family inet6
ipset -q create Vid6 hash:ip family inet6
ipset -q create BE6 hash:ip family inet6
ipset -q create Bulk6 hash:ip family inet6

from what I can see... it looks like it kinda needs to be edited a bit manually anyway... there is a ctinfo 5 at LDIR github... maybe it has newer setup code?... TBH I never looked what was required to properly install them so if you figure it out let me know!

1 Like

Gotcha. Let me have a play about with it later (currently making dinner!). Thanks again.

1 Like

you can give this one a whirl... it's hackorrific, but will setup a few dynamic ipsets for you...

curl -L https://raw.githubusercontent.com/wulfy23/rpi4/master/utilities/ctinfo_4layercake_rpi4.qos > /usr/lib/sqm/ctinfo_4layercake_rpi4.qos
1 Like

Yo... this build is cool!! I just checked the progress on this project for the first time since last summer and now I wish I had followed the progress here more closely.

Awesome stuff, thanks!

1 Like

Continuing the discussion from Rpi4 < $(community_build):

Hi guys,
Since past couple versions I run into the same problem - my ethernet wan stops working after a couple days. I tried setting up watchcat since reboot fixes it (or even a service restart) but it does not trigger for some reason.

n Jan 17 10:29:34 2021 kern.warn kernel: [110991.688813] ------------[ cut here ]------------
Sun Jan 17 10:29:34 2021 kern.info kernel: [110991.693541] NETDEV WATCHDOG: eth1 (ax88179_178a): transmit queue 0 timed out
Sun Jan 17 10:29:34 2021 kern.warn kernel: [110991.700744] WARNING: CPU: 2 PID: 0 at net/sched/sch_generic.c:448 dev_watchdog+0x2b8/0x2c0
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.709093] Modules linked in: qcserial pppoe ppp_async option l2tp_ppp cdc_mbim brcmfmac usb_wwan sr9700 rndis_host qmi_wwan pppox ppp_generic iscsi_tcp ipt_REJECT huawei_cdc_ncm ftdi_sio dm9601 cfg80211 cdc_ncm cdc_ether ax88179_178a xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_recent xt_quota2 xt_quota xt_pkttype xt_owner xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_helper xt_hashlimit xt_geoip xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_addrtype xt_TCPMSS xt_REDIRECT xt_MASQUERADE xt_LOG xt_HL xt_FLOWOFFLOAD xt_DSCP xt_CT xt_CLASSIFY wireguard usbserial usbnet usbhid ums_usbat ums_sddr55 ums_sddr09 ums_karma ums_jumpshot ums_isd200 ums_freecom ums_datafab ums_cypress ums_alauda slhc sch_cake r8152 pegasus nf_reject_ipv4 nf_log_ipv4 nf_flow_table_hw nf_flow_table nf_conntrack_rtcache nf_conntrack_netlink nf_conncount macvlan libiscsi_tcp libiscsi iptable_raw iptable_nat iptable_mangle iptable_filter ipt_ECN ip6table_raw
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.709153]  ip_tables hid_generic exfat crc_ccitt compat cdc_wdm brcmutil fuse sch_teql sch_sfq sch_red sch_prio sch_pie sch_multiq sch_gred sch_fq sch_dsmark sch_codel em_text em_nbyte em_meta em_cmp act_simple act_police act_pedit act_ipt act_gact act_csum libcrc32c act_ctinfo sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_tcindex cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred snd_bcm2835(C) hid evdev usb_f_ecm u_ether libcomposite ledtrig_usbport ledtrig_oneshot ledtrig_heartbeat ledtrig_gpio cryptodev xt_set ip_set_list_set ip_set_hash_netportnet ip_set_hash_netport ip_set_hash_netnet ip_set_hash_netiface ip_set_hash_net ip_set_hash_mac ip_set_hash_ipportnet ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink ip6table_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 ip6t_NPT ip6t_rt ip6t_mh ip6t_ipv6header ip6t_hbh ip6t_frag ip6t_eui64 ip6t_ah
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.796454]  nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 ip6_gre ip_gre gre ifb dummy sit l2tp_netlink l2tp_core udp_tunnel ip6_udp_tunnel ipip ip6_tunnel tunnel6 tunnel4 ip_tunnel veth tun snd_rawmidi snd_seq_device snd_pcm_oss snd_pcm_dmaengine snd_pcm snd_timer snd_mixer_oss snd_hwdep snd_compress snd soundcore nls_utf8 crypto_user algif_skcipher algif_rng algif_hash algif_aead af_alg sha1_generic md5 ghash_generic gf128mul gcm des_generic libdes cmac ccm authenc crypto_acompress vfat fat nls_iso8859_1 nls_cp437 dwc2 uhci_hcd ohci_platform ohci_hcd ledtrig_transient fsl_mph_dr_of ehci_platform ehci_fsl ehci_hcd gpio_button_hotplug udc_core
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.945723] CPU: 2 PID: 0 Comm: swapper/2 Tainted: G         C        5.4.85 #0
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.953117] Hardware name: Raspberry Pi 4 Model B Rev 1.1 (DT)
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.959035] pstate: 40400005 (nZcv daif +PAN -UAO)
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.963913] pc : dev_watchdog+0x2b8/0x2c0
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.968006] lr : dev_watchdog+0x2b8/0x2c0
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.972097] sp : ffffffc010013da0
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.975492] x29: ffffffc010013da0 x28: 00000000000000e0
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.980890] x27: 0000000000000140 x26: 00000000ffffffff
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.986286] x25: 0000000000000000 x24: 0000000000000000
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.991682] x23: 0000000000000001 x22: ffffff807a0b9000
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110991.997078] x21: ffffff807a0b9480 x20: ffffffc0109c6000
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.002473] x19: 0000000000000000 x18: 0000000000000000
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.007868] x17: 0000000000000000 x16: 0000000000000000
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.013263] x15: 0000000000000000 x14: 07740775076f0720
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.018658] x13: 07640765076d0769 x12: 0774072007300720
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.024053] x11: 0765077507650775 x10: 0771072007740769
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.029448] x9 : 076d0773076e0761 x8 : 077207740720073a
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.034844] x7 : 0729076107380737 x6 : 0000000000000001
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.040239] x5 : 0000000000000000 x4 : 0000000000000000
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.045634] x3 : 0000000000000000 x2 : ffffff807fbc2258
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.051029] x1 : ffffffc06f20c000 x0 : 0000000000000040
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.056424] Call trace:
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.058956]  dev_watchdog+0x2b8/0x2c0
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.062704]  call_timer_fn.isra.34+0x20/0x78
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.067057]  run_timer_softirq+0x1e8/0x478
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.071236]  __do_softirq+0x11c/0x250
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.074983]  irq_exit+0x9c/0xb8
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.078207]  __handle_domain_irq+0x64/0xb8
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.082385]  gic_handle_irq+0x5c/0xb8
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.086130]  el1_irq+0xf0/0x1c0
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.089354]  arch_cpu_idle+0x10/0x18
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.093015]  do_idle+0x1e4/0x258
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.096326]  cpu_startup_entry+0x24/0x78
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.100333]  secondary_start_kernel+0x148/0x158
Sun Jan 17 10:29:35 2021 kern.warn kernel: [110992.104947] ---[ end trace bd5fb4000b24a6b4 ]---

Any idea what could cause this ? I have this issue since last couple versions (the very first were running fine)

1 Like

can you be more specific about;

  • build version numbers?
  • describe any setup config that is non-standard... i.e. network settings, extra installed programs, custom config.txt options if any... etc. etc.
  • list firmware version
1 Like

the issue is present since: -25063-2.3.637-2-r15199
Current firmware: OpenWrt SNAPSHOT r15323-7ba2f5c96f / LuCI Master git-20.339.75073-e54708a

I have SQM on that network adapter enabled + AdGuard Home installed and serving as DHCP( but this setup is from beginning and on the earliest versions (l think November) I hadn't have those types of issues.

Update: I've also enabled PacketSteering in Global network options(forgot to mention that)

1 Like