IPQ4019 - Mesh Connection Issue

Hello,
I am using 1 x Zyxel NBG 6617 and 2 x Xiaomi Mi 4A Gigabit Router.
I would like to create mesh network between 3 routers.

There is no problem between 4As'. Connection works perfect and there is no issue between them.

But I am having issue on NBG 6617.
I can successfully create link on 6617 also. But link is not stable and having corruptions, timeouts etc.

What I have tried until now:

  1. 2.4GHz / 5GHz with and without password authentication. - Link was not stable.
  2. Mesh link with batman. - Link was not stable.
  3. Tried on 19.07, 20.02rc1, 20.02rc2 and Snapshot - On all versions link was not stable.
  4. Replaced ath10k-firmware-qca4019-ct and kmod-ath10k-ct with non ct versions. - Link was not stable.

I could make link stable only when I change wireless mode to Legacy. Link was stable both on 2.4GHz and 5GHz. But throughput was not good enough due to Lecagy mode.

I am not sure if my 6617's chip is defective.

Do you have any recommendations for me?

Thank you in advance.

I don't have a specific solution but some things for you to consider for testing purposes....

  • Although they both claim to be 802.11ac / 866Mbps...it looks like the zyxel has less antenna diversity than the 4A. If that were the case then there would be hiccups. (I've seen that between ar750s and C7, both use the same chip but the ar750s can only hit 433Mbps at 5Ghz vs the C7 which can do 1300Mbps - I meshed them and they didn't like it).

  • easy answer is to repurpose the zyxel and buy another 4A. Or vice versa. Keep the nodes homogenous / same models and on the same chip family for best results usually. Repurpose the zyxel as an AP or edge router.

  • I couldn't get pictures of the PCB inside the zyxel so it is hard to say what antenna layout it is using. The pictures of the 4A looks like it has real antennas and not some PCB or hybrid which is what I think the zyxel is using.

  • collect system (and kernel?) logs when the mesh starts acting up. Post them on here. Strip out any identifiable info such as mac addresses.

  • post your UCI configs for network and wireless for the 4A and the Zyxel for comparison purposes. Strip out personally identifying information.

I apologize in advance if alot of this is redundant. It sounds like you tested alot!

HTH

Crazy idea...

  • Disclaimer: for testing purposes try rolling back the zyxel's OpenWrt version? Probably not advisable due to security patches. See below:

Updated:

  • the Zyxel does have 2x2 antennas like the Xiaomi 4A, so it must be either IPQ4018 vs MT7621 conflict or settings.

Hello,

My configs are below.

NBG6617


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ip6ifaceid '::1'

config interface 'wan'
	option device 'eth1'
	option proto 'pppoe'
	option username 'XXXX@vodafone'
	option password 'XXX'
	option peerdns '0'
	list dns '127.0.0.1'
	option delegate '0'
	option ipv6 '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0'

config interface 'wg0'
	option proto 'wireguard'
	option private_key 'XXX'
	list addresses '192.168.10.2/32'
	option mtu '1412'
	option peerdns '0'
	option delegate '0'
	option listen_port '51820'

config wireguard_wg0
	option public_key 'XXXX'
	option persistent_keepalive '25'
	option route_allowed_ips '1'
	option endpoint_host '91.241.XX.XX'
	option description 'dipper'
	option endpoint_port '51820'
	list allowed_ips '192.168.10.0/24'
	list allowed_ips '192.168.11.0/24'
	list allowed_ips '172.16.0.0/24'

config wireguard_wg0
	option public_key 'XXXX'
	option persistent_keepalive '25'
	option route_allowed_ips '1'
	option endpoint_host '91.93.XX.XX'
	option description 'isxwrt'
	option endpoint_port '51820'
	list allowed_ips '192.168.10.3/32'
	list allowed_ips '10.0.0.0/8'
	list allowed_ips '172.16.0.0/12'
	list allowed_ips '157.247.0.0/16'

config wireguard_wg0
	option public_key 'XXXX'
	option persistent_keepalive '25'
	option endpoint_port '51820'
	option route_allowed_ips '1'
	option endpoint_host '130.61.XX.XX'
	option description 'de'
	list allowed_ips '192.168.10.12/32'

config wireguard_wg0
	option public_key 'XXXX'
	option persistent_keepalive '25'
	option endpoint_port '51820'
	option route_allowed_ips '1'
	option endpoint_host '185.219.135.56'
	option description 'trweb'
	list allowed_ips '192.168.10.11/32'

config interface 'wan6'
	option proto 'wireguard'
	option private_key 'XXX'
	list addresses '192.168.20.2/32'
	list addresses '2a0c:8dc6:XX:1::3/128'
	option ip6prefix '2a0c:8dc6:XX:XX::/64'
	option mtu '1412'
	option peerdns '0'
	option listen_port '51821'

config wireguard_wan6
	option public_key 'XXX'
	option persistent_keepalive '25'
	option endpoint_port '51821'
	option route_allowed_ips '1'
	option endpoint_host '91.241.XX.XX'
	option description 'dipper'
	list allowed_ips '192.168.20.1/32'
	list allowed_ips '::/0'

config wireguard_wan6
	option public_key 'XXX'
	option description 'trweb'
	option persistent_keepalive '25'
	option endpoint_port '51821'
	option route_allowed_ips '1'
	option endpoint_host '185.219.XX.XX'
	list allowed_ips '192.168.20.3/32'
	list allowed_ips '2a0c:XX:XX:1::5/128'

config interface 'cf'
	option proto 'wireguard'
	list addresses 'fd01:5ca1:ab1e:86a2:bcd2:83dd:7bc0:e83c/128'
	list addresses '192.168.200.2/32'
	option peerdns '0'
	option listen_port '2408'
	option mtu '1412'
	option delegate '0'
	option private_key 'XXX'

config wireguard_cf
	option public_key 'bmXOC+F1FxEMF9dyiK2H5/1SUtzH0JuVo51h2wPfgyo='
	option persistent_keepalive '25'
	option endpoint_port '2408'
	list allowed_ips '173.245.48.0/20'
	list allowed_ips '103.21.244.0/22'
	list allowed_ips '103.22.200.0/22'
	list allowed_ips '103.31.4.0/22'
	list allowed_ips '141.101.64.0/18'
	list allowed_ips '108.162.192.0/18'
	list allowed_ips '190.93.240.0/20'
	list allowed_ips '188.114.96.0/20'
	list allowed_ips '197.234.240.0/22'
	list allowed_ips '198.41.128.0/17'
	list allowed_ips '162.158.0.0/15'
	list allowed_ips '172.64.0.0/13'
	list allowed_ips '131.0.72.0/22'
	list allowed_ips '104.16.0.0/13'
	list allowed_ips '104.24.0.0/14'
	list allowed_ips '2400:cb00::/32'
	list allowed_ips '2606:4700::/32'
	list allowed_ips '2803:f800::/32'
	list allowed_ips '2405:b500::/32'
	list allowed_ips '2405:8100::/32'
	list allowed_ips '2a06:98c0::/29'
	list allowed_ips '2c0f:f248::/32'
	option route_allowed_ips '1'
	option endpoint_host '162.159.192.5'


--------------------------



config wifi-device 'radio0'
	option type 'mac80211'
	option macaddr '60:31:97:01:XX:XX'
	option band '2g'
	option country 'TR'
	option channel '1'
	option cell_density '0'
	option noscan '1'
	option htmode 'HT20'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'XXX'
	option ifname 'AP-2'
	option encryption 'psk2+ccmp'
	option key 'XXX'
	option ieee80211r '1'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'
	option ieee80211k '1'
	option ieee80211v '1'
	option bss_transition '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option macaddr '60:31:97:01:XX:XX'
	option band '5g'
	option cell_density '0'
	option htmode 'VHT80'
	option channel '36'
	option country 'TR'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'XXX'
	option ifname 'AP-5'
	option encryption 'psk2+ccmp'
	option key 'XXX'
	option ieee80211r '1'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'
	option ieee80211k '1'
	option ieee80211v '1'
	option bss_transition '1'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'mesh'
	option encryption 'none'
	option mesh_id 'Mesh'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option ifname 'Mesh'
	option network 'lan'



1st Mi 4a as dumb ap

/etc/config/network
config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option packet_steering '1'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.2'
	option gateway '192.168.1.1'
	list ip6addr '2a0c:8dc6:XXX:XXX::2/64'
	option ip6gw '2a0c:8dc6:XXX:XXX::1'
	option ip6prefix '2a0c:8dc6:XXX:XXX::/64'
	option device 'br-lan'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'

config route6
	option interface 'lan'
	option target '::/0'
	option gateway '2a0c:8dc6:XXX:XXX::1'

-------------------------------


config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option htmode 'HT20'
	option country 'TR'
	option cell_density '0'
	option channel '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'XXX'
	option ifname 'AP-2'
	option encryption 'psk2+ccmp'
	option key 'XXX'
	option ieee80211r '1'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'
	option ieee80211k '1'
	option ieee80211v '1'
	option wnm_sleep_mode '1'
	option bss_transition '1'
	option logger_syslog_level '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option country 'TR'
	option cell_density '0'
	option channel '36'


config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'mesh'
	option encryption 'none'
	option mesh_id 'Mesh'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option ifname 'Mesh'
	option network 'lan'

config wifi-iface 'wifinet4'
	option device 'radio1'
	option mode 'ap'
	option ssid 'XXX'
	option encryption 'psk2+ccmp'
	option ifname 'AP-5'
	option key 'XXX'
	option ieee80211r '1'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'
	option network 'lan'


2nd Mi 4a as dumb ap


config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option packet_steering '1'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option ipaddr '192.168.1.3'
	list ip6addr '2a0c:8dc6:XXX:XXX::3/64'
	option ip6gw '2a0c:8dc6:XXX:XXX::1'
	option ip6prefix '2a0c:8dc6:XXX:XXX::/64'
	option device 'br-lan'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'

config route6
	option interface 'lan'
	option target '::/0'
	option gateway '2a0c:8dc6:XXX:XXX::1'

------------------



config wifi-device 'radio0'
	option type 'mac80211'
	option macaddr '9c:9d:7e:82:XX:XX'
	option band '2g'
	option country 'TR'
	option cell_density '0'
	option channel '1'
	option htmode 'HT20'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'XXX'
	option ifname 'AP-2'
	option encryption 'psk2+ccmp'
	option key 'XXX'
	option ieee80211r '1'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'
	option ieee80211k '1'
	option ieee80211v '1'
	option wnm_sleep_mode '1'
	option bss_transition '1'
	option logger_syslog_level '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option macaddr '9c:9d:7e:82:XX:XX'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'
	option country 'TR'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'mesh'
	option encryption 'none'
	option mesh_id 'Mesh'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option ifname 'Mesh'
	option network 'lan'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'XXX'
	option encryption 'psk2+ccmp'
	option ifname 'AP-5'
	option key 'XXX'
	option ieee80211r '1'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'
	option network 'lan'

Sys and Kernel logs on 6617

Mon Jun 14 18:40:52 2021 daemon.notice hostapd: nl80211: deinit ifname=AP-5 disabled_11b_rates=0
Mon Jun 14 18:40:52 2021 daemon.notice hostapd: nl80211: Failed to remove interface AP-5 from bridge br-lan: Invalid argument
Mon Jun 14 18:40:52 2021 kern.info kernel: [146740.392455] ath10k_ahb a800000.wifi: mac flush null vif, drop 0 queues 0xffff
Mon Jun 14 18:40:52 2021 kern.warn kernel: [146740.394062] ath10k_ahb a800000.wifi: peer-unmap-event: unknown peer id 0
Mon Jun 14 18:40:52 2021 kern.warn kernel: [146740.398653] ath10k_ahb a800000.wifi: peer-unmap-event: unknown peer id 0
Mon Jun 14 18:40:52 2021 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy AP-5) --> new PHY
Mon Jun 14 18:40:54 2021 kern.warn kernel: [146742.758989] ath10k_ahb a800000.wifi: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Mon Jun 14 18:40:54 2021 kern.warn kernel: [146742.759038] ath10k_ahb a800000.wifi: msdu-desc: 2500  skid: 32
Mon Jun 14 18:40:54 2021 kern.info kernel: [146742.806098] ath10k_ahb a800000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Mon Jun 14 18:40:54 2021 kern.info kernel: [146742.807040] ath10k_ahb a800000.wifi: wmi print 'free: 53252 iram: 13432 sram: 35752'
Mon Jun 14 18:40:54 2021 kern.info kernel: [146743.122248] ath10k_ahb a800000.wifi: rts threshold -1
Mon Jun 14 18:40:54 2021 kern.warn kernel: [146743.122555] ath10k_ahb a800000.wifi: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4
Mon Jun 14 18:40:54 2021 kern.info kernel: [146743.131657] br-lan: port 2(AP-5) entered blocking state
Mon Jun 14 18:40:54 2021 kern.info kernel: [146743.137324] br-lan: port 2(AP-5) entered disabled state
Mon Jun 14 18:40:54 2021 daemon.notice hostapd: AP-5: interface state UNINITIALIZED->COUNTRY_UPDATE
Mon Jun 14 18:40:54 2021 kern.info kernel: [146743.143275] device AP-5 entered promiscuous mode
Mon Jun 14 18:40:55 2021 kern.info kernel: [146743.461677] IPv6: ADDRCONF(NETDEV_CHANGE): AP-5: link becomes ready
Mon Jun 14 18:40:55 2021 kern.info kernel: [146743.461975] br-lan: port 2(AP-5) entered blocking state
Mon Jun 14 18:40:55 2021 kern.info kernel: [146743.467106] br-lan: port 2(AP-5) entered forwarding state
Mon Jun 14 18:40:55 2021 daemon.notice hostapd: AP-5: interface state COUNTRY_UPDATE->ENABLED
Mon Jun 14 18:40:55 2021 daemon.notice hostapd: AP-5: AP-ENABLED
Mon Jun 14 18:40:55 2021 daemon.err hostapd: nl80211: kernel reports: key addition failed
Mon Jun 14 18:40:55 2021 daemon.info hostapd: AP-5: STA a4:50:46:ee:08:8d IEEE 802.11: associated (aid 1)
Mon Jun 14 18:40:55 2021 daemon.notice hostapd: AP-5: AP-STA-CONNECTED a4:50:46:ee:08:8d
Mon Jun 14 18:40:56 2021 kern.info kernel: [146744.586218] ath10k_ahb a800000.wifi: rts threshold -1
Mon Jun 14 18:40:56 2021 kern.info kernel: [146744.892586] IPv6: ADDRCONF(NETDEV_CHANGE): Mesh: link becomes ready
Mon Jun 14 18:40:56 2021 daemon.notice netifd: Network device 'AP-5' link is up
Mon Jun 14 18:40:56 2021 daemon.notice netifd: Network device 'Mesh' link is up
Mon Jun 14 18:40:56 2021 kern.info kernel: [146744.972106] br-lan: port 4(Mesh) entered blocking state
Mon Jun 14 18:40:56 2021 kern.info kernel: [146744.972142] br-lan: port 4(Mesh) entered disabled state
Mon Jun 14 18:40:56 2021 kern.info kernel: [146744.976849] device Mesh entered promiscuous mode
Mon Jun 14 18:40:56 2021 kern.info kernel: [146744.982053] br-lan: port 4(Mesh) entered blocking state
Mon Jun 14 18:40:56 2021 kern.info kernel: [146744.986385] br-lan: port 4(Mesh) entered forwarding state
[146744.892586] IPv6: ADDRCONF(NETDEV_CHANGE): Mesh: link becomes ready
[146744.972106] br-lan: port 4(Mesh) entered blocking state
[146744.972142] br-lan: port 4(Mesh) entered disabled state
[146744.976849] device Mesh entered promiscuous mode
[146744.982053] br-lan: port 4(Mesh) entered blocking state
[146744.986385] br-lan: port 4(Mesh) entered forwarding state

And wireless status on 6617 when peers are connected.

Crank up the transmit power on all the mesh nodes:

LuCI->network->wireless->maximum transmit power->23 dBm (199mW)

Ideally you should see -50 or -60 dBm between mesh nodes on LuCI->status->overview. -96dBm = no signal. Mesh point 9c:9d:7e..... is not getting any signal.

9c:9d:7e is getting signal from 52:D2:F5.. It is around -65 dBm from 52:D2:F5

Setting -23 dBm manually on both AP's did not work out also.

Btw my current configuration is like this:

6617 <-- WDS --> 4A <-- Mesh --> 4A

I have no problem configuration as like above.

WDS is considered almost obsolete and will not transmit certain protocols like WPA3. Make the root node 802.11s?

So its fixed then? Or you experience connection interuptions?

Almost over 1 year I am using it with WDS link to NBG6617.

Setting up 23 dBm did not fix the connection interruptions on Mesh link.

You could set this to -85 dBm assuming your nodes have -60 to -70 dBm of signal.

  • Are the nodes crashing and requiring reboots every 2-3 days? If so you could just cron job them to reboot every 24 hours as a temporary measure until you find a better solution.

  • Also the 175Mbps on mesh node 52:df:f5... seems a little low. Maybe it's a busy channel. Did you try channel 153 using max 1000 mW transmit power?

  • Is this a home mesh or is it connected to the neighborhood?

Setting up -85 dBm did not help also.

Both 4A's are working fine without any crash or reboot.

Right now i am testing one of the 4A next to 6617.

Wireless on 6617

Wireless on 4A

Ping result from 6617 to 4A

Reply from 192.168.1.2: bytes=32 time=92ms TTL=64
Reply from 192.168.1.2: bytes=32 time=2ms TTL=64
Reply from 192.168.1.2: bytes=32 time=1ms TTL=64
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.1.2: bytes=32 time=3ms TTL=64
Reply from 192.168.1.2: bytes=32 time=1ms TTL=64
Reply from 192.168.1.2: bytes=32 time=95ms TTL=64
Reply from 192.168.1.2: bytes=32 time=25ms TTL=64
Reply from 192.168.1.2: bytes=32 time=1ms TTL=64
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.1.2: bytes=32 time=1ms TTL=64
Reply from 192.168.1.2: bytes=32 time=1ms TTL=64
Reply from 192.168.1.2: bytes=32 time=1ms TTL=64
Reply from 192.168.1.2: bytes=32 time=3ms TTL=64
Reply from 192.168.1.2: bytes=32 time=96ms TTL=64

Both routers are in the same home.

Only 6617 does not want to join mesh link :smiley:

Sadly both routers are allowing channel up to 140.

  • I would move all AP's to 2.4Ghz to free up the 5Ghz radios for the mesh. Otherwise it will be unstable.

  • The 4A in the middle is trying to juggle WDS and MESH on the same radio? Seems like a bad idea if that is the case. I would think WDS would be best off on its own dedicated radio.

Let's see what others have to say. Most of my experience is with vanilla 802.11s - no WDS.

HTH
:grinning_face_with_smiling_eyes:

Disabling AP's on 5GHz on all routers did not help also.

I might try older version of OpenWRT.

If you can’t get the mesh to play nicely with the 6617, then another possible configuration would be:

-->no WDS
-->keep the 4A's meshed
-->6617 becomes node 3 and connects to node 2 as a client (STA MODE)

[node 1, 4A] ↔ [node 2, 4A] ↔ [node 3, 6617]

Node 1:

  • 4A

  • internet connection

  • 2.4Ghz AP for clients

  • 5 Ghz MESH POINT for node 2

Node 2:

  • 4A

  • 5 Ghz MESH POINT for node 1

  • 5 Ghz AP for node 3

  • 2.4Ghz AP for clients

Node 3:

  • NBG6617

  • 5 Ghz STA MODE β†’ 5 Ghz AP on node 2

  • 2.4Ghz AP for clients


Notes:

  • 802.11s with SAE between the 4A, no batman.

  • Node 3: connects as a client to node 2's 5 Ghz AP which should be much more stable in theory. I have run like that on the AR750S because it only has one 5Ghz radio like most routers. It works. Or you could connect to node 2's 2.4Ghz AP and put up a 5Ghz AP and 2.4Ghz AP.

  • no WDS.

  • this topology is only concerned with providing internet access and getting the misbehaving 6617 operational.

You could also implement the above config without moving any routers:

[node 1: 6617] <--AP/STA--> [node 2: 4A] <-- 802.11s --> [node 3: 4A]


Node 1:

  • 6617
  • internet
  • 2.4 Ghz AP for clients
  • hidden 5 Ghz AP for node 2

Node 2:

  • 4A
  • STA MODE (no WDS) 5 Ghz connects to node 1's 5 Ghz AP
  • 5 Ghz 802.11s MESH to node 3
  • 2.4 Ghz AP for clients

Node 3:

  • 4A
  • 5 Ghz 802.11s MESH to node 2
  • 2.4 Ghz AP for clients

Notes:

  • 6617 is quad core with more memory = making it ideal as the edge router

:partying_face:
GLHF

Thank you for all your suggestions.

I have tried over 3 hours last night to make connection of 6617. Every attemptions were unsuccessfully. Mesh only works stable when I set wireless mode Legacy on 6617.

I have fed up with mesh connection of 6617. I will keep 6617 as edge router and I will buy another 4A to make direct connection to 6617 and turn of wifi of 6617. I will make Mesh with 3 Mi 4As.

Thank for your time and suggestions again.

Regards

1 Like