Zyxel nbg6617/ipq4019 regression in Wifi 5GHz

I've been running a some old-ish snapshot on Zyxel NBG6617 until 19.07rcx was released and everything seemed to be stable enough and very fast, every fast.com speed test while connected to 5Ghz was about my downlink speed(250Mbps)

After flashing both 19.07rc performance on 5Ghz Wifi(AC) has degraded so much that I get about only 20Mbps in speed tests and latency is all over the place(ssh to the router is a very very difficult). 2.4Ghz seems to work better, just the occasional hiccup.
On 5GHz I use 3 devices:

  • one laptop with Marvel Avastar 802.11AC network card -> Wifi is not usable
  • one phone with Qualcomm QCA 802.11AC wifi -> much better throughput in the speed test but latency is still very bad.
  • one other laptop with bcm43xx network card 802.11AN wifi(wl driver) -> sometimes it can't even connect to WiFi 5Ghz
    The current snapshot running 4.19 kernel has exactly the same problem.

Since I was sure at some point the wifi was fine I started bisecting the 19.07 branch for every kernel version bump.
The latest working and building commit has is 6ac1aa19579ddbee922ea5b89d7398f527baabd8:

kernel: bump 4.14 to 4.14.152

At the next bump with hash db345220b485ce3e20642bd1fbf9b65d5f1cd4f1

kernel: bump 4.14 to 4.14.155
I start experience the problems listed above.

Now between these 2 commits I see updates to mac80211, hostapd and wpad, and even a gcc bump. But there is quite a big number of commits and very time consuming to test each one, does anybody with more experience have any idea how I could narrow down the problem?
At this point 19.07 is not usable at all.

1 Like

git bisect

(Though I'd look at changes to the ath10k-CT package first.)

I'm basically bisecting now, but it takes quite a long time because I have no idea what I'm looking for, so I need to rebuild everything flash and test again. On top of that this is my main router so it's also a bit annoying.

As far as I can tell ath10k-ct has no changes between the 2 commits I mentioned, the -ct firmware also seems to be exactly the same.

After reverting the hostapd-2.9 version update the wifi is back working correctly again.

1 Like

I have no problems on NBG6617 with hostapd-2.9 so far.

Which wireless card do you have on you computer? ac or na? On my phone who has a QCA 802.11ac card is not that noticeable but on the computer with Marvel 802.11ac it's not usable.

I have a few laptops with various Intel ac devices and a few Android 802.11ac devices. I didn't check which wireless chips are in Android ones.

Which wireless channel are you using and what country is set?

Wireless channel is set to auto(it selects 52 usually) and country to FI.

The Marvell Avastar 802.11ac has not been great in the past because of terrible drivers, but recently it has improved. Without hostapd 2.9 I can max out my upstream ISP bandwidth on a speed test. As far as I can tell it reaches the max VHT MCS rate but the throughput never goes past 15Mbps

52 is a DFS channel. Try to set 36 manually.

Already tried that, didn't change anything, besides starting the 5G network faster at boot.

Starting faster on non-DFS is expected.

Are you using default package set of did you install anything like wpad-full?

Did you look into system log?

I got the default packages, so CONFIG_DEFAULT_wpad-basic=y
But I started using the the rc2 official build first with the same issue.

I tried both the ath10k and ath10k-ct with all the firmwares available(ct and official). Nothing strange in the syslog except a lot of disconnect from the laptop with the Broadcom 802.11an card repeatedly trying to connect.

The only warning? I've seen in kernel log related to the 5G network was this:
ath10k_ahb a800000.wifi: Invalid VHT mcs 15 peer stats
but I'm not sure it's an error or a warning.

I have this too. It doesn't affect anything.

I don't have any Broadcom or marvel clients.

Try to connect only one device at a time.

Just to add to the information here - I experienced similar issues with an Archer C7 V2 on 5 GHz with a MS Surface client (Marvel Avastar 802.11ac device). See my bug report at FS#2563. I was seeing high (but useable) latency prior to the change I bisected to on 11 Sep 2019, after that date the latency went to seconds and stopped the MS surface doing anything sensible.

The hostapd 2.9 update happened on 10 Aug 2019. I suspect that this indeed was the cause of the issue but was unable to revert the change in later snapshots.

I'm also using the surface client, so that seems like a common issue. I made bug a report at FS#2679 and at least one more person has the exact same issue on the Archer C7 v2 @systemcrash If you are willing to try I made for him a build of 19.07 with hostapd 2.8. He had some problems with the openwrt configuration but my build seemed to boot and work somewhat. If it's not your primary router maybe you can give it a try.

Maybe @systemcrash sees the ping in this message and can chime in with some update.

Message received. Will give your build another try (just requires re-working the radio config). Going to give 19.07.0 a try first - see if there are any improvements there.

Edit: 19.07.0 - still shit on 5GHz.

Edit 2: @hgblob 19.07.0-rc2 custom build - check your inbox - could not get 5GHz online.

1 Like

I use the Archer C7 as one of two AP-only devices in the house. It will be no problem to try your build.

I have a pair of EA6350 v3. I started using them only recently as a simple wireless access point, wired to another openwrt router. I installed 19.07.0-rc2 and also tried NotTengoBattery v0.30.

Everything was working fine (apart from some minor ping latency issues) until I stumbled across transfer speed problems with Intel Centrino 6300 802.11n (3x3) wifi cards. Speeds were capped to 12-15 Mbps on different model Dell Windows 10 laptops on both 2.4 and 5 GHz bands even though wireless link speed is shown as 300 Mbps on 5 GHz band. Same for Intel 6205 (2x2) card which uses same windows wifi driver.

There are no speed problems when using older Intel 6200 card (uses older driver) and later 7260 N and AC cards (newer driver).

After reading this thread, I flashed older 19.07-r10293 snapshot (kernel 4.14.136, hostapd-common: 2018-12-02-c2c6c01b-6) and transfer speeds with Intel 6300 wifi card are back to normal. ie. not capped at 12-15 Mbps.


I also quickly tested 19.07.0-rc1 with hostapd-common: 2018-12-02-c2c6c01b-9 still suffers from same problem.