Internet Connection Issue through LAN, no prob through WiFi

Hi all. I'd like to ask help for my STRANGE situation I'm experiencing.
I have a TP-LINK TD-W8970 with OpenWRT already running the last available version (OpenWrt 19.07.4 r11208-ce6496d796). I set it up through the user-guide and it was working very well. My home config is the following:
Internet operator Router set as pure modem (PPPOE, bridged+routed, no dhcp, NAT active, DNS active)
Ubiquity EdgeRouter X acting as the main router (PPPOE, DHCP, NAT active, gateway)
TP-LINK switch TL-SG108E
TD-W8970 w/original fw acting as AP connected to the main router through power-line
TD-W8970 w/OpenWRT actually connected through the TP-LINK Switch (LAN interface set as Static IP in the same subnet as the main router, bridge, no dhcp, default firewall active for lan interface, Internet operator's DNS was input specificly; default WAN interface inactive; default WAN6 interface inactive; Wireless interface active acting as AP).

Since one month ago my config was working correctly, can connect to the WiFi and able to reach the internet, can connect to the LAN through one of the free eth ports in my OpenWRT device and able to reach the internet, the OpenWRT device was able to reach the internet itself.

Yesterday something happened.....the situation was almost the same unless the OpenWRT device could not reach the internet (opkg update failed, ping failed, etc). I didn't know what do
until I tried to adjust DNS settings and, here is, the strange thing (at least for me that I'm not an IT or NETWORK expert). I changed the DNS address (copying them from my "modem" settings page) and it worked again. WHY, the internet connection is available for devices connected through eth ports or wireless but not for the OpenWRT device itself? Unless I change the DNS address?

Sorry for the exhausting explanation, I tried to give as many info as I could to explain my situation.


DNS settings were hard-coded on the openwrt unit, while the other devices used the ones provided by the ISP via DHCP.

If the ISP changes the DNS IPs, all units with DHCP will change accordingly, devices with static DNS settings will not.


Ciao frollic.
Many thanks for your hint. I understood it but what I still cannot understand is that if I leave the DNS empty on OpenWRT the devices connected to it can still reach the internet but OpenWRT itself cannot. How can I overcome the situation to update OpenWRT DNS every time there's a change in my ISP's "modem"?

If your device have nothing to do with the internet access, then it's just a transport.

You could set up your OpenWRT unit completely up the wall, but as long it doesn't
act as a router, or firewall (where IPs have to be "correct" or "sane"), everything will
still work, except for the internet access for the OpenWRT unit itself.

You could put a static lease in your DHCP for your unit, so it always gets the same IP,
and the newest DNS settings along with them.
Or you could set it to use a public DNS like googles -, it's usually up :wink:


GREAT! Thanks frollic. It's working. I understood your hint and, having left my OpenWRT with Static IP, I changed the DNS with OpenDNS ones. I thought that I was forced to leave my ISP's DNS instead putting the new ones both wired and wireless devices are able to reach the internet and OpenWRT device too. For sure it would work also the other solution putting the interface as Client DHCP but, for now, I don't want to try, I have to solve another issue with samba shares not accessable by W10 or Linux...... See you maybe in another thread. THANKS THANKS THANKS

In win10 you manually have to enable legacy samba support, it's disabled by default :wink:

Mark your topic as solved - How to mark a topic as [Solved]

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.