Installing unbound stops DNS

I've been using unbound as a recursive DNS server on my router for a long time. Rebuilding today using the latest snapshot, I found that the package was renamed to unbound-daemon.

Oddly, as soon as I installed unbound-daemon, without even starting it, dhcp provided DNS queries fails. Removing it, DNS resolv works again.
Further, the service won't start anyhow. the log shows; 'openwrt unbound s in a crash loop'

Sun Jun 16 22:47:01 2019 procd: Instance unbound::unbound s in a crash loop 6 crashes, 0 seconds since last crash
Mon Jun 17 00:04:04 2019 procd: Instance unbound::unbound s in a crash loop 7 crashes, 0 seconds since last crash

The config is 100% identical to the one that was already working.

Looking online, I cannot find any kind of solution for this. I want unbound to be a recursive dns stand alone server that does not use the local or forwarded DNS servers but I want the router to use the local dhcp dns servers.

There must be a directive or two that I am not seeing in the config file that is overriding the dhcp dns servers when installed.

unbound logs would be helpful

I'd also start with a bone-stock configuration and confirm that it works.

I cannot get logs since the service won't start. All I can get is the logread info.
It is also a new firmware install, very minimal.

This is again one of those things where if it is seemingly working for everyone else but failing for you, it's time to at least see if you can do what they do.

I'm not sure what this means but sure, I'm learning so always trying to figure things out.
I found an older version that installs and it does exactly the same thing, not starting.

I'm not doing anything unusual that I know of, just building a pretty minimal fw.

In as far as why dns stops, it's because the service is not starting and when installing unbound or unbound/daemon, it overwrites the /etc/resov.conf.

nameserver ::1
search lan.

This is easily understood. However, why the service is not starting is not easily understood. I will also have to find an option to prevent unbound from overwriting the dhcp server dns servers.

Apparently you are, or the package would be broadly reported as broken.

Second that, if there are no reports about this type of problem, than it is probably somewhere at your end.

Using Unbound myself as well here, no issues with the package on 19.07 (which at this point still looks pretty much like master).

Have you changed dnsmasq's listening port before starting unbound?

People post when they are experiencing problems not when all of the other things they are doing are working fine.

I don't think I'm not the only one seeing this (or has) but it does seem to be rare.
I searched this;
openwrt 'unbound s in a crash loop'
While there are some google results, there is not enough for me to solve the problem which is why I posted.

I cannot say why this is happening, it's a brand new very minimal build. I tried with both the latest unbound-daemon and now unbound - 1.9.1-3 mipsel.

Neither starts and both output the same errors which means to me something about the build is not right or some sort of rare conflict with packages. No idea why which is why I am asking here for leads. Happy to provide what ever info is needed.

By the way, I also tried installing using opkg and it didn't warn of any missing packages.

dnsmasq did not install automatically as a dependency package and also isn't needed for unbound to simply act as a dns server since on my other device, it works just fine simply installed and nothing more than starting the service.

The one that has no problems is OpenWrt 18.06.2, r7676-cddd7b4c77. No dnsmasq and works perfectly as a DNS server.

The one having problems is OpenWrt SNAPSHOT, r10231-1fd900d. No dnsmaqs but service won't start.

I disagree wtih your assessment of @JoshGrant's issue.

I've been having issues with snmpd randomly crash looping with certain snapshot installs as well.

Perhaps it's not the individual packages (i.e. snmpd or unbound), but a boot script, interface scrip or something?

I find it hard to believe it's just me.

Now I just downloaded the snapshot again and am trying to build but keep getting errors for over an hour now.

make image PROFILE="gl-mt300n-v2"
and get this...

Installing packages...
Installing libc (1.1.22-1) to root...
Installing libgcc1 (7.4.0-1) to root...
Configuring libgcc1.
Configuring libc.
Installing kernel (4.14.125-1-e12d1ba9b9a71c449bb345046c7edbf7) to root...
Configuring kernel.
Installing base-files (198-r10242-3c401f45c9) to root...
Unknown package 'busybox'.
Unknown package 'dnsmasq'.
Unknown package 'dropbear'.
Unknown package 'firewall'.
Installing fstools (2019-03-28-ff1ded63-4) to root...
Installing ip6tables (1.8.2-3) to root...


Needless to day, it just fails. My network/dns are working fine so it's not a matter of not being able to reach the repo. Just another fun thing that seems to only happen to me :).

New download, unpack and 'make image'

Downloading file:packages/kmod-usb-ehci_4.14.125-1_mipsel_24kc.ipk
Package libc (1.1.22-1) installed in root is up to date.
Package libgcc1 (7.4.0-1) installed in root is up to date.
Unknown package 'logd'.
Installing mtd (24) to root...
Copying /clients/openwrt-imagebuilder-ramips-mt76x8.Linux-x86_64/dl/mtd_24_mipsel_24kc.ipk.
Unknown package 'netifd'.
Unknown package 'odhcp6c'.
Unknown package 'odhcpd-ipv6only'.
Unknown package 'opkg'.
Unknown package 'ppp'.
Unknown package 'ppp-mod-pppoe'.
Unknown package 'swconfig'.
Unknown package 'uci'.
Unknown package 'uclient-fetch'.
Unknown package 'urandom-seed'.
Unknown package 'urngd'.
Unknown package 'wpad-basic'.

Is it possible something is not getting downloaded which is breaking other packages? Maybe the builder is not recognizing the missing deps?

OK, this is slightly different than my issue...I'm not compiling firmware then attempting to use official repos.

@JoshGrant, what happens when you use the snapshots from the official downloads site?

This is where I'm downloading from. Isn't this the official site?

Is there's a pre-compiled firmware?

Not one that you biuld.

Yes, they always have it but I want to build my own since I don't use all of the pre-installed packages.
Still, currious why I've not been able to build, all morning so far.

Is it my machine, maybe something new to be installed/required on it to build or is it something with the repo?

So this means you're not gonna try it?


Apparently a few glitches at the moment.

There are no packages installed in snapshot, other than required defaults(not even LuCI). But, it should be six of one, half a dozen of the other, between imagebuilder and snapshot, both of the same vintage.

@ lleachii
Not sure what you mean 'not gonna try'.
Yes, it's what I first used to convert the router to default openwrt and now want to use image generator to build my own.

1 Like

By doing so, I was attempting to see if it occurred on both.

I understand now.